Foros del Web » Creando para Internet » HTML »

problemas con marquee

Estas en el tema de problemas con marquee en el foro de HTML en Foros del Web. Hola a todos, mTengo un problema con el marquee y es que cuando pongo un texto muy largo me aprece dividido en renglones. es decir ...
  #1 (permalink)  
Antiguo 13/10/2008, 14:35
 
Fecha de Ingreso: diciembre-2007
Mensajes: 274
Antigüedad: 10 años
Puntos: 0
problemas con marquee

Hola a todos,

mTengo un problema con el marquee y es que cuando pongo un texto muy largo me aprece dividido en renglones.

es decir

<marquee>hola</marquee>

devuelve : hola (en movimiento)

<marquee>Hola a todos, me llamo lucas, vivo en argentina y bla bla bla</marquee>

devueve:
Hola a todos, mellamo lucas vivo en
argentina y bla bla bla


como hago para que no me ponga uno abajo del otro

mi codigo, lo pongo por si es eso el problema es

Código HTML:
<marquee onMouseOver="this.stop()" onMouseOut="this.start()" scrollamount="2" scrolldelay="80" direction="left" align="center" height="20"> <table width="632" border="0" cellpadding="5" cellspacing="0">
         <tr>
        <td>&nbsp;</td>
        <td>
<a href='?incluir=todanoticia.phpnoticiaid='>sssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss </a></td>
      </tr>
  </table> </marquee> 

¿Entienden lo que digo o lo especifico mejor?

si alguien pude ayudarme se lo agradeceria

Última edición por luks77; 13/10/2008 a las 16:28
  #2 (permalink)  
Antiguo 13/10/2008, 17:13
Avatar de ElJavista
Colaborador
 
Fecha de Ingreso: marzo-2007
Ubicación: Lima Perú
Mensajes: 2.231
Antigüedad: 10 años, 9 meses
Puntos: 67
Respuesta: problemas con marquee

OK, ese problema tiene una solución muy sencilla, en realidad hay otras más, pero esta es la más fácil que conozco. Si necesitas escribir una frase larga, entonces no uses los espacios comunes, usa espacios HTML, de este modo:

esto&nbsp;es&nbsp;una&nbsp;frase&nbsp;muy&nbsp;lar ga

De ese modo todo el texto se interpretará como un solo bloque y no hará el salto de línea.
  #3 (permalink)  
Antiguo 13/10/2008, 18:43
 
Fecha de Ingreso: diciembre-2007
Mensajes: 274
Antigüedad: 10 años
Puntos: 0
Respuesta: problemas con marquee

Si el problema es que en verdad son datos recuperados por la BD (Base de datos) entonces no le puedo poner &nbsp; a cada uno, no abra otra forma o alguna manera de agregar eso de la base de datos¿?
  #4 (permalink)  
Antiguo 15/10/2008, 15:35
Avatar de ElJavista
Colaborador
 
Fecha de Ingreso: marzo-2007
Ubicación: Lima Perú
Mensajes: 2.231
Antigüedad: 10 años, 9 meses
Puntos: 67
Respuesta: problemas con marquee

Pues si las frases son recuperadas de la Base de Datos no hay ningún problema? donde está tu ingenio? Basta con esto:

$frase = str_replace(" ", "&nbsp;", $frase);
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:39.