Foros del Web » Creando para Internet » HTML »

Problemas con navegadores

Estas en el tema de Problemas con navegadores en el foro de HTML en Foros del Web. Hola a todos, Os escribo porqué estoy haciendo mi primera web y tengo bastantes problemas para que se me visualicen todos más o menos bien. ...
  #1 (permalink)  
Antiguo 30/03/2011, 02:13
Avatar de sergi_multimedia  
Fecha de Ingreso: noviembre-2010
Mensajes: 213
Antigüedad: 7 años
Puntos: 4
Pregunta Problemas con navegadores

Hola a todos,

Os escribo porqué estoy haciendo mi primera web y tengo bastantes problemas para que se me visualicen todos más o menos bien. La verdad es que con Safari y Chrome se me ve sin ningún fallo aparente.

El problema viene con FireFox 4, Firefox 3 y cualquiera de los Internet Explorer.

La web es sencilla, he utilizado XHTML 1.0 y CSS, así que supongo que tendrá los errores más comunes (creo).

Antes que nada me gustaría preguntar como puedo solucionar esto:

[url=http://www.flickr.com/photos/sbeltranprat/5573651808/][img]http://farm6.static.flickr.com/5054/5573651808_8221699bd6_z.jpg[/img][/url]

Cuando ya no hay más puertas pero quiero mantener la estructura de la lista pongo esto en el código:
Código HTML:
Ver original
  1. <li><img src="" alt="" width="120" height="285"/></li>

Aquí tenéis un enlance de la web:

[URL="http://s310876771.mialojamiento.es/productes/portadeza.html"]http://s310876771.mialojamiento.es/productes/portadeza.html[/URL]

¿Como puedo evitar que se me vea el rectángulo vacío? ¿La única solución es poner una imagen del mismo color del fondo?

Bien, ahora comento los principales problemas con los navegadores:

En Internet Explorer i Firefox 3 en las imagenes me ocurre esto:

[url=http://www.flickr.com/photos/sbeltranprat/5573086027/][img]http://farm6.static.flickr.com/5145/5573086027_34ce7613dc.jpg[/img][/url]

Me sale un contorno en las imágenes que tienen un enlace, ¿como lo soluciono?

Otro problema y el más "grave" ha sido con las listas donde pongo las imágenes.

Safari y Chrome

[url=http://www.flickr.com/photos/sbeltranprat/5573095073/][img]http://farm6.static.flickr.com/5174/5573095073_78d9306490_z.jpg[/img][/url]

Perfecto (excepto la puerta vacía que he comentado anteriormente)

FireFox 4

[url=http://www.flickr.com/photos/sbeltranprat/5573686824/][img]http://farm6.static.flickr.com/5299/5573686824_78ceb4e59a.jpg[/img][/url]

Aquí podemos ver como se me ha desmontado un poco la estructura, la puerta vacía que estaba la derecho en safari y Chrome ahora está a la izquierda, y la descripción vacío con un guionito está debajo de una puerta que no le corresponde.

FireFox 3 y Internet Explorer

[url=http://www.flickr.com/photos/sbeltranprat/5573696128/][img]http://farm6.static.flickr.com/5263/5573696128_7071bf2469.jpg[/img][/url]

Como se puede observar está todo desmontado, es un desastre!

Aquí os vuelvo a poner el enlace para que podáis ver el código entero:

[URL="http://s310876771.mialojamiento.es/productes/portadeza.html"]http://s310876771.mialojamiento.es/productes/portadeza.html[/URL]

Y por último quería comentar una cosa en referencia a las fuentes. En Safari, Chrome y FireFox 4 (Mac) las fuentes se ven respetando las fuentes. Pero luego he visto en Firefox 3 y Internet Explorer (win) que las fuentes se me ven horribles, muy delgadas, sin estilo, y yo he puesto de tipo de letras en la web Tahoma o Verdana, fuentes que el ordenador de Win tiene, a que se debe?

Perdonar por el rollazo este, y gracias de antemano.
  #2 (permalink)  
Antiguo 30/03/2011, 02:14
Avatar de sergi_multimedia  
Fecha de Ingreso: noviembre-2010
Mensajes: 213
Antigüedad: 7 años
Puntos: 4
Respuesta: Problemas con navegadores

Quería editar y me he equivocado...¬¬
  #3 (permalink)  
Antiguo 30/03/2011, 02:17
Avatar de sergi_multimedia  
Fecha de Ingreso: noviembre-2010
Mensajes: 213
Antigüedad: 7 años
Puntos: 4
Respuesta: Problemas con navegadores

Cita:
Iniciado por sergi_multimedia Ver Mensaje
Hola a todos,

Os escribo porqué estoy haciendo mi primera web y tengo bastantes problemas para que se me visualicen todos más o menos bien. La verdad es que con Safari y Chrome se me ve sin ningún fallo aparente.

El problema viene con FireFox 4, Firefox 3 y cualquiera de los Internet Explorer.

La web es sencilla, he utilizado XHTML 1.0 y CSS, así que supongo que tendrá los errores más comunes (creo).

Antes que nada me gustaría preguntar como puedo solucionar esto:

[url=http://www.flickr.com/photos/sbeltranprat/5573651808/][img]http://farm6.static.flickr.com/5054/5573651808_8221699bd6_z.jpg[/img][/url]

Cuando ya no hay más puertas pero quiero mantener la estructura de la lista pongo esto en el código:
Código HTML:
Ver original
  1. <li><img src="" alt="" width="120" height="285"/></li>

Aquí tenéis un enlance de la web:

[URL="http://s310876771.mialojamiento.es/productes/portadeza.html"]http://s310876771.mialojamiento.es/productes/portadeza.html[/URL]

¿Como puedo evitar que se me vea el rectángulo vacío? ¿La única solución es poner una imagen del mismo color del fondo?

Bien, ahora comento los principales problemas con los navegadores:

En Internet Explorer i Firefox 3 en las imagenes me ocurre esto:

[url=http://www.flickr.com/photos/sbeltranprat/5573086027/][img]http://farm6.static.flickr.com/5145/5573086027_34ce7613dc.jpg[/img][/url]

Me sale un contorno en las imágenes que tienen un enlace, ¿como lo soluciono?

Otro problema y el más "grave" ha sido con las listas donde pongo las imágenes.

Safari y Chrome

[url=http://www.flickr.com/photos/sbeltranprat/5573095073/][img]http://farm6.static.flickr.com/5174/5573095073_78d9306490_z.jpg[/img][/url]

Perfecto (excepto la puerta vacía que he comentado anteriormente)

FireFox 4

[url=http://www.flickr.com/photos/sbeltranprat/5573686824/][img]http://farm6.static.flickr.com/5299/5573686824_78ceb4e59a.jpg[/img][/url]

Aquí podemos ver como se me ha desmontado un poco la estructura, la puerta vacía que estaba la derecho en safari y Chrome ahora está a la izquierda, y la descripción vacío con un guionito está debajo de una puerta que no le corresponde.

FireFox 3 y Internet Explorer

[url=http://www.flickr.com/photos/sbeltranprat/5573696128/][img]http://farm6.static.flickr.com/5263/5573696128_7071bf2469.jpg[/img][/url]

Como se puede observar está todo desmontado, es un desastre!

Aquí os vuelvo a poner el enlace para que podáis ver el código entero:

[URL="http://s310876771.mialojamiento.es/productes/portadeza.html"]http://s310876771.mialojamiento.es/productes/portadeza.html[/URL]

Y por último quería comentar una cosa en referencia a las fuentes. En Safari, Chrome y FireFox 4 (Mac) las fuentes se ven respetando las fuentes. Pero luego he visto en Firefox 3 y Internet Explorer (win) que las fuentes se me ven horribles, muy delgadas, sin estilo, y yo he puesto de tipo de letras en la web Tahoma o Verdana, fuentes que el ordenador de Win tiene, a que se debe?

Perdonar por el rollazo este, y gracias de antemano.
  #4 (permalink)  
Antiguo 30/03/2011, 02:20
Avatar de sergi_multimedia  
Fecha de Ingreso: noviembre-2010
Mensajes: 213
Antigüedad: 7 años
Puntos: 4
Respuesta: Problemas con navegadores

PORQUÉ NO SE ME VEN LAS IMAGENES QUE SI QUE SE ME VEN EN VISTA PREVIA

Qué rabia dios, yo mirando se ponerlo todo bien y luego me sale una chusta...
  #5 (permalink)  
Antiguo 30/03/2011, 05:31
 
Fecha de Ingreso: marzo-2011
Mensajes: 119
Antigüedad: 6 años, 9 meses
Puntos: 9
Respuesta: Problemas con navegadores

Hola

sobre las fuenets utiliza @font-face en el css , sobre las imagene sme gustari a ayudarte pero no puedo ver las url que has dejado
  #6 (permalink)  
Antiguo 30/03/2011, 05:39
Avatar de sergi_multimedia  
Fecha de Ingreso: noviembre-2010
Mensajes: 213
Antigüedad: 7 años
Puntos: 4
Respuesta: Problemas con navegadores

Cita:
Iniciado por saul123 Ver Mensaje
Hola

sobre las fuenets utiliza @font-face en el css , sobre las imagene sme gustari a ayudarte pero no puedo ver las url que has dejado
Gracias por contestar saul123,

Esto que me dices de la fuentes que tendría que poner así?
Código CSS:
Ver original
  1. @font-face: tahoma, verdana, "sans-serif";

Safari y Chrome

http://farm6.static.flickr.com/5174/5573095073_78d9306490_z.jpg

FireFox 4

http://farm6.static.flickr.com/5299/5573686824_78ceb4e59a.jpg

FireFox 3 y Internet Explorer

http://farm6.static.flickr.com/5263/5573696128_7071bf2469.jpg


Enlace de la web para que puedas verla:

http://s310876771.mialojamiento.es/productes/portadeza.html

Etiquetas: navegadores
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:38.