Foros del Web » Creando para Internet » HTML »

Problemas al validar XHTML con W3C

Estas en el tema de Problemas al validar XHTML con W3C en el foro de HTML en Foros del Web. Muy buenas, Resulta que estoy intentando validar una pagina web que genero mediante C# en la que hago una transformacion XSLT. Al ejecutar la aplicacion ...
  #1 (permalink)  
Antiguo 12/06/2009, 03:42
 
Fecha de Ingreso: mayo-2009
Mensajes: 42
Antigüedad: 8 años, 6 meses
Puntos: 1
Problemas al validar XHTML con W3C

Muy buenas,

Resulta que estoy intentando validar una pagina web que genero mediante C# en la que hago una transformacion XSLT.

Al ejecutar la aplicacion me genera dicha transformacion y su consecuente pagina Web. Todo me lo muestra correctamente, el problema viene cuando intento validarla con el W3C y me ocurren cosas raras.

Si veo el codigo fuente que me ha generado en la web veo que me ha puesto 2 DOCTYPE con 2 etiquetas html y head body etc.
La verdad, no entiendo por que ni de donde salen.

En mi plantilla xsl no digo en ningun sitio que me genere tales etiquetas repetidas.


Alguien sabria ayudarme pq me genera ese codigo de mas cuando hago la transformacion XSLT?

Un saludo y gracias de antemano.
  #2 (permalink)  
Antiguo 12/06/2009, 05:54
Avatar de PatomaS
Colaborador
 
Fecha de Ingreso: marzo-2004
Ubicación: En alguna otra parte
Mensajes: 4.656
Antigüedad: 13 años, 9 meses
Puntos: 63
Respuesta: Problemas al validar XHTML con W3C

Hola

Tu problema no tiene que ver con la validación de la página, tu problema está en el código en C# o en el xslt.

Tu problema está en la cuarta línea de la transformación, justo después de tercer espacio en blanco.

Felicidad

P.D.

Si, mi respuesta no tiene sentido, pero es que no soy medium para saber tus códigos. Si estás seguro de que tu problema no es del xslt, será del C#, así que mejor revisas si tienes algún bucle, algún parámetro extra o algo por el estilo, si no ves nada, pásate por el subforo de programación y pregunta allí.

Si el código de C# no tiene nada malo, pásate por el de xml para que te revisen la transformación.
__________________
¡ hey, hou, hou, hey !
  #3 (permalink)  
Antiguo 12/06/2009, 06:02
 
Fecha de Ingreso: mayo-2009
Mensajes: 42
Antigüedad: 8 años, 6 meses
Puntos: 1
Respuesta: Problemas al validar XHTML con W3C

Buenas,

No pude copiar el codigo realizado porque al ser nuevo usuario no me deja copiarlo (o eso me ponia en el mensaje cuando daba a Enviar Respuesta)

Aun así voy a intentar mandartelo por mensaje privado a ver si me puedes echar una mano.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:45.