Foros del Web » Creando para Internet » HTML »

problemas al ver imágenes con explorer

Estas en el tema de problemas al ver imágenes con explorer en el foro de HTML en Foros del Web. Hola gente tengo un problema de lo más raro, resulta que estoy haciendo una web y en la cabecera con css pongo un fondo que ...
  #1 (permalink)  
Antiguo 05/03/2009, 09:46
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 15 años, 5 meses
Puntos: 8
problemas al ver imágenes con explorer

Hola gente tengo un problema de lo más raro, resulta que estoy haciendo una web y en la cabecera con css pongo un fondo que es una preciosa foto de la alhambra de Granada, el tema es que con explorer NO SE VE y con MOZILLA SI ¿cual puede ser el problema?, es curioso porque si la ruta de la imagen estuviera mal (que fué lo primero que pensé) entonces no se mostraría tampoco con mozilla por lo que se me han acabado las ideas, otra cosa , dreamweaver tampoco me muestra la imagen en la cabecera cuando la inserto y es muy muy raro ¿alguna idea?. Mil gracias

Css donde pongo el fondo:
Código:
#header{height:190px; border:#009900 0px solid; background-image:url(images/portada/alahambra.jpg) }
No sabía si poner esto en el foro de Css o en este .

He probado (para descartar que fuera cosa del Css ) ha meter la capa dentro de una table y darle a esta el fondo de la imagen:
pero tampoco funciona , de este modo en plan cutre (jejejej)
Código:
<table background="http://www.forosdelweb.com/images/portada/alahambra.jpg" >
<tr><td>
<div id="header"  >

<div id="banner" align="center"><img src="http://www.forosdelweb.com/images/portada/texto.gif" alt="header" width="623" height="128" /></div>
<div id="langs"> 
	<ul>
	<li> 
	<a href="hojas/see.htm" target="_self" ><img src="http://www.forosdelweb.com/images/sas.gif"  border="0"  alt="Granada"/></a> 
	</li>
	<li>
	<a href="hojas/uk/eegng.htm" target="_self" ><img src="http://www.forosdelweb.com/images/uddg.gif"  border="0" alt="Granada" /></a>	
	</li>
	</ul> 
 </div>
</div>
</tr></td>
</table>
Esto ha sido probado con
IE7 y con mozilla y con el primero no se ve la imagen de la que hablamos.
Un saludo y gracias de antemano a [email protected]

Última edición por Dundee; 05/03/2009 a las 09:54 Razón: añadir cosas
  #2 (permalink)  
Antiguo 05/03/2009, 10:23
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: problemas al ver imágenes con explorer

¿#header tiene algún tamaño de ancho? Al menos aquí no

#header{height:190px; border:#009900 0px solid; background-image:url(images/portada/alahambra.jpg) }

Prueba a ver así:
#header{height:190px; width: 600px; border:#009900 0px solid; background: url(images/portada/alahambra.jpg) no-repeat; }
__________________
Visita mi nueva web idplus.org
  #3 (permalink)  
Antiguo 05/03/2009, 10:50
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 15 años, 5 meses
Puntos: 8
Respuesta: problemas al ver imágenes con explorer

Cita:
Iniciado por Mikmoro Ver Mensaje
¿#header tiene algún tamaño de ancho? Al menos aquí no

#header{height:190px; border:#009900 0px solid; background-image:url(images/portada/alahambra.jpg) }

Prueba a ver así:
#header{height:190px; width: 600px; border:#009900 0px solid; background: url(images/portada/alahambra.jpg) no-repeat; }
No no tiene ningún ancho pero aún así no funciona:

#header{height:190px; width:600px; border:#009900 0px solid; background-image:url(images/portada/alahambra.jpg) ; background-color:#FFF}

Como ya he comentado antes , he probado metiendo todo dentro de una tabla y dándole un fondo con alto y ancho y no funciona tampoco.

SOLUCIONADO A MEDIAs: El tema es que he probado a hacer lo mismo con otras imágenes , (recortarlas con photoshop para mi header) y funciona perfectamente , es decir se ven en mozilla y explorer ¿que raro no? , ¿como puede ser que una imagen en concreto no la quiera el explorer?? ¿tiene esto alguna explicación?.


_Un saludo y gracias

Última edición por Dundee; 05/03/2009 a las 11:04
  #4 (permalink)  
Antiguo 05/03/2009, 12:50
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Respuesta: problemas al ver imágenes con explorer

puedes colgar un enlace a la página, es que así solo vemos una parte del código, además puede que tu imagen esté a más pixeles de lo que debería; te has fijado si está a 600ppp o más?
__________________
Al final del día hablar es gratis, codificar no lo es
  #5 (permalink)  
Antiguo 05/03/2009, 13:40
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 15 años, 5 meses
Puntos: 8
Respuesta: problemas al ver imágenes con explorer

Cita:
Iniciado por baccxus Ver Mensaje
puedes colgar un enlace a la página, es que así solo vemos una parte del código, además puede que tu imagen esté a más pixeles de lo que debería; te has fijado si está a 600ppp o más?
Bueno en la web ya he puesto otra y va de maravilla , pero ¿es posible que una imagen que tenga más de 600 ppp (supongo que serán píxeles por pulgada) no se vea en explorer y en mozilla si , ¿porque? ¿cual es la explicación?..


Gracias de antemano
  #6 (permalink)  
Antiguo 05/03/2009, 15:43
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Respuesta: problemas al ver imágenes con explorer

Hace años había ese problema (win 98/explorer 4 y 5), pero buscando y leyendo no he visto que se haga referencia a este error en navegadores actuales, sin embargo hay una referencia en soporte/microsoft en el que hablan de este tema, pero como te digo navegadores viejos y sistemas operativos viejos.

http://support.microsoft.com/kb/181836/es
__________________
Al final del día hablar es gratis, codificar no lo es
  #7 (permalink)  
Antiguo 05/03/2009, 15:44
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Respuesta: problemas al ver imágenes con explorer

Se me duplicó la respuesta!
__________________
Al final del día hablar es gratis, codificar no lo es

Última edición por baccxus; 05/03/2009 a las 15:47 Razón: duplicado
  #8 (permalink)  
Antiguo 06/03/2009, 01:24
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 15 años, 5 meses
Puntos: 8
Respuesta: problemas al ver imágenes con explorer

Ok Gracias.
  #9 (permalink)  
Antiguo 18/03/2009, 12:52
 
Fecha de Ingreso: marzo-2009
Mensajes: 1
Antigüedad: 8 años, 8 meses
Puntos: 0
Respuesta: problemas al ver imágenes con explorer

A mi me ha pasado lo mismo. un moton de jpg recien creaditos en el photoshop y no se veian en la web con Internet Ecplorer.

Los probe de guardar desde Otra aplicacion, fireworks en mi caso y voila se hizo la luz.

me fije que el photoshop les escribe al principio del fichero una cabera rara y muy larga.


Espero que os sirva de ayuda
  #10 (permalink)  
Antiguo 18/03/2009, 13:10
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Respuesta: problemas al ver imágenes con explorer

Puede ser también lo que dice pacodm, a veces en programas como photoshop usamos configuraciones diferentes de color, o trabajamos en CMYK y cuando lo exportamos se nos van así mismo como lo editamos.

Lo mejor es usar "save for webs & devices"(cntrl + alt + shift + s) que está en el menú file.

Saludos
__________________
Al final del día hablar es gratis, codificar no lo es
  #11 (permalink)  
Antiguo 18/03/2009, 15:00
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 15 años, 5 meses
Puntos: 8
Respuesta: problemas al ver imágenes con explorer

Ok , gracias ,creo que va a ser algo de eso.

Un saludo y gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:06.