Foros del Web » Creando para Internet » HTML »

Problemas al visulizar mi página

Estas en el tema de Problemas al visulizar mi página en el foro de HTML en Foros del Web. Hola: Estoy haciendo una página web, en xhtml 1.1 y hoja de estilo css. Lo que voy haciendo de la página lo valido en w3c. ...
  #1 (permalink)  
Antiguo 01/02/2007, 12:13
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Problemas al visulizar mi página

Hola:

Estoy haciendo una página web, en xhtml 1.1 y hoja de estilo css. Lo que voy haciendo de la página lo valido en w3c.

El problema es que al visualizarla en ciertos ordenadores no aparece bien.

Para que os hagáis a una idea, la página web, tiene un menú a la izquierda, el cual, tiene una pequeña distancia con el borde izquierdo, para que las letras no estén tan pegadas al borde. Pues ese margen, no me aparece en algunos ordenadores. Y ese menú, tiene unas viñetas, que en realidad son imágenes de fondo, y también no parecen en algunos ordenadores:

background-repeat: no-repeat;
background-position:center left;
background-image: url('imagenes/flecha-n-trans.gif');


Lo que se me ocurre que puede ser, es que sea incompatible con el internet explorer 6, ¿puedo ser eso? Y si es eso, ¿tendrá alguna solución? (que no sea cambiar xhtml por html, claro).

Gracias.
  #2 (permalink)  
Antiguo 01/02/2007, 12:25
Avatar de _alvaro_  
Fecha de Ingreso: diciembre-2005
Mensajes: 18
Antigüedad: 12 años
Puntos: 0
Re: Problemas al visulizar mi página

yo de ti mejor lo hago con css, pero no te olvides de relacionar el css con el html :P
  #3 (permalink)  
Antiguo 01/02/2007, 12:26
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

Bueno, he probado en otros ordenadores, y definitivamente el problema es el internet explorer 6. Con mozilla y ie 7 va bien. ¿Hay alguna solución?

El problema es que la página web, es para un organismo de una universidad, y se supone que lo tengo que hacer compatible, al menos con el explorer 7.

Gracias por adelantado, pero darme una solución.
  #4 (permalink)  
Antiguo 01/02/2007, 12:26
Avatar de _alvaro_  
Fecha de Ingreso: diciembre-2005
Mensajes: 18
Antigüedad: 12 años
Puntos: 0
Re: Problemas al visulizar mi página

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>.:ORANGEBAR.AT:.</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<link href="style.css" rel="stylesheet" type="text/css">
<style type="text/css">
<!--

algo mas o menos asi en la cabeza de tu programacion en el html ;)
  #5 (permalink)  
Antiguo 01/02/2007, 12:29
Avatar de _alvaro_  
Fecha de Ingreso: diciembre-2005
Mensajes: 18
Antigüedad: 12 años
Puntos: 0
Re: Problemas al visulizar mi página

uhm... a mi por lo general eso siempre me funciona en explorer pero la verdad es que no me sale en firefox, no se como acer para que firefox me reconosca los css... pero bueno espero que mi consejo te haya sido util... aunque sea un pokito
  #6 (permalink)  
Antiguo 01/02/2007, 16:20
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

Arreglado, creo.

El problema era que en la cabecera de la página, como estoy trabajando con xhtml, añadí <?xml version="1.0" encoding="iso-8859-1"?> , y el explorer con eso no tira bien. Asi que nada, lo quité, y ahora se visualiza bien en el explorer, al menos en el 7. Tengo que mirar en más ordenadores, pero creo que es eso.

_alvaro_ la página ya la tenía enlazada con la hoja de estilos, el problema no era eso, el problema es que, hacía caso a la hoja de estilos pa lo que le daba la gana.

Gracias de todas formas.

Mañana lo miro en los explorer de otros ordenadores, a ver si es verdad que lo arreglé.
  #7 (permalink)  
Antiguo 01/02/2007, 16:42
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

Encontré una forma de arreglarlo sin tener que quitar la declaración xml, y es sustituyendola por
<!--[if !IE]><-->
<?xml version="1.0" encoding="iso-8859-1"?>
<!--><![endif]-->
ya que por lo visto Internet Explorer en el momento en que encuentra algo diferente a la declaración de tipo de documento (DOCTYPE) en la primera línea del documento, como la declaración <?xml?>, hace cosas raras, como lo que me pasaba a mi con al hoja de estilo.

A ver si esto ayuda a alguien más.

P.D.: _alvaro_, el problema no era ese, pero gracias de todas formas. Lo de que firefox no te reconozca los css es algo muy raro, lo haces de forma parecida a la mia:
<link rel="stylesheet" type="text/css" href="estilo.css" />

Última edición por DyoSa; 01/02/2007 a las 16:54
  #8 (permalink)  
Antiguo 01/02/2007, 17:22
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 9 meses
Puntos: 997
Re: Problemas al visulizar mi página

solo una acotación: Ie no soporta XHTML enviado como application/xhtml+xml (la única forma de trabajar bien en 1.1).
Dejo tambien la explicación de porque XHTML no es para principiantes. Recordá que XHTML 1.1 es XMl puro, no HTML.
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
  #9 (permalink)  
Antiguo 02/02/2007, 05:52
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

vale, ¿y no hay alguna forma de hacer que lo soporte? Cambiando algo por ejemplo...
  #10 (permalink)  
Antiguo 02/02/2007, 05:59
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

¿Si lo cambio a xhtml 1.0 me lo soportará?
  #11 (permalink)  
Antiguo 02/02/2007, 08:15
Avatar de DyoSa  
Fecha de Ingreso: octubre-2006
Mensajes: 9
Antigüedad: 11 años, 1 mes
Puntos: 0
Re: Problemas al visulizar mi página

Ahora si que lo arreglé, el problema era con la hoja de estilos css. No con xhtml.
era que ponia

.mapa > li > ul > li {
...
}


y por lo visto el explorer 6 no interpreta los >, los quité y arreglado.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:25.