Foros del Web » Creando para Internet » HTML »

A que se deve un espcio extraño encima de mi Web??

Estas en el tema de A que se deve un espcio extraño encima de mi Web?? en el foro de HTML en Foros del Web. Saludos A todos, Necesito Ayuda lo que pasa es que en una Web se genera un espacio al principio, al parecer la codificacionde caracteres! AYUDENME ...
  #1 (permalink)  
Antiguo 08/11/2010, 18:12
 
Fecha de Ingreso: agosto-2010
Ubicación: Peru
Mensajes: 24
Antigüedad: 7 años, 3 meses
Puntos: 0
A que se deve un espcio extraño encima de mi Web??

Saludos A todos, Necesito Ayuda lo que pasa es que en una Web se genera un espacio al principio, al parecer la codificacionde caracteres! AYUDENME PORFAVOR si ah alguien le paso algo similar y Soluciono el problema Ayudenme!
Cita:
Aqui se genera un extraño espacio<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>.:: Instituto Nacional de Defensa Civil del Perú ::.</title>


Aqui se genera un extraño espacio
: cuando le das ver codigo fuente en explorer y mozila
[URL="http://www.sinadeci.gob.pe/disac/"]

Este es el link de la Pagina!
http://www.sinadeci.gob.pe/disac/[/URL]
  #2 (permalink)  
Antiguo 08/11/2010, 20:07
Avatar de Panino5001
Moderatroll
 
Fecha de Ingreso: mayo-2004
Ubicación: -34.637167,-58.462984
Mensajes: 5.062
Antigüedad: 13 años, 6 meses
Puntos: 775
Respuesta: A que se deve un espcio extraño encima de mi Web??

Fijate en esto: http://es.wikipedia.org/wiki/Marca_d..._de_bytes_(BOM)
  #3 (permalink)  
Antiguo 08/11/2010, 23:15
 
Fecha de Ingreso: octubre-2008
Mensajes: 165
Antigüedad: 9 años, 1 mes
Puntos: 12
Respuesta: A que se deve un espcio extraño encima de mi Web??

Yo pienso que si tiene un espacio arriba le falta margen superior 0 en el contenedor #cnt_cabe, aunque veo bien la página.
  #4 (permalink)  
Antiguo 09/11/2010, 03:27
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola armank17

Muevo tu tema al foro de HTML desde Web general.

Saludos,
  #5 (permalink)  
Antiguo 09/11/2010, 07:38
 
Fecha de Ingreso: abril-2009
Ubicación: En foros del web, normalmente en Web general, HTML y CSS.
Mensajes: 258
Antigüedad: 8 años, 7 meses
Puntos: 3
Respuesta: A que se deve un espcio extraño encima de mi Web??

Cita:
Iniciado por armank17 Ver Mensaje
Saludos A todos, Necesito Ayuda lo que pasa es que en una Web se genera un espacio al principio, al parecer la codificacionde caracteres! AYUDENME PORFAVOR si ah alguien le paso algo similar y Soluciono el problema Ayudenme!



Aqui se genera un extraño espacio
: cuando le das ver codigo fuente en explorer y mozila
[URL="http://www.sinadeci.gob.pe/disac/"]

Este es el link de la Pagina!
http://www.sinadeci.gob.pe/disac/[/URL]
Posiblemente sea debido a que has definido dos veces el Doctype (me sucedió una vez algo similar), mira a ver si en algún archivo CSS o en alguna entrada (noticia) lo tienes puesto aparte de encima de la etiqueta head. En el código fuente no aparecerá dos veces el Doctype debido a que lo leera una vez y la segunda lo interpretará como un espacio.

No existe tal artículo...

Saludos =)
__________________
¿Por qué Anónimo?, porque como está el mundo no podemos considerarnos humanos...
  #6 (permalink)  
Antiguo 09/11/2010, 10:47
Avatar de Panino5001
Moderatroll
 
Fecha de Ingreso: mayo-2004
Ubicación: -34.637167,-58.462984
Mensajes: 5.062
Antigüedad: 13 años, 6 meses
Puntos: 775
Respuesta: A que se deve un espcio extraño encima de mi Web??

http://es.wikipedia.org/wiki/Marca_d...ytes_%28BOM%29

No tomó el último paréntesis
  #7 (permalink)  
Antiguo 09/11/2010, 13:16
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: A que se deve un espcio extraño encima de mi Web??

armank17:

En principio, no creo que se problema del BOM, no veo la marca ni el validador la detecta (cuando habitualmente lo hace). si se ven unos 10 espacios en blanco antes de iniciar el Doctype.

Veo que tu servidor usa PHP y la página viene comprimida con Gzip, así que probablemente el propio php te esté generando esos espacios.

de todas maneras, en cuanto a la marca del BOM. te sugiero que leas el siguiente artículo que publiqué

http://foros.emprear.com/codificar, aunque insisto, creo que el problema es otro

Saludos
__________________
La voz de las antenas va, sustituyendo a Dios.
Cuando finalice la mutación, nueva edad media habrá
S.R.

Etiquetas: encima, extraño
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:40.