Foros del Web » Creando para Internet » HTML »

Signo de ?

Estas en el tema de Signo de ? en el foro de HTML en Foros del Web. necesito ayuda cuando escribo en mi pagina web un titulo o algun comentario me aparece el sig signos �� supuestamente que no reconoce algunos caracteres ...
  #1 (permalink)  
Antiguo 26/08/2011, 12:13
 
Fecha de Ingreso: junio-2011
Mensajes: 59
Antigüedad: 5 años, 5 meses
Puntos: 0
Signo de ?

necesito ayuda cuando escribo en mi pagina web un titulo o algun comentario me aparece el sig signos �� supuestamente que no reconoce algunos caracteres como puedo acer que me los acepte y ya no aparescan esos signos ??????????
  #2 (permalink)  
Antiguo 26/08/2011, 13:00
 
Fecha de Ingreso: abril-2008
Ubicación: Santa Fe, Argentina
Mensajes: 41
Antigüedad: 8 años, 7 meses
Puntos: 14
Respuesta: Signo de ?

Depende del juego de caracteres que estés utilizando. Asegurate de tener el meta content con el charset correcto.

http://www.w3.org/TR/html4/charset.html

Generalmente con UTF-8 no vas a tener problemas.
  #3 (permalink)  
Antiguo 26/08/2011, 13:13
 
Fecha de Ingreso: junio-2011
Mensajes: 59
Antigüedad: 5 años, 5 meses
Puntos: 0
Respuesta: Signo de ?

hei que onda sii le tengo pues esto en el meta

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> pero me siguen saliendo jejejeje igual en la base de datos le tengo puesto el utf 8
  #4 (permalink)  
Antiguo 26/08/2011, 13:34
 
Fecha de Ingreso: abril-2008
Ubicación: Santa Fe, Argentina
Mensajes: 41
Antigüedad: 8 años, 7 meses
Puntos: 14
Respuesta: Signo de ?

Como dije, depende del juego de caracteres.

Si queremos representar vocales con acentos en Western, vamos a ver basura, pero sí va a funcionar en Unicode.

Código HTML:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
  2. "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
  3. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="es" lang="es">
  4.     <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type" />
  5.     <title>Web</title>
  6. </head>
  7.     <p>áéíóú</p>
  8. </body>
  9. </html>
  #5 (permalink)  
Antiguo 26/08/2011, 15:41
Avatar de IsaBelM
Colaborador
 
Fecha de Ingreso: junio-2008
Mensajes: 5.032
Antigüedad: 8 años, 5 meses
Puntos: 1008
Respuesta: Signo de ?

Cita:
Iniciado por kinto Ver Mensaje
hei que onda sii le tengo pues esto en el meta

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> pero me siguen saliendo jejejeje igual en la base de datos le tengo puesto el utf 8
has de guardar el archivo con esa codificación además de usar el meta charset utf-8

Etiquetas: signo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:09.