Foros del Web » Creando para Internet » HTML »

submit con imagen

Estas en el tema de submit con imagen en el foro de HTML en Foros del Web. Hola amigos. Mirad, quiero hacer lo siguiente. Tengo un <input name="" type="submit" /> en el quiero meter una imagen. He visto en algun hilo que ...
  #1 (permalink)  
Antiguo 02/03/2011, 03:41
 
Fecha de Ingreso: mayo-2009
Mensajes: 729
Antigüedad: 8 años, 6 meses
Puntos: 6
submit con imagen

Hola amigos. Mirad, quiero hacer lo siguiente.

Tengo un <input name="" type="submit" /> en el quiero meter una imagen.

He visto en algun hilo que se puede hacer asi

<input type="image" src="tuBotón.jpg" />

o asi

<button type="submit"><img src="tuBoton.jpg" /></button>

de las dos maneras queda bien, pero no me envia los datos del formulario donde esta el boton.

A ver si me podeis ayudar. Gracias. Un saludo.
  #2 (permalink)  
Antiguo 02/03/2011, 03:49
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.544
Antigüedad: 15 años, 8 meses
Puntos: 1262
Respuesta: submit con imagen

Hola:

Como bien dices, las dos opciones valen para hacer submit, la diferencia está en que la imagen es un tipo "input", o sea que es una entrada, en concreto es la entrada de las coordenadas en donde se pinche, por eso si no importan, lo que me parece más aconsejable (incluso semánticamente) es usar un botón, pero un botón no debería ser una entrada; y los datos normales del formulario siempre se enviarán. Esos datos, obligatoriamente deben tener un name

Si el action es un php prueba mostrando los valores recibidos (print_r($_POST))

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #3 (permalink)  
Antiguo 02/03/2011, 04:05
 
Fecha de Ingreso: mayo-2009
Mensajes: 729
Antigüedad: 8 años, 6 meses
Puntos: 6
Respuesta: submit con imagen

HOla. Gracias por tu respuesta.

Lo que hago es sustituir el <input name="" type="submit" /> que tenía por <button type="submit"><img src="tuBoton.jpg" /></button> y no me envia los datos, cuando con el primero si me los enviaba
  #4 (permalink)  
Antiguo 02/03/2011, 04:19
 
Fecha de Ingreso: mayo-2009
Mensajes: 729
Antigüedad: 8 años, 6 meses
Puntos: 6
Respuesta: submit con imagen

Rectifico. Si envia los datos. El problema era que al recibir los datos, comprobaba el nombre del boton, cuando le he puesto al boton nuevo el nombre del boton antiguo ha funcionado. Perdon.

Gracias por tu ayuda. Un saludo.

Etiquetas: submit
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:55.