Foros del Web » Creando para Internet » HTML »

Tablas + iE + Mozilla + Safari + Opera

Estas en el tema de Tablas + iE + Mozilla + Safari + Opera en el foro de HTML en Foros del Web. ¡Buenas! Llevo mucho tiempo leyeendos, y poco haciendo webs...... pero es mi curro actualmente. Me habeis ayudado mucho, y ahora, se me presenta un problema ...
  #1 (permalink)  
Antiguo 15/04/2008, 03:08
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 9 años, 8 meses
Puntos: 325
Tablas + iE + Mozilla + Safari + Opera

¡Buenas!

Llevo mucho tiempo leyeendos, y poco haciendo webs...... pero es mi curro actualmente.

Me habeis ayudado mucho, y ahora, se me presenta un problema con tablas, con firefox, y con los otros navegadores.

El caso es que en firefox se carga correctamente..... sólo la primera vez, una vez que tiene la imagen en caché me deforma la tabla, cosa que no pasa en ie, ni en safari ni en opera. No sé que hacer :S

Os adjunto unas imagenes :)

Mozilla First Time (= q los demas):
http://img514.imageshack.us/img514/4954/mzftls5.png

Mozilla Second Time:
http://img512.imageshack.us/img512/9370/mzstuw9.png

El Código no lo pongo, pq lo tngo repartido en varios muchos archivos, pero, si hace falta, lo pondré :)

Vosotros direis

Gracias ^^
  #2 (permalink)  
Antiguo 15/04/2008, 13:26
 
Fecha de Ingreso: octubre-2005
Mensajes: 28
Antigüedad: 12 años, 1 mes
Puntos: 1
Re: Tablas + iE + Mozilla + Safari + Opera

Buenas

En caso de usar tablas, es posible que no hayas indicado un width y por esto coge el tamaño del contenido.

Dale a la tabla un width:100%.

Saludos
  #3 (permalink)  
Antiguo 16/04/2008, 04:51
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 9 años, 8 meses
Puntos: 325
Re: Tablas + iE + Mozilla + Safari + Opera

en ese caso, no tendría sentido q cuando cargo la pagina la primera vez, se me vea bien, y la segunda no......

y sólo me pasa con esa imagen, no con otras. Me resulta muy extraño :S
Todas las tablas tienen atributo width. Y no es el width de la imagen, pq todas tienen el mismo :S

No sé pq me pasa
  #4 (permalink)  
Antiguo 16/04/2008, 10:22
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: Tablas + iE + Mozilla + Safari + Opera

Cita:
Iniciado por Eleazan Ver Mensaje
El Código no lo pongo, pq lo tngo repartido en varios muchos archivos, pero, si hace falta, lo pondré :)
¿Esto significa que es php y usas includes? Quizá por ahí puedan venir los tiros.

Yo creo que es mejor ver el código, y si la tienes subida a algún servidor para mi todavía mejor.

Mikel.
  #5 (permalink)  
Antiguo 17/04/2008, 04:10
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 9 años, 8 meses
Puntos: 325
Re: Tablas + iE + Mozilla + Safari + Opera

ya está, lo solucioné :)

algo chapuza, pero bueno >.<

el problema era que habia una td (dónde estan los nombres del portfolio) q era mayor de lo que debia, y me lo descuadraba con esa imagen :S

Hice la imagen 1px más pekeña, y se soluciono XD

Aunque sigo sin saber porque en mozilla sí, y en otros no. ¿Quizás algun parametro omitido? ¿Un valor por defecto q no tiene los otros? ¿Padding?¿Margin? no sé :S
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas (incluyéndote)




La zona horaria es GMT -6. Ahora son las 10:26.