Foros del Web » Creando para Internet » HTML »

Vinculo que en el computador me sirve pero en el servidor no??

Estas en el tema de Vinculo que en el computador me sirve pero en el servidor no?? en el foro de HTML en Foros del Web. Bueno como dice el titulo me pasa eso, tengo un frame con un link y ke al hacerle click me actualice 2 frames, casi no ...
  #1 (permalink)  
Antiguo 12/07/2010, 20:23
 
Fecha de Ingreso: julio-2007
Mensajes: 11
Antigüedad: 10 años, 4 meses
Puntos: 0
Vinculo que en el computador me sirve pero en el servidor no??

Bueno como dice el titulo me pasa eso, tengo un frame con un link y ke al hacerle click me actualice 2 frames, casi no lo logro pero lo logre xD..

Código HTML:
<a href="inicio-juegosps1.html"target="I1" onclick="parent.frames['I2'].location.href='menujuegosps1.html';return true"> 
y lo pruebo abriendolo en un navegador y funcionaa pero lo pruebo ya no abriendolo desde mi compu si no desde el servidor (mi compu es server) y no funciona solo abre: inicio-juegosps1.html.

Como les digo todo alojado en mi compu y me meto a la pagina atraves de un redireccionamiento por No-ip.comy no sirve y me meto a mi ip y tampoco sirve, es bastante raro, espero su ayuda!!!!!! GRACIASSSSSS:a plauso::aplaus o:
  #2 (permalink)  
Antiguo 12/07/2010, 22:59
Avatar de eZakto  
Fecha de Ingreso: julio-2008
Mensajes: 214
Antigüedad: 9 años, 5 meses
Puntos: 5
Respuesta: Vinculo que en el computador me sirve pero en el servidor no??

Cambia return true por return false a ver...
__________________
eZakto™
  #3 (permalink)  
Antiguo 12/07/2010, 23:56
Avatar de emprear
Colaborador
 
Fecha de Ingreso: junio-2007
Ubicación: me mudé
Mensajes: 8.388
Antigüedad: 10 años, 5 meses
Puntos: 1567
Respuesta: Vinculo que en el computador me sirve pero en el servidor no??

ARNOLDGARCES1994:

disculpa pero no entiendo nada.
a ver, cuando es que funciona y cuando no?
El código que pasaste esta correcto y funciona, desde el disco, en un servidor local y en mi servidor de internet.
digamos, pasado en limpio, algo como esto.



<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="es" lang="es" >
<head>
<title>XHTML 1.0 transitional</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
</head>
<body>
<p><a href="inicio-juegosps1.html"target="I1" onclick="parent.frames['I2'].location.href='menujuegosps1.html';return true">
cargar 2 frames</a></p>
<p><br />Primer iframe</p>
<iframe name="I1" width="300" height="300"></iframe>
<p><br />Segundo iframe</p>
<iframe name="I2" width="300" height="300"></iframe>
</body>
</html>




Para más pruebas te dejo una demo
http://foros.emprear.com/html/dos-iframes/index.html


"Lo pruebo desde un navegador y funciona" , y sí, hay que abrirlo desde el navegador.

ya no abriendolo desde mi compu si no desde el servidor (mi compu es server) y no funciona ... , pero en el servidor supongo que tambien utilizas un navegador para abrirlo.
Asi que no sé bien a que te refieres.
Lo que intuyo (y sólo intuyo), es que estás intentando acceder a
http://tudominio.no-ip.info/ (que debes tener redireccionado a tu webserver) desde tu propia PC. Lo cual no vas a poder si estas detras de un router y no tienes bien configurados los puerto y demas cosas. Quizás este diciendo cualquier cosa, pero en realidad no se entiende bien tu problema.

En definitiva el código SI carga dos páginas al mismo tiempo en iframes diferentes.

Saludos
  #4 (permalink)  
Antiguo 13/07/2010, 21:54
Avatar de raxper  
Fecha de Ingreso: enero-2010
Ubicación: ------
Mensajes: 472
Antigüedad: 7 años, 11 meses
Puntos: 2
Respuesta: Vinculo que en el computador me sirve pero en el servidor no??

Che no se que dificultoso lo ven a esto, que está sencillo, bueno publico lo que un dia x hay mongoliando me las ingenié, aver si les sirve :).



<script>
function rxp () {window.open('/paginados.html', 'dos');}
</script>
<center><a href="/paginauno.html" target="uno" onclick="rxp()">Abrir</a>
<p> </p>

<iframe style="border: dashed green" name="uno" width="400" height="400"></iframe>
<p> </p>

<iframe style="border: dashed green" name="dos" width="400" height="400"></iframe></center>



Saludos

Última edición por raxper; 13/07/2010 a las 22:03

Etiquetas: frames, link, marcos, vinculo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 21:23.