Foros del Web » Creando para Internet » HTML »

Vista Previa Imagenes solo funciona con algunas imagenes

Estas en el tema de Vista Previa Imagenes solo funciona con algunas imagenes en el foro de HTML en Foros del Web. Estoy haciendo una Vista Previa de una imagen jpg con Internet Explorer. Me funciona solo con algunas imagenes y no con todas. ¿A que puede ...
  #1 (permalink)  
Antiguo 17/11/2005, 04:37
 
Fecha de Ingreso: mayo-2003
Mensajes: 866
Antigüedad: 14 años, 7 meses
Puntos: 0
Vista Previa Imagenes solo funciona con algunas imagenes

Estoy haciendo una Vista Previa de una imagen jpg con Internet Explorer.
Me funciona solo con algunas imagenes y no con todas.
¿A que puede ser debido?
Todas las imagenes estan en la misma carpeta, y tienen nombres
foto1.jpg,foto2.jpg,etc (para evitar que el error sea debido a eso)

<FORM>
<input type="file" NAME=File1 SIZE=100 onChange="document.imagen.src='file:///' + this.value">
Vista previa:<br><br>
<img src="../activos/spacer.gif" name="imagen">
</FORM>
  #2 (permalink)  
Antiguo 19/11/2005, 03:41
 
Fecha de Ingreso: mayo-2003
Mensajes: 866
Antigüedad: 14 años, 7 meses
Puntos: 0
¿Ninguna idea?
  #3 (permalink)  
Antiguo 21/11/2005, 03:09
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.544
Antigüedad: 15 años, 8 meses
Puntos: 1262
Hola sqa212:

La verdad es que no tengo idea de la razón, habría que ver el tema funcionando... aunque lo que me desorienta es el atributo size... tal vez el "path" o ruta de la imagen tenga más de 100 caracteres y recorte la url...

Prueba viendo las propiedades del objeto (la imagen) para ver si es el correcto. Con window te muestra esa ruta... luego la insertas en la barra de direcciones y así lo controlas.

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #4 (permalink)  
Antiguo 21/11/2005, 20:15
 
Fecha de Ingreso: mayo-2003
Mensajes: 866
Antigüedad: 14 años, 7 meses
Puntos: 0
Hola caricatos
Gracias por intentar resolver una de mis dudas una vez mas.
Esta tarde un amigo comentandoselo a un amigo diseñador grafico dio con el problema y la solucion.
Las imagenes que tenian modo CMYK
(CMYK: Acrónimo inglés de Cyan Magenta Yellow blacK (Cian, Magenta, Amarillo y Negro). ) No funcionan.
Cambiando el modo a RGB (RGB es el acrónimo inglés Red, Green, Blue (Rojo, verde, Azul). Es un modelo de color en el cual es posible representar un color mediante la mezcla de tres colores primarios: rojo, verde y azul. )
Funcionan

Gracias de nuevo por tu ayuda.
Voy a investigar ahora si es posible mediante codigo detectar el modo de la imagen.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:15.