Foros del Web » Administración de Sistemas » Unix / Linux »

Algo tan sencillo como el NAT no me anda y no se porque

Estas en el tema de Algo tan sencillo como el NAT no me anda y no se porque en el foro de Unix / Linux en Foros del Web. Estimados perdon que los moleste espero que estoy este bien en donde lo posteo. El tema es que estoy haciendo un router con una maquina ...
  #1 (permalink)  
Antiguo 02/01/2014, 14:35
 
Fecha de Ingreso: octubre-2008
Mensajes: 75
Antigüedad: 14 años, 4 meses
Puntos: 1
Algo tan sencillo como el NAT no me anda y no se porque

Estimados perdon que los moleste espero que estoy este bien en donde lo posteo. El tema es que estoy haciendo un router con una maquina y un linux debian 6 simplemente para dar nat y a futuro montar un pptp para una maquina de otra sucursal.

Le puse al servidor dos placas dlink y anule la onboard que tenia por lo tanto en ifconfig me quedo lo siguiente:

eth0 Link encap:Ethernet HWaddr 00:1c:f0:a6:b8:d0
inet addr:10.0.0.210 Bcast:10.255.255.255 Mask:255.0.0.0
inet6 addr: fe80::21c:f0ff:fea6:b8d0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:104 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7648 (7.4 KiB) TX bytes:1620 (1.5 KiB)
Interrupt:17 Base address:0xbc00

eth1 Link encap:Ethernet HWaddr 00:1c:f0:a6:b9:ae
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21c:f0ff:fea6:b9ae/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:197 errors:0 dropped:0 overruns:0 frame:0
TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20062 (19.5 KiB) TX bytes:18355 (17.9 KiB)
Interrupt:19 Base address:0xc000


Note se que la eth0 tiene una direccion interna por que lo estoy probando en mi lan interna pero una red es A y la otra C asique no deberia de tener problema.

la tabla de ruteo del server linux queda asi

[email protected]:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth1
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default 10.0.0.246 0.0.0.0 UG 0 0 0 eth0


donde 10.0.0.246 es mi router actual que tiene el cable de internet.

Luego activo el forward y queda esto

[email protected]:~# cat /proc/sys/net/ipv4/ip_forward
1

Y desde otra compu por medio de un switch conecto al server y el ping entre ellas es bueno, el ping de mi computadora 192.168.0.2 a la ip 10.0.0.210 tambien llega pero si desde la maquina cliente que esta detras de mi linux/router pongo ping 10.0.0.246 o ping www.google.com.ar no hay forma de que pase un paquete

Es como que no le diera importancia el tema del ip_forward, alguien por favor me puede decir que se me esta pasando por alto?, millón de gracias a todos y que tengan un muy buen 2014, saludos


La Santa

Etiquetas: anda, debian, ip, linux, nat, sencillo, servidor
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:15.