Foros del Web » Administración de Sistemas » Unix / Linux »

Error al instalar LAMP en ubuntu 18.04

Estas en el tema de Error al instalar LAMP en ubuntu 18.04 en el foro de Unix / Linux en Foros del Web. Estoy probando ubuntu 18.04 intente instalar lamp pero me manda muchos errores Intente instalar el servidor mysql sudo apt update sudo apt install mysql-server mysql-client ...
  #1 (permalink)  
Antiguo 20/06/2018, 11:29
 
Fecha de Ingreso: febrero-2016
Mensajes: 38
Antigüedad: 3 años, 1 mes
Puntos: 2
Error al instalar LAMP en ubuntu 18.04

Estoy probando ubuntu 18.04 intente instalar lamp pero me manda muchos errores

Intente instalar el servidor mysql

sudo apt update
sudo apt install mysql-server mysql-client

aparentemente hace todo bien pero al final me manda la siguiente salida

Código BASH:
Ver original
  1. dpkg: error al procesar el paquete mysql-server-5.7 (--configure):
  2.  instalado mysql-server-5.7 paquete post-installation guión el subproceso devolvió un error con estado de salida 2
  3. dpkg: problemas de dependencias impiden la configuración de mysql-server:
  4.  mysql-server depende de mysql-server-5.7; sin embargo:
  5.  El paquete `mysql-server-5.7' no está configurado todavía.
  6.  
  7. dpkg: error al procesar el paquete mysql-server (--configure):
  8. problemas de dependencias - se deja sin configurar
  9. Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
  10. No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
  11.                                                                                                                           Se encontraron errores al procesar:
  12. mysql-server-5.7
  13. mysql-server
  14. E: Sub-process /usr/bin/dpkg returned an error code (1)

Posteriormente intento instalar apache2

sudo apt install apache2

y obtengo los siguientes errores


Código BASH:
Ver original
  1. Leyendo lista de paquetes... Hecho
  2. Creando árbol de dependencias      
  3. Leyendo la información de estado... Hecho
  4. Paquetes sugeridos:
  5.   apache2-doc apache2-suexec-pristine | apache2-suexec-custom
  6. Se instalarán los siguientes paquetes NUEVOS:
  7.   apache2
  8. 0 actualizados, 1 nuevos se instalarán, 0 para eliminar y 8 no actualizados.
  9. 2 no instalados del todo o eliminados.
  10. Se necesita descargar 95.1 kB de archivos.
  11. Se utilizarán 532 kB de espacio de disco adicional después de esta operación.
  12. Des:1 http://mx.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2 amd64 2.4.29-1ubuntu4.1 [95.1 kB]
  13. Descargados 95.1 kB en 1s (95.9 kB/s)
  14. Seleccionando el paquete apache2 previamente no seleccionado.
  15. (Leyendo la base de datos ... 166170 ficheros o directorios instalados actualmente.)
  16. Preparando para desempaquetar .../apache2_2.4.29-1ubuntu4.1_amd64.deb ...
  17. Desempaquetando apache2 (2.4.29-1ubuntu4.1) ...
  18. Procesando disparadores para ufw (0.35-5) ...
  19. Configurando apache2 (2.4.29-1ubuntu4.1) ...
  20. Enabling module mpm_event.
  21. cp: no se puede efectuar `stat' sobre '/usr/share/apache2/default-site/index.html': No existe el archivo o el directorio
  22. dpkg: error al procesar el paquete apache2 (--configure):
  23. instalado apache2 paquete post-installation guión el subproceso devolvió un error con estado de salida 1
  24. Procesando disparadores para ureadahead (0.100.0-20) ...
  25. Procesando disparadores para systemd (237-3ubuntu10) ...
  26. Procesando disparadores para man-db (2.8.3-2) ...
  27. Configurando mysql-server-5.7 (5.7.22-0ubuntu18.04.1) ...
  28. update-alternatives: error: la ruta alternativa /etc/mysql/mysql.cnf no existe
  29. dpkg: error al procesar el paquete mysql-server-5.7 (--configure):
  30. instalado mysql-server-5.7 paquete post-installation guión el subproceso devolvió un error con estado de salida 2
  31. dpkg: problemas de dependencias impiden la configuración de mysql-server:
  32. mysql-server depende de mysql-server-5.7; sin embargo:
  33. El paquete `mysql-server-5.7' no está configurado todavía.
  34.  
  35. dpkg: error al procesar el paquete mysql-server (--configure):
  36.  problemas de dependencias - se deja sin configurar
  37. No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
  38.                                                                                                                            Procesando disparadores para ufw (0.35-5) ...
  39. Se han actualizado las reglas para el perfil «Apache Full»
  40. El cortafuegos se ha recargado
  41. Se encontraron errores al procesar:
  42.  apache2
  43.  mysql-server-5.7
  44.  mysql-server
  45. E: Sub-process /usr/bin/dpkg returned an error code (1)

si ejecuto sudo service apache2 start obtengo

Código BASH:
Ver original
  1. Job for apache2.service failed because the control process exited with error code.
  2. See "systemctl status apache2.service" and "journalctl -xe" for details.

Alquien me puede ayudar ? generalmente configuro e instalo estos servicios sin ningun problema pero ahora no se que pueda estar pasando
  #2 (permalink)  
Antiguo 20/06/2018, 11:32
 
Fecha de Ingreso: febrero-2016
Mensajes: 38
Antigüedad: 3 años, 1 mes
Puntos: 2
Respuesta: Error al instalar LAMP en ubuntu 18.04

dejo la salida de systemctl status apache2.service

Código BASH:
Ver original
  1. ● apache2.service - The Apache HTTP Server
  2.    Loaded: loaded (/lib/systemd/system/apache2.service; disabled; vendor preset: enabled)
  3.   Drop-In: /lib/systemd/system/apache2.service.d
  4.            └─apache2-systemd.conf
  5.    Active: failed (Result: exit-code) since Wed 2018-06-20 12:37:41 CDT; 3min 45s ago
  6.   Process: 9011 ExecStart=/usr/sbin/apachectl start (code=exited, status=127)
  7.  
  8. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: Starting The Apache HTTP Server...
  9. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: /usr/sbin/apachectl: 174: /usr/sbin/apachectl: /usr/sbin/apache2: not found
  10. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: Action 'start' failed.
  11. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: The Apache error log may have more information.
  12. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: apache2.service: Control process exited, code=exited status=127
  13. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: apache2.service: Failed with result 'exit-code'.
  14. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: Failed to start The Apache HTTP Server.

salida de journalctl -xe

Código BASH:
Ver original
  1. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #13 0x557061e6e7b8 i   resource:///org/gnome/shell/ui/extensionSystem.js:343 (0x7faad2e5ab38 @
  2. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #14 0x557061e6e738 i   resource:///org/gnome/shell/ui/extensionSystem.js:361 (0x7faad2e5ac48 @
  3. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #15 0x7fffb2a83890 b   resource:///org/gnome/gjs/modules/signals.js:128 (0x7faaf01d3230 @ 386)
  4. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #16 0x7fffb2a840a0 b   resource:///org/gnome/shell/ui/sessionMode.js:205 (0x7faad2a6b670 @ 254
  5. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #17 0x7fffb2a85490 b   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7faaf01b5de0 @ 71)
  6. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #18 0x557061e6e5f8 i   resource:///org/gnome/shell/ui/sessionMode.js:167 (0x7faad2a6b450 @ 40)
  7. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #19 0x7fffb2a867f0 b   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7faaf01b5de0 @ 71)
  8. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC gnome-software[2536]: no app for changed ubuntu-dock@ubuntu.com
  9. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #20 0x557061e6e550 i   resource:///org/gnome/shell/ui/screenShield.js:1280 (0x7faad2a50bc0 @ 1
  10. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #21 0x7fffb2a87b50 b   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7faaf01b5de0 @ 71)
  11. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #22 0x557061e6e4a0 i   resource:///org/gnome/shell/ui/screenShield.js:1329 (0x7faad2a50c48 @ 3
  12. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #23 0x7fffb2a88eb0 b   resource:///org/gnome/gjs/modules/_legacy.js:82 (0x7faaf01b5de0 @ 71)
  13. jun 20 12:30:00 desarrollo-HP-Compaq-6200-Pro-SFF-PC org.gnome.Shell.desktop[2333]: #24 0x557061e6e420 i   resource:///org/gnome/shell/ui/screenShield.js:852 (0x7faad2a4fb38 @ 25
  14. jun 20 12:31:18 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:00:e6:20:10:3f:b2:08:00 SRC=192.168.1.64 DST=224.0.0.251 LE
  15. jun 20 12:32:44 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:a0:d7:95:3c:20:8a:08:00 SRC=192.168.1.72 DST=224.0.0.251 LE
  16. jun 20 12:33:25 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:18:cf:5e:81:16:4e:08:00 SRC=192.168.1.122 DST=224.0.0.251 L
  17. jun 20 12:33:26 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:a0:d7:95:3c:20:8a:08:00 SRC=192.168.1.72 DST=224.0.0.251 LE
  18. jun 20 12:35:28 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:30:10:b3:e6:6f:2d:08:00 SRC=192.168.1.71 DST=224.0.0.251 LE
  19. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gdm-password][8945]: gkr-pam: unlocked login keyring
  20. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gnome-software[2536]: no app for changed ubuntu-dock@ubuntu.com
  21. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gnome-software[2536]: no app for changed ubuntu-appindicators@ubuntu.com
  22. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gvfsd-metadata[2634]: g_udev_device_has_property: assertion 'G_UDEV_IS_DEVICE (device)' failed
  23. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gvfsd-metadata[2634]: g_udev_device_has_property: assertion 'G_UDEV_IS_DEVICE (device)' failed
  24. jun 20 12:35:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC gnome-shell[2333]: [AppIndicatorSupport-DEBUG] Registering StatusNotifierItem :1.59/org/ayatana/NotificationItem/software_upd
  25. jun 20 12:35:43 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:a0:d7:95:3c:20:8a:08:00 SRC=192.168.1.72 DST=224.0.0.251 LE
  26. jun 20 12:37:31 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:20:10:7a:64:e6:7a:08:00 SRC=192.168.1.126 DST=224.0.0.251 L
  27. jun 20 12:37:40 desarrollo-HP-Compaq-6200-Pro-SFF-PC sudo[8984]:   imagen : TTY=pts/0 ; PWD=/home/imagen ; USER=root ; COMMAND=/usr/sbin/service apache2 start
  28. jun 20 12:37:40 desarrollo-HP-Compaq-6200-Pro-SFF-PC sudo[8984]: pam_unix(sudo:session): session opened for user root by (uid=0)
  29. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: Starting The Apache HTTP Server...
  30. -- Subject: Unit apache2.service has begun start-up
  31. -- Defined-By: systemd
  32. -- Support: http://www.ubuntu.com/support
  33. --
  34. -- Unit apache2.service has begun starting up.
  35. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: /usr/sbin/apachectl: 174: /usr/sbin/apachectl: /usr/sbin/apache2: not found
  36. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: Action 'start' failed.
  37. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC apachectl[9011]: The Apache error log may have more information.
  38. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: apache2.service: Control process exited, code=exited status=127
  39. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: apache2.service: Failed with result 'exit-code'.
  40. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC systemd[1]: Failed to start The Apache HTTP Server.
  41. -- Subject: Unit apache2.service has failed
  42. -- Defined-By: systemd
  43. -- Support: http://www.ubuntu.com/support
  44. --
  45. -- Unit apache2.service has failed.
  46. --
  47. -- The result is RESULT.
  48. jun 20 12:37:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC sudo[8984]: pam_unix(sudo:session): session closed for user root
  49. jun 20 12:39:18 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:a0:d7:95:3c:20:8a:08:00 SRC=192.168.1.72 DST=224.0.0.251 LE
  50. jun 20 12:39:22 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:a0:d7:95:3c:20:8a:08:00 SRC=192.168.1.72 DST=224.0.0.251 LE
  51. jun 20 12:39:40 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:00:e6:20:10:3f:b2:08:00 SRC=192.168.1.64 DST=224.0.0.251 LE
  52. jun 20 12:41:41 desarrollo-HP-Compaq-6200-Pro-SFF-PC kernel: [UFW BLOCK] IN=wlx1062eb8499a1 OUT= MAC=01:00:5e:00:00:fb:20:10:7a:64:e6:7a:08:00 SRC=192.168.1.126 DST=224.0.0.251 L
  53. lines 1450-1501/1501 (END)
  #3 (permalink)  
Antiguo 20/06/2018, 12:54
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.250
Antigüedad: 5 años, 8 meses
Puntos: 391
Respuesta: Error al instalar LAMP en ubuntu 18.04

Ya empiezas mal...

Si quieres instalr Lamp, comienza por apache.
Código BASH:
Ver original
  1. sudo apt install apache2
Esta mal decirlo pero aqui tienes un tuto que funciona sin problemas.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #4 (permalink)  
Antiguo 20/06/2018, 13:32
 
Fecha de Ingreso: febrero-2016
Mensajes: 38
Antigüedad: 3 años, 1 mes
Puntos: 2
Respuesta: Error al instalar LAMP en ubuntu 18.04

si amigo gracias por responder, de hecho el error da igual he intentado primero por apache y da exactamente el mismo error, le dare una revisada al tuto que mandas gracias!
  #5 (permalink)  
Antiguo 13/08/2018, 13:58
Avatar de alvidales  
Fecha de Ingreso: febrero-2012
Mensajes: 108
Antigüedad: 7 años, 1 mes
Puntos: 11
Respuesta: Error al instalar LAMP en ubuntu 18.04

Qué tal!,
Te recomendaria reinstalar Ubuntu, posterior a eso lo primero que tienes que hacer antes que nada es lo siguiente:

Código:
# sudo apt update
# sudo apt upgrade
Entonces comienzas con la instalación de tu "LAMP"

Código:
# sudo apt install apache2
# sudo apt install mysql-server //El cliente se instala por default en la mayoría de los casos
# sudo mysql_secure_installation //Sigues los pasos que se te indican, si tienes dudas google!
# sudo apt install php libapache2-mod-php php-mysql
Reinicia apache
Código:
# sudo systemctl restart apache2
Si tienes dudas me avisas.

Referencia en extenso:
https://www.digitalocean.com/communi...k-ubuntu-18-04
__________________
Hasta que el hombre no es nada, Dios no puede hacer nada con el.
  #6 (permalink)  
Antiguo 01/10/2018, 16:09
Avatar de iconogt  
Fecha de Ingreso: septiembre-2004
Ubicación: Guatemala
Mensajes: 576
Antigüedad: 14 años, 6 meses
Puntos: 4
Respuesta: Error al instalar LAMP en ubuntu 18.04

Docker? https://hub.docker.com/
__________________
_______
Jorge Rojas.



La zona horaria es GMT -6. Ahora son las 00:32.