Foros del Web » Administración de Sistemas » Unix / Linux »

no acceptable C compiler found in $PATH

Estas en el tema de no acceptable C compiler found in $PATH en el foro de Unix / Linux en Foros del Web. Buenas a todos, Veréis, debido a la vulnerabilidad que se descubrió en septiembre sobre el BASH de Linux estoy actualizando todos mis servidores, mediante un ...
  #1 (permalink)  
Antiguo 29/10/2014, 05:59
Avatar de Lothbrok  
Fecha de Ingreso: octubre-2014
Ubicación: Barcelona
Mensajes: 1
Antigüedad: 4 años, 7 meses
Puntos: 0
Exclamación no acceptable C compiler found in $PATH

Buenas a todos,

Veréis, debido a la vulnerabilidad que se descubrió en septiembre sobre el BASH de Linux estoy actualizando todos mis servidores, mediante un update&&upgrade de los paquetes. O bien, en caso de que la maquina ya disponga de soporte, actualizo el BASH manualmente.
Hasta ahora me ha ido bien en todas las máquinas excepto en esta que os voy a comentar.
Es un SUSE Linux Enterprise Server 9 de 32bits.
Según tengo entendido el SLES usa el zypper al igual que Ubuntu usa apt-get, pues bien cuando intento hacer zypper update me salta el siguiente error:

Código:
"-bash: zypper: command not found"
Debido a esto lo que hago es actualizar el BASH manualmente como he hecho en el caso de algunos servidores.
Cuando ya me he bajado todos los ficheros y voy a compilar con el comando ./configure, me da el siguiente error:

Código:
MART:/tmp/bash/bash-3.0 # ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for emacs... no
checking for xemacs... no

Beginning configuration for bash-3.0-release for i686-pc-linux-gnu

checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
MART:/tmp/bash/bash-3.0 #
Buscando por Google he encontrado que me falta un compilador de C, vale muy fácil. Busco uno, por ejemplo el gcc y lo instalo... pero NO! No puedo instalarlo debido a que no me funciona ningún comando para poder instalar paquetes....

Todo esto lo hago desde la consola de comandos.

Entonces se me ha ocurrido intentar instalar el paquete por el gestor de Instalar/Desintalar programas, busco el paquete lo selecciono, y cuando le doy a aceptar para que empiece a instalar, me pide el CD3 de instalación... CD que no dispongo y tampoco he encontrado por Internet.

A ver si me podéis echar una mano por favor.

Muchas gracias!

Última edición por Lothbrok; 29/10/2014 a las 06:14

Etiquetas: bash, found, linux, path, servidor, ubuntu
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:02.