Foros del Web » Programación para mayores de 30 ;) » Java »

Ayuda Pool de Conexiones

Estas en el tema de Ayuda Pool de Conexiones en el foro de Java en Foros del Web. Buenas tengo montado en un equipo un pool de conexiones que monte hace ya un tiempo, el problema es que quiero montar otro y el ...
  #1 (permalink)  
Antiguo 07/09/2010, 06:06
 
Fecha de Ingreso: junio-2005
Mensajes: 24
Antigüedad: 17 años
Puntos: 0
Ayuda Pool de Conexiones

Buenas tengo montado en un equipo un pool de conexiones que monte hace ya un tiempo, el problema es que quiero montar otro y el tomcat me da un error y no me deja levantar la apliacion he comprado los dos equipos y no veo el error, asi que os paso el Log para ver si me podeis orientar por donde esta el fallo.

--------
07-sep-2010 13:48:38 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: E:\Archivos de programa\Apache Software Foundation\Tomcat 5.5\bin;.;E:\WINDOWS\Sun\Java\bin;E:\WINDOWS\syste m32;E:\WINDOWS;D:\oracle\product\10.1.0\Db_2\bin;D :\oracle\product\10.1.0\Db_2\jre\1.4.2\bin\client; D:\oracle\product\10.1.0\Db_2\jre\1.4.2\bin;E:\WIN DOWS\system32;E:\WINDOWS;E:\WINDOWS\System32\Wbem
07-sep-2010 13:48:38 org.apache.coyote.http11.Http11BaseProtocol init
INFO: Inicializando Coyote HTTP/1.1 en puerto http-8989
07-sep-2010 13:48:38 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 578 ms
07-sep-2010 13:48:38 org.apache.catalina.core.StandardService start
INFO: Arrancando servicio Catalina
07-sep-2010 13:48:38 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.27
07-sep-2010 13:48:38 org.apache.catalina.core.StandardHost start
INFO: Desactivada la validación XML
07-sep-2010 13:48:40 org.apache.catalina.startup.ContextConfig applicationWebConfig
GRAVE: Error de evaluación (parse) en el archivo web.xml de la aplicación a jndi:/localhost/MYNET/WEB-INF/web.xml
com.sun.org.apache.xerces.internal.impl.io.Malform edByteSequenceException: Invalid byte 2 of 3-byte UTF-8 sequence.
at com.sun.org.apache.xerces.internal.impl.io.UTF8Rea der.invalidByte(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.io.UTF8Rea der.read(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLEntityS canner.load(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLEntityS canner.skipChar(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumen tFragmentScannerImpl$FragmentContentDriver.next(Un known Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumen tScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumen tFragmentScannerImpl.scanDocument(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Co nfiguration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Co nfiguration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XMLPars er.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.Abstrac tSAXParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserI mpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.tomcat.util.digester.Digester.parse(Dig ester.java:1562)
at org.apache.catalina.startup.ContextConfig.applicat ionWebConfig(ContextConfig.java:348)
at org.apache.catalina.startup.ContextConfig.start(Co ntextConfig.java:1048)
at org.apache.catalina.startup.ContextConfig.lifecycl eEvent(ContextConfig.java:261)
at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4148)
at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:760)
at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:740)
at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:544)
at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:927)
at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:890)
at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:492)
at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1150)
at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:311)
at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1022)
at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:736)
at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1014)
at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:443)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:448)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:433)
07-sep-2010 13:48:40 org.apache.catalina.startup.ContextConfig start
GRAVE: Esta aplicación está marcada como no disponible debido a los errores precedentes
07-sep-2010 13:48:40 org.apache.catalina.core.StandardContext start
GRAVE: Error getConfigured
07-sep-2010 13:48:40 org.apache.catalina.core.StandardContext start
GRAVE: Falló en arranque del Contexto [/MYNET] debido a errores previos
07-sep-2010 13:48:41 org.apache.coyote.http11.Http11BaseProtocol start
INFO: Arrancando Coyote HTTP/1.1 en puerto http-8989
07-sep-2010 13:48:41 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
07-sep-2010 13:48:41 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/47 config=null
07-sep-2010 13:48:41 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
07-sep-2010 13:48:41 org.apache.catalina.startup.Catalina start
INFO: Server startup in 2703 ms

--------


Muchas gracias
  #2 (permalink)  
Antiguo 07/09/2010, 06:21
 
Fecha de Ingreso: octubre-2003
Mensajes: 3.578
Antigüedad: 18 años, 8 meses
Puntos: 51
Respuesta: Ayuda Pool de Conexiones

Cita:
GRAVE: Error de evaluación (parse) en el archivo web.xml de la aplicación a jndi:/localhost/MYNET/WEB-INF/web.xml
com.sun.org.apache.xerces.internal.impl.io.Malform edByteSequenceException: Invalid byte 2 of 3-byte UTF-8 sequence.
El error dice que en tu web.xml tienes algún caracter que no es UTF-8 y lo tienes declarado como UTF-8 (o no declarado ya que UTF-8 es el valor por defecto).

Puede que al transferirlo de un equipo a otro se haya hecho mal la codificación. A veces es dificil verlo con los editores ya que para "ayudar" suelen arreglarte esos problemas en la visualización y no sabes que realmente esta mal.

S!
__________________
Para obtener respuestas, pregunta de forma inteligente o si no, pregunta lo que quieras que yo contestaré lo que me dé la gana.
  #3 (permalink)  
Antiguo 07/09/2010, 06:33
 
Fecha de Ingreso: junio-2005
Mensajes: 24
Antigüedad: 17 años
Puntos: 0
Respuesta: Ayuda Pool de Conexiones

entonces lo vuelvo a escribir a mano por ejemplo?
  #4 (permalink)  
Antiguo 07/09/2010, 08:29
 
Fecha de Ingreso: octubre-2003
Mensajes: 3.578
Antigüedad: 18 años, 8 meses
Puntos: 51
Respuesta: Ayuda Pool de Conexiones

Comprueba que no tengas ningun caracter que no sea UTF-8, como acentos, dieresis, eñes... y si no es así, vuelvelo a copiar desde el ordenador que funciona. Por FTP en modo ASCII debería hacer las transformaciones adecuadas en caso necesario.

S!
__________________
Para obtener respuestas, pregunta de forma inteligente o si no, pregunta lo que quieras que yo contestaré lo que me dé la gana.
  #5 (permalink)  
Antiguo 08/09/2010, 02:28
 
Fecha de Ingreso: junio-2005
Mensajes: 24
Antigüedad: 17 años
Puntos: 0
Respuesta: Ayuda Pool de Conexiones

Cita:
Iniciado por GreenEyed Ver Mensaje
Comprueba que no tengas ningun caracter que no sea UTF-8, como acentos, dieresis, eñes... y si no es así, vuelvelo a copiar desde el ordenador que funciona. Por FTP en modo ASCII debería hacer las transformaciones adecuadas en caso necesario.

S!
SOLUCIONADO MUCHAS GRACIAS eran unos acentos

Etiquetas: conexiones, pool
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:43.