Foros del Web » Programación para mayores de 30 ;) » Java »

class file has wrong version

Estas en el tema de class file has wrong version en el foro de Java en Foros del Web. Hola que tal, tengo un problema. me encuentro cambiando una clases antiguias que usaban un jar POI antiguo, para la creacion de xls, pero ahora ...
  #1 (permalink)  
Antiguo 05/08/2011, 15:54
HaX
 
Fecha de Ingreso: octubre-2007
Mensajes: 34
Antigüedad: 12 años
Puntos: 0
class file has wrong version

Hola que tal, tengo un problema.
me encuentro cambiando una clases antiguias que usaban un jar POI antiguo, para la creacion de xls, pero ahora necesito que las mismas clases creen XLSX. y para ellos trbajo con nuevos jars, pero al momento de compilar me dice esto:

Error(3,38): cannot access class org.apache.poi.hssf.usermodel.HSSFCell; class file has wrong version 49.0, should be 45.3 or 46.0 or 47.0 or 48.0

a alguien le ha pasado esto? alguna ayuda por ahi?


gracias
  #2 (permalink)  
Antiguo 05/08/2011, 20:34
Avatar de HackmanC  
Fecha de Ingreso: enero-2008
Ubicación: Guatemala
Mensajes: 1.817
Antigüedad: 11 años, 9 meses
Puntos: 260
Sonrisa Respuesta: class file has wrong version

Hola,

Estas usando una versión antigua de Java, posiblemente el JDK 1.4. Cuando compilas una clase con una versión del JDK mas nueva e intentas ejecutarla con una versión mas antigua, te dice que no puede.

Actualiza las instalaciones de Java a una versión mas nueva.

Saludos,

ps:

J2SE 7 = 51 (0x33 hex),
J2SE 6.0 = 50 (0x32 hex),
J2SE 5.0 = 49 (0x31 hex),
JDK 1.4 = 48 (0x30 hex),
JDK 1.3 = 47 (0x2F hex),
JDK 1.2 = 46 (0x2E hex),
JDK 1.1 = 45 (0x2D hex).

http://en.wikipedia.org/wiki/Java_class_file
  #3 (permalink)  
Antiguo 08/08/2011, 15:40
HaX
 
Fecha de Ingreso: octubre-2007
Mensajes: 34
Antigüedad: 12 años
Puntos: 0
Respuesta: class file has wrong version

gracias hackamanc, hice lo q me dijiste, actualize el jdk del 1.4 al 1.6.0.26
pero sabes, el problemas sigue....



eso si que ahora bajo la cantidad de errores a solo uno, me marca el error en la primera linea,
en los package....


Error: initialization error: class file has wrong version 49.0, should be 45.3 or 46.0 or 47.0 or 48.0 on classpath


que estoy haciendo mal?

gracias.-
  #4 (permalink)  
Antiguo 08/08/2011, 18:14
Avatar de HackmanC  
Fecha de Ingreso: enero-2008
Ubicación: Guatemala
Mensajes: 1.817
Antigüedad: 11 años, 9 meses
Puntos: 260
Sonrisa Respuesta: class file has wrong version

Hola,

Cita:
Iniciado por HaX Ver Mensaje
gracias hackamanc, hice lo q me dijiste, actualize el jdk del 1.4 al 1.6.0.26
pero sabes, el problemas sigue....
El problema es que estas usando una versión antigua de JDeveloper.
¿Acerté con lo de JDeveloper? Google oracle.com

Lo que quise dar a entender es: asegúrate, sin lugar a dudas, que estas usando una versión de Java mas reciente, sin importar que fabricante o herramienta estés usando, si esa herramienta no permite actualizar o usar un compilador javac mas nuevo, actualiza la herramienta para ver si lo permite, sino lo permite, cambia a una herramienta que permita usar cualquier compilador mas nuevo.

El compilador de Oracle muestra estos mensajes de error cuando intentas usar una clase mas nueva (JDK7) con un compilador mas antiguo:

JDK 6
warning: .\V6.class: major version 51 is newer than 50, the highest major version supported by this compiler.

JDK 5
class file has wrong version 51.0, should be 49.0

JDK 4
class file has wrong version 51.0, should be 48.0

JDK 3
class file has wrong version 51.0, should be 47.0

Ves la similitud del problema?
Saludos,
  #5 (permalink)  
Antiguo 09/08/2011, 01:38
Avatar de Fuzzylog  
Fecha de Ingreso: agosto-2008
Ubicación: En internet
Mensajes: 2.509
Antigüedad: 11 años, 2 meses
Puntos: 188
Respuesta: class file has wrong version

Deberías revisar las propiedades del proyecto y ver que versión de java estás utilizando para compilar/ejecutar. Es ahí donde debes hacer los cambios.

A mi me pasaba con una clase de un jar hace tiempo.

Etiquetas: class, file, jar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:12.