Foros del Web » Programación para mayores de 30 ;) » Java »

Problema con json Request

Estas en el tema de Problema con json Request en el foro de Java en Foros del Web. Hola, como estan? Estoy desarrollando una palicación en HTML5 con jQuery, usando Sync Framework para la sincronización, el cual consume un servicio que esta alojado ...
  #1 (permalink)  
Antiguo 30/11/2011, 05:45
 
Fecha de Ingreso: noviembre-2011
Mensajes: 1
Antigüedad: 10 años, 8 meses
Puntos: 0
Pregunta Problema con json Request

Hola, como estan?

Estoy desarrollando una palicación en HTML5 con jQuery, usando Sync Framework para la sincronización, el cual consume un servicio que esta alojado en la en Windows Azure.

El problema esta cuando envio el Request al dicho servicio:

<pre lang='lenguaje'>
var data;
jQuery.get(serviceUri, {},
function (data) {
console.log(" reponse :" + data);
}
, "json");
</pre>

El Request es el siguiente:

<pre lang='lenguaje'>
GET http://157.56.8.203/DefaultScopeSyncService.svc/defaultscope/DownloadChanges?id=7AE7C771-0A98-4A5D-A046-430DDB0A7917 HTTP/1.1
Host: 157.56.8.203
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Accept: application/json, text/javascript, */*
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Connection: keep-alive
Referer: http://localhost:49427/ListSample.htm
Origin: http://localhost:49427
</pre>

Y la respuesta del servicio esta:

<pre lang='lenguaje'>
HTTP/1.1 200 OK
Content-Length: 1388
Content-Type: application/json
Server: Microsoft-IIS/7.0
SyncServiceVersion: 1.0
X-Powered-By: ASP.NET
Date: Wed, 30 Nov 2011 11:34:55 GMT

{"d":{"__sync":{"moreChangesAvailable":false,"serv erBlob":"AAEAAAD\/\/\/\/\/AQAAAAAAAAAMAgAAAGVNaWNyb3NvZnQuU3luY2hyb25pemF0aW 9uLlNlcnZpY2VzLCBWZXJzaW9uPTQuMC4wLjAsIEN1bHR1cmU9 bmV1dHJhbCwgUHVibGljS2V5VG9rZW49ODk4NDVkY2Q4MDgwY2 M5MQUBAAAAK01pY3Jvc29mdC5TeW5jaHJvbml6YXRpb24uU2Vy dmljZXMuU3luY0Jsb2IFAAAAIDxDbGllbnRLbm93bGVkZ2U+a1 9fQmFja2luZ0ZpZWxkIDxDbGllbnRTY29wZU5hbWU+a19fQmFj a2luZ0ZpZWxkHDxJc0xhc3RCYXRjaD5rX19CYWNraW5nRmllbG QaPEJhdGNoQ29kZT5rX19CYWNraW5nRmllbGQaPE5leHRCYXRj aD5rX19CYWNraW5nRmllbGQHAQADAwIBbVN5c3RlbS5OdWxsYW JsZWAxW1tTeXN0ZW0uR3VpZCwgbXNjb3JsaWIsIFZlcnNpb249 NC4wLjAuMCwgQ3VsdHVyZT1uZXV0cmFsLCBQdWJsaWNLZXlUb2 tlbj1iNzdhNWM1NjE5MzRlMDg5XV1tU3lzdGVtLk51bGxhYmxl YDFbW1N5c3RlbS5HdWlkLCBtc2NvcmxpYiwgVmVyc2lvbj00Lj AuMC4wLCBDdWx0dXJlPW5ldXRyYWwsIFB1YmxpY0tleVRva2Vu PWI3N2E1YzU2MTkzNGUwODldXQIAAAAJAwAAAAYEAAAAJGM3Nj M2YTlmLTBhOTYtNDJhOC04ZDgxLTBhNDE5NTJmOTUyYgEKCg8D AAAAkAAAAAIAAAAFAAAAAAAAAAEAAAAAAAAABQAAEAAAAALHY2 qfCpZCqI2BCkGVL5UrebAhJqekSVCrBoALPwfgsQAAABgAABAB KAIAAAEAAAAVAAAAAgAAAAEAAAAAAAAAAQAAAAEAAAABAAAAAA AAAQ0AAAAXAAAAAQAAABYAAAABAAMAAAAAAQAAAAAAAAAZAQAA AAAL"},"results":[{"Id":"7ae7c771-0a98-4a5d-a046-430ddb0a7917","Name":"Santiago","Surname":"Dalto", "BirthDate":"\/Date(917913600000)\/","Gender":"M","__metadata":{"uri":"http:\/\/157.56.8.203\/DefaultScopeSyncService.svc\/Persons(Id=guid'7ae7c771-0a98-4a5d-a046-430ddb0a7917')","type":"DefaultScope.Persons"}}]}}
</pre>

El objeto data del script es siempre null, sin embargo el servicio retorna bien el resultado.
Alguien sabe que me puede estar pasando?

Saludos y muchas gracias!

Etiquetas: azure, framework, jquery, json, request, response, sync, javascript
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:38.