Foros del Web » Programación para mayores de 30 ;) » Java »

Problema con Tomcat 7.0.25 y Eclipse

Estas en el tema de Problema con Tomcat 7.0.25 y Eclipse en el foro de Java en Foros del Web. Hola, Recien estoy empezando a trabajar con Eclipse, y no he podido avanzar mucho ya que cuando ejecute no puedo ver la pagina, Estado HTTP ...
  #1 (permalink)  
Antiguo 16/02/2012, 06:42
 
Fecha de Ingreso: febrero-2012
Mensajes: 2
Antigüedad: 7 años, 9 meses
Puntos: 0
Problema con Tomcat 7.0.25 y Eclipse

Hola,
Recien estoy empezando a trabajar con Eclipse, y no he podido avanzar mucho ya que cuando ejecute no puedo ver la pagina,

Estado HTTP 404

Tengo instalado Tomcat 7.0.25. Lo hemos probado en Linux y Win7 sin obtener buenos resultados.

En la consola me aparece estos errores:

ADVERTENCIA: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:MiprimerJSP' did not find a matching property.
16-feb-2012 9:30:32 org.apache.coyote.AbstractProtocol init

GRAVE: Failed to initialize end point associated with ProtocolHandler ["http-bio-8080"]
java.net.BindException: Address already in use: JVM_Bind <null>:8080
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:391)
at org.apache.tomcat.util.net.AbstractEndpoint.init(A bstractEndpoint.java:554)
at org.apache.coyote.AbstractProtocol.init(AbstractPr otocol.java:409)
at org.apache.coyote.http11.AbstractHttp11JsseProtoco l.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:956)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardService.initInter nal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardServer.initIntern al(StandardServer.java:781)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina .java:595)
at org.apache.catalina.startup.Catalina.load(Catalina .java:620)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstr ap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:449)
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :383)
at java.net.ServerSocket.bind(ServerSocket.java:328)
at java.net.ServerSocket.<init>(ServerSocket.java:194 )
at java.net.ServerSocket.<init>(ServerSocket.java:150 )
at org.apache.tomcat.util.net.DefaultServerSocketFact ory.createSocket(DefaultServerSocketFactory.java:4 9)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:378)
... 17 more
16-feb-2012 9:30:32 org.apache.catalina.core.StandardService initInternal
GRAVE: No pude inicializar el conector [Connector[HTTP/1.1-8080]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8080]]
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:106)
at org.apache.catalina.core.StandardService.initInter nal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardServer.initIntern al(StandardServer.java:781)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina .java:595)
at org.apache.catalina.startup.Catalina.load(Catalina .java:620)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstr ap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:449)
Caused by: org.apache.catalina.LifecycleException: Falló la inicialización del manejador de protocolo
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:958)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
... 12 more
Caused by: java.net.BindException: Address already in use: JVM_Bind <null>:8080
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:391)
at org.apache.tomcat.util.net.AbstractEndpoint.init(A bstractEndpoint.java:554)
at org.apache.coyote.AbstractProtocol.init(AbstractPr otocol.java:409)
at org.apache.coyote.http11.AbstractHttp11JsseProtoco l.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:956)
... 13 more
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :383)
at java.net.ServerSocket.bind(ServerSocket.java:328)
at java.net.ServerSocket.<init>(ServerSocket.java:194 )
at java.net.ServerSocket.<init>(ServerSocket.java:150 )
at org.apache.tomcat.util.net.DefaultServerSocketFact ory.createSocket(DefaultServerSocketFactory.java:4 9)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:378)
... 17 more
16-feb-2012 9:30:32 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
16-feb-2012 9:30:32 org.apache.coyote.AbstractProtocol init
GRAVE: Failed to initialize end point associated with ProtocolHandler ["ajp-bio-8009"]
java.net.BindException: Address already in use: JVM_Bind <null>:8009
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:391)
at org.apache.tomcat.util.net.AbstractEndpoint.init(A bstractEndpoint.java:554)
at org.apache.coyote.AbstractProtocol.init(AbstractPr otocol.java:409)
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:956)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardService.initInter nal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardServer.initIntern al(StandardServer.java:781)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina .java:595)
at org.apache.catalina.startup.Catalina.load(Catalina .java:620)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstr ap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:449)
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :383)
at java.net.ServerSocket.bind(ServerSocket.java:328)
at java.net.ServerSocket.<init>(ServerSocket.java:194 )
at java.net.ServerSocket.<init>(ServerSocket.java:150 )
at org.apache.tomcat.util.net.DefaultServerSocketFact ory.createSocket(DefaultServerSocketFactory.java:4 9)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:378)
... 16 more
16-feb-2012 9:30:32 org.apache.catalina.core.StandardService initInternal
GRAVE: No pude inicializar el conector [Connector[AJP/1.3-8009]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[AJP/1.3-8009]]
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:106)
at org.apache.catalina.core.StandardService.initInter nal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardServer.initIntern al(StandardServer.java:781)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina .java:595)
at org.apache.catalina.startup.Catalina.load(Catalina .java:620)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstr ap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:449)
Caused by: org.apache.catalina.LifecycleException: Falló la inicialización del manejador de protocolo
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:958)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
... 12 more
Caused by: java.net.BindException: Address already in use: JVM_Bind <null>:8009
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:391)
at org.apache.tomcat.util.net.AbstractEndpoint.init(A bstractEndpoint.java:554)
at org.apache.coyote.AbstractProtocol.init(AbstractPr otocol.java:409)
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:956)
... 13 more
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :383)
at java.net.ServerSocket.bind(ServerSocket.java:328)
at java.net.ServerSocket.<init>(ServerSocket.java:194 )
at java.net.ServerSocket.<init>(ServerSocket.java:150 )
at org.apache.tomcat.util.net.DefaultServerSocketFact ory.createSocket(DefaultServerSocketFactory.java:4 9)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:378)
... 16 more
...

Espero que me puedan ayudar, desde ya Muchas Gracias
  #2 (permalink)  
Antiguo 16/02/2012, 07:11
 
Fecha de Ingreso: febrero-2012
Mensajes: 2
Antigüedad: 7 años, 9 meses
Puntos: 0
Respuesta: Problema con Tomcat 7.0.25 y Eclipse

Ya hemos solucionado el problema. Espero que les sirva...
Hay que desinstalar Tomcat y volverlo a instalar. En el ultimo recuadro de instalacion dice Ejecutar Tomcat ahi hay que poner NO. Luego ejecutar Eclipse y sale andando.
Saludos
  #3 (permalink)  
Antiguo 18/02/2012, 18:11
 
Fecha de Ingreso: agosto-2011
Ubicación: Madrid
Mensajes: 185
Antigüedad: 8 años, 3 meses
Puntos: 29
Respuesta: Problema con Tomcat 7.0.25 y Eclipse

El error venía por estar ya ocupado el puerto de escucha que trae por defecto Tomcat (8080)?

Etiquetas: eclipse, jar, jsp, tomcat
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:07.