Foros del Web » Programación para mayores de 30 ;) » Java »

problema eclipse tomcat

Estas en el tema de problema eclipse tomcat en el foro de Java en Foros del Web. Hola: tengo un problema al crear un dynamic web project y hacerlo correr en el servidor, lo tengo todo configurado, y al hacer run on ...
  #1 (permalink)  
Antiguo 10/05/2011, 03:15
 
Fecha de Ingreso: julio-2010
Mensajes: 29
Antigüedad: 9 años, 2 meses
Puntos: 3
problema eclipse tomcat

Hola:

tengo un problema al crear un dynamic web project y hacerlo correr en el servidor, lo tengo todo configurado, y al hacer run on server sobre el proyecto pasa lo siguiente.
Se inicia el server, sin dar ningun error y me aparece el server started y el proyecto syncronized, sin embargo al abrirse el localhost:8080/nombreproyecto/index.jsp me dice que no se encuentra, mi duda esta en si el workspace de trabajo debe ser el mismo del tomcat, ya que imagino que el servidor buscara el nombreproyecto dentro de su webapp y no dentro del workspace. Pero si pruebo con algun proyecto que tenga dentro del webapp y que desde el cualquier navegador funciona desde el eclipse tampoco lo encuentra, no se si es normal ya que deberia estar synchronized o es que hay algo mal.

Deciros que he seguido todas las instruciones para añadir el server en eclipse y supongo que este bien ya que cuando me pide el directorio del servidor si pongo uno distinto al que tengo me da un error de que no encuentra el directorio lib.

Muchas gracias
  #2 (permalink)  
Antiguo 10/05/2011, 06:44
Avatar de chuidiang
Colaborador
 
Fecha de Ingreso: octubre-2004
Mensajes: 3.773
Antigüedad: 14 años, 11 meses
Puntos: 454
Respuesta: problema eclipse tomcat

Hola:

Puedes probar lo siguiente. Botón derecho sobre el fichero index.jsp y un "run as"->"run on a server". Esto te arrancará el tomcat si no está arrancado y te abrirá directamente el navegador (el del sistema operativo o el interno de eclipse, según lo tengas configurado) y ahí podrás ver la URL exacta.

En mi caso, la url es http://localhost:8080/NombreProyectoEclipse/fichero.jsp

Se bueno.
__________________
Apuntes Java
Wiki de Programación
  #3 (permalink)  
Antiguo 22/07/2011, 13:47
 
Fecha de Ingreso: julio-2011
Ubicación: Bogotá
Mensajes: 6
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: problema eclipse tomcat

Tengo el mismo problema, con la diferencia que cuando ejecuto la aplicacion web todo está correcto, pero cunado corro la aplicación con el firefox me aparece la página incompleta, los tags de jsf no me salen, las imagenes tampoco, tengo un footer y header y tampoco salen sin embargo el texto del context si sale, cuando lo intento abrir por IE no abre la aplicación que en un estado "conectando", no se que puede ser.

Alguien me puede ayudar a arreglar el problemita porfavor
  #4 (permalink)  
Antiguo 23/07/2011, 22:59
 
Fecha de Ingreso: julio-2011
Ubicación: México
Mensajes: 11
Antigüedad: 8 años, 2 meses
Puntos: 10
Respuesta: problema eclipse tomcat

Efectivamente, la direccion que yo pongo para ver una pagina JSP es:

http://localhost:8080/miprog/Index.jsp

aunque tambien funciona:

http://127.0.0.1:8080/miprog/Index.jsp

Etiquetas: eclipse, tomcat
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 3 personas




La zona horaria es GMT -6. Ahora son las 02:24.