Foros del Web » Programación para mayores de 30 ;) » Java »

Problema al enviar un correo

Estas en el tema de Problema al enviar un correo en el foro de Java en Foros del Web. Tengo un problema al enviar un correo con un servidor de aplicaciones JBoss. El problema es que al enviar un correo con un fichero adjunto, ...
  #1 (permalink)  
Antiguo 22/09/2011, 05:08
 
Fecha de Ingreso: septiembre-2007
Mensajes: 268
Antigüedad: 14 años, 10 meses
Puntos: 8
Problema al enviar un correo

Tengo un problema al enviar un correo con un servidor de aplicaciones JBoss. El problema es que al enviar un correo con un fichero adjunto, envia el correo, pero lo envia vacio, es decir, ni el texto del mensaje ni los archivos adjuntos.

El problema es que las mismas clases y la misma prueba funciona con en tomcat.

Hay que configurar de alguna manera el servidor o tratar el envio de manera distinta si es un JBoss.

Muchas gracias por las molestias.
  #2 (permalink)  
Antiguo 22/09/2011, 05:36
Avatar de Fuzzylog  
Fecha de Ingreso: agosto-2008
Ubicación: En internet
Mensajes: 2.511
Antigüedad: 14 años
Puntos: 188
Respuesta: Problema al enviar un correo

Eso igual se debe a que en JBoss hay que configurar el servicio de mailing por separado.

https://www.ideasoft.biz/wiki/displa...+Mail+de+JBoss
  #3 (permalink)  
Antiguo 26/09/2011, 10:29
 
Fecha de Ingreso: septiembre-2007
Mensajes: 268
Antigüedad: 14 años, 10 meses
Puntos: 8
Respuesta: Problema al enviar un correo

No la respuesta era mas sencilla. Me faltaba un jar.

El jar era activation.jar.

Etiquetas: correo, aplicaciones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:53.