Foros del Web » Creando para Internet » CSS »

2 Problemas en IE con CSS

Estas en el tema de 2 Problemas en IE con CSS en el foro de CSS en Foros del Web. El primero: http://www.arubamax.com/component/pa...art/Itemid,31/ No consigo que se vea en el IE igual que en el FFX. El IE parece no tener en cuenta el atributo ...
  #1 (permalink)  
Antiguo 07/08/2006, 17:08
Avatar de pmuruaga  
Fecha de Ingreso: diciembre-2005
Mensajes: 127
Antigüedad: 12 años
Puntos: 0
Sonrisa 2 Problemas en IE con CSS

El primero:

http://www.arubamax.com/component/pa...art/Itemid,31/

No consigo que se vea en el IE igual que en el FFX. El IE parece no tener en cuenta el atributo float, la tercera columna se baja, todo se corre a la izq

... y el segundo:

Tengo un boton cuya imagen de fondo aparece en el FFX pero en el IE no, quiesiera saber cual es el problema. En los otros botones si me toma los fondos pero hay uno que no, este ultimo tiene una hoja de estilos diferente.

Muchas Gracias!!! Please salvenme!!
  #2 (permalink)  
Antiguo 09/08/2006, 09:03
Avatar de Apolo
Colaborador
 
Fecha de Ingreso: abril-2003
Ubicación: ubicado
Mensajes: 7.961
Antigüedad: 14 años, 8 meses
Puntos: 109
Tema movido desde el foro de Aplicaciones pre-fabricadas hacia el foro de CSS.

Saludos.
__________________
Planes VPS en el mundo > DirectorioVPS
Visita los foros de hosting de ComunidadHosting
  #3 (permalink)  
Antiguo 09/08/2006, 18:52
 
Fecha de Ingreso: agosto-2006
Ubicación: Madrid
Mensajes: 95
Antigüedad: 11 años, 4 meses
Puntos: 0
Mmmm... la verdad es que no entiendo muy bien tu planteamiento de columnas. ¿Por qué en el contenedor principal pones la columna de la izquierda, y luego otro contenedor que (valga la rebuznancia) contiene el contenido principal y la columna de la derecha?

¿No sería más fácil usar un solo contenedor con 3 columnas? Bueno, al margen de eso, he visto que usas XHTML Transitional, y sin embargo colocas el prólogo XML. Estrictamente hablando, es correcto, pero IE tiene otro concepto universal de lo que es correcto e incorrecto, y en vez de renderizar en modo estandar, renderiza en modo "quirks". Prueba a quitar el prólogo XML (al ser XHTML transitional, no es obligatorio)

Leete esto, igual te ayuda: http://www.quirksmode.org/css/quirksmode.html
  #4 (permalink)  
Antiguo 09/08/2006, 19:00
 
Fecha de Ingreso: agosto-2006
Ubicación: Madrid
Mensajes: 95
Antigüedad: 11 años, 4 meses
Puntos: 0
Por otra parte, prueba como solución, a poner "columna3" antes de "main", y con la propiedad "float:right"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:34.