Foros del Web » Creando para Internet » CSS »

Ayuda Css

Estas en el tema de Ayuda Css en el foro de CSS en Foros del Web. Resulta que cuando visito mi web, me encuentro con ese horrible header: http://flatpress.site11.com/ Alguien sabe por que puede ser?? :(...
  #1 (permalink)  
Antiguo 31/08/2010, 17:45
Avatar de franextreme  
Fecha de Ingreso: septiembre-2009
Mensajes: 110
Antigüedad: 8 años, 2 meses
Puntos: 0
Ayuda Css

Resulta que cuando visito mi web, me encuentro con ese horrible header:

http://flatpress.site11.com/

Alguien sabe por que puede ser?? :(
  #2 (permalink)  
Antiguo 31/08/2010, 17:56
Avatar de mayid
Colaborador
 
Fecha de Ingreso: marzo-2009
Ubicación: BsAs
Mensajes: 4.014
Antigüedad: 8 años, 8 meses
Puntos: 101
Respuesta: Ayuda Css

Porque te estarían por dar la pagina de baja?

Yo también alojo mis paginas en ese host. Lo que te dice el mensaje es que tenés contenidos que quizás van en contra de sus terminos de uso (TOC).

Teníamos música con derechos de autor o algo así?
  #3 (permalink)  
Antiguo 01/09/2010, 07:58
Avatar de franextreme  
Fecha de Ingreso: septiembre-2009
Mensajes: 110
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: Ayuda Css

Pero que contenidos, solo es un simple flatpress que estoy modificando para crear una plantilla :/
  #4 (permalink)  
Antiguo 01/09/2010, 08:19
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Ayuda Css

Entre otros errores (pásela por el validador) tiene mal algunas rutas a imágenes que coloca vía css:
Cita:
url("../imgs//img02.jpg") no-repeat left top;
  #5 (permalink)  
Antiguo 01/09/2010, 13:32
Avatar de mayid
Colaborador
 
Fecha de Ingreso: marzo-2009
Ubicación: BsAs
Mensajes: 4.014
Antigüedad: 8 años, 8 meses
Puntos: 101
Respuesta: Ayuda Css

Oh! Ayer cuando visité tu pagina había un cartel de 000webhost.

Ahora si puedo ver de que se trata ese horrible header.

Dejo un enlace al validador W3C: http://jigsaw.w3.org/css-validator/
  #6 (permalink)  
Antiguo 03/09/2010, 10:48
Avatar de franextreme  
Fecha de Ingreso: septiembre-2009
Mensajes: 110
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: Ayuda Css

kseso? gracias por tu ayuda, pero la ruta está perfecta, verás lo que he hecho a sido el editar el entry-default.tpl, pero cuando desmonto todo lo que he hecho, en el entry-default, el header se ve como quiero, asi que no es un error de rutas :S

Mayid gracias por tu ayuda, pero ya lo he pasado por el validator y no tiene errores importantes :S
  #7 (permalink)  
Antiguo 03/09/2010, 11:19
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Ayuda Css

Cita:
Iniciado por franextreme Ver Mensaje
kseso? gracias por tu ayuda, pero la ruta está perfecta, verás lo que he hecho a sido el editar el entry-default.tpl, pero cuando desmonto todo lo que he hecho, en el entry-default, el header se ve como quiero, asi que no es un error de rutas :S

Mayid gracias por tu ayuda, pero ya lo he pasado por el validator y no tiene errores importantes :S
Yo lo que veo es:

Fíjese que lo que he seleccionado son los /li/ de su menú, donde la ruta del background incluye doble barra: //
Y sí, debería mirar el tema de los errores, ya que entre otras cosas le marca etiquetas no cerradas y elementos donde no pueden ir contenidos (el que yo le señalo es un ejemplo).
  #8 (permalink)  
Antiguo 03/09/2010, 13:34
Avatar de franextreme  
Fecha de Ingreso: septiembre-2009
Mensajes: 110
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: Ayuda Css

Bueno, he decidido volver a editar el css y quitar esas lineas que dices, ya las he quitado y he revisado de arriba a abajo el html, y la verdad es que no entiendo...

Entry-default:

Código:
<div id="page">
	<div id="page-bgtop">
		<div id="content">
			<div class="post">
	            <div class="meta" class="date {$date|date_format:"y-%Y m-%m d-%d"}">				
				<h2 class="title"><a href="{$id|link:post_link}">{$subject|tag:the_title} </a></h2>
				{include file=shared:entryadminctrls.tpl}
						<div class="entry">
						{$content|tag:the_content}
			            </div>
			<ul class="info">
				<li><span>{$author}</span><span>{$date|date_format:"%e"}, {$date|date_format:"%b"}, {$date|date_format:"%Y"}</span><span>{if ($categories)} {$categories|@filed}{/if}</span></li>
				{if !(in_array('commslock', $categories) && !$comments)}
				<li><a href="{$id|link:comments_link}#comments">{$comments|tag:comments_number} {if isset($views)}(<strong>{$views}</strong> views){/if}</a></li>
				{/if}
			</ul>			
	</div><!-- end of .entry -->
Header:

Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<title>{$flatpress.title|tag:wp_title:'&raquo;'}{$flatpress.page}</title>
	<meta http-equiv="Content-Type" content="text/html; charset={$flatpress.charset}" />
	{action hook=wp_head}
</head>

<body>
<div id="header-wrapper">
	<div id="header">
		<div id="menu">
			<ul>
				{widgets pos=menubar}
			{$content}
		{/widgets}
			</ul>
		</div>
<div id="container">

	<div id="menu">
	
		{widgets pos=menubar}
			{$content}
		{/widgets}
	</div><!-- end of #menu -->
			<div id="search">
			<form method="get" action="search.php">
				<fieldset>
					<input type="text" name="s" id="search-text" size="15" />
					<input type="submit" id="search-submit" value="GO" />
				</fieldset>
			</form>
		</div>
<div id="logo">
	
	<h1><a href="{$flatpress.www}" title="{$flatpress.title}">{$flatpress.title}</a></h1>
	<p><em>{$flatpress.subtitle}</em></p>
</div>
<hr />
<!-- end #logo -->
	</div><!-- end of #header -->
Parece estar todo en orden :S

Última edición por franextreme; 03/09/2010 a las 13:46
  #9 (permalink)  
Antiguo 03/09/2010, 14:26
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Ayuda Css

Mire la importancia de validar los códigos y corregir los errores detectados:
el archivo print.css es un html renombrado
los /<div id="main">/ /<div id="page">/ /<div id="page-bgtop">/ están sin cerrar
En el menú no ha corregido las dos etiquetas /ul/ consecutivas. Borre una de ellas y su cierre.
En el background de los /li/ del menú usa una imagen de 1px de ancho y no re-repeat.

Vea de corregir eso y a ver qué pasa.
  #10 (permalink)  
Antiguo 03/09/2010, 17:10
Avatar de franextreme  
Fecha de Ingreso: septiembre-2009
Mensajes: 110
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: Ayuda Css

Hola Kseso? nuevamente gracias por tu ayuda:

Respecto al archivo print.css, lo que he quitado.

He cerrado loas divs page y page-bgtop, el div "main" no lo he encontrado en la zona que he editado.

Etiquetas /ul/ eliminadas ambas.

En el background, usa 10px de ancho y cambie no re-repeat por repeat.

Y ahora el header se ve peor, la imagen deforme se ha desplazado muchisimo más abajo, pero al menos el menú se ve, pero no como ha de ser, pues el color el diferente, y deberia de estar más abajo al igual que la barra de search... :S
  #11 (permalink)  
Antiguo 03/09/2010, 17:50
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Ayuda Css

Según el validador sigue usted teniendo elementos sin cerrar. Y para mi es imposible saber dónde termina cada cual. A no ser por el método "prueba y error", cosa que, permítame, no haré yo.

Corrija esos errores, todos, y vemos qué ocurre.

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:33.