Foros del Web » Creando para Internet » CSS »

body y background

Estas en el tema de body y background en el foro de CSS en Foros del Web. wola! Estoy empezando a maquetar con css y me he encontrado con un problema poco usual y bastante tonto... Resulta que la propiedad background no ...
  #1 (permalink)  
Antiguo 27/04/2004, 05:23
Avatar de roninrojo  
Fecha de Ingreso: abril-2003
Ubicación: España
Mensajes: 103
Antigüedad: 14 años, 8 meses
Puntos: 0
body y background

wola! Estoy empezando a maquetar con css y me he encontrado con un problema poco usual y bastante tonto... Resulta que la propiedad background no me funciona en la etiqueta body. He comprobado cien veces que este bien escrito así que no se que puede fallar. Sin embargo si duplico la etiquta body, la coloco al final de la etiqueta style y especifico en esta el background si que me lo aplica..... es muy raro.... si alguien sabe la respuesta se lo agradezco muchisimo
Saludos
__________________
www.albertocarazo.com
  #2 (permalink)  
Antiguo 27/04/2004, 05:34
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola, roninrojo.

La forma habitual de poner un fondo a la página sería:

<body style="background-image:url('tuimagen.gif')" />

o

<body style="background-color:red">

De todas formas si pones el código que están utilizando quizás alguien vea donde está el problema.

Saludos,
  #3 (permalink)  
Antiguo 27/04/2004, 06:06
Avatar de roninrojo  
Fecha de Ingreso: abril-2003
Ubicación: España
Mensajes: 103
Antigüedad: 14 años, 8 meses
Puntos: 0
Hola JavierB. Bueno yo no quiero colocar el estilo directamente en el body sino en un archivo .css dentro de la etiqueta body{} , como tu lo pones si funciona.
El codigo es muy simple:

body {
padding:0px;
}

body {
background:#ccc;
}

En la primera etiqueta tengo otra propiedad cualquiera pero el background no funciona, si la duplico y en esta especifico el background si funciona, y es bastante guarro tener que ponerlo asi. Tengo mas codigo css, quizá hace algun tipo de conlicto con otra etiqueta... no se.
Alguien sabe??????
__________________
www.albertocarazo.com
  #4 (permalink)  
Antiguo 27/04/2004, 14:19
Avatar de PatomaS
Colaborador
 
Fecha de Ingreso: marzo-2004
Ubicación: En alguna otra parte
Mensajes: 4.656
Antigüedad: 13 años, 9 meses
Puntos: 63
Hola

Eso que dices es bastante raro, mira este es un ejemplo de un estilo para el body que funciona a la perfección:

Código:
body {
	background-color: #ffffff;
	font-family: Verdana, Arial, Helvetica, sans-serif;
	font-size: 10pt;
	color: #000000;
	padding: 0;
	border: 0;
}
y para incluir el archivo css en las páginas html, l oque tienes que hacer, es incluir esta línea entre <head> y </head>:

Código:
<link rel="stylesheet" href="tu_estilo.css" type="text/css" />
Espero que te sirva.

SUerte

Felicidad
__________________
¡ hey, hou, hou, hey !
  #5 (permalink)  
Antiguo 28/04/2004, 03:06
Avatar de roninrojo  
Fecha de Ingreso: abril-2003
Ubicación: España
Mensajes: 103
Antigüedad: 14 años, 8 meses
Puntos: 0
Ok patomas, gracias. Es un error bastante raro, sigue persistiendo, supongo qure se debe a un error de sintaxis que no logro localizar en alguna de las etquetas del archivo css. Si me sigue dando quebraderos de cabeza despues de exprimirme los sesos volveré a postearlo. Muchas gracias
__________________
www.albertocarazo.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:52.