Foros del Web » Creando para Internet » CSS »

Cómo validar en diferentes versiones de navegadores?

Estas en el tema de Cómo validar en diferentes versiones de navegadores? en el foro de CSS en Foros del Web. Hola, Hoy casi me arranco el poco cabello que tengo al ver algo horroroso. Hice un sitio el cual cuidé minuciosamente que funcionara en firefox, ...
  #1 (permalink)  
Antiguo 23/06/2005, 18:51
 
Fecha de Ingreso: febrero-2005
Mensajes: 135
Antigüedad: 12 años, 9 meses
Puntos: 0
Pregunta Cómo validar en diferentes versiones de navegadores?

Hola,
Hoy casi me arranco el poco cabello que tengo al ver algo horroroso. Hice un sitio el cual cuidé minuciosamente que funcionara en firefox, iexplorer y opera, en sus versiones actuales. Al momento de ir a revisarlo en una computadora nueva me di cuenta de que mi header se movia completamente a un lado !!

Descubrí que eso se debió a que la dichosa computadora tenía instalado el iexplorer 5 !!!!

Mi pregunta despues de tánto rollo es:

¿cómo puedo validar en diferentes versiones de los navegadores?
El caso de iexplorer es especial ya que si te descargas la nueva versión te quita la antigua, además de que es muy dificil encontrar las versiones anteriores.
Además ya que estamos en esto me gustaría validar para MAC aunque por desgracia no tengo una de esas

¿Hay alguna liga dónde te validen?

Gracias !
  #2 (permalink)  
Antiguo 24/06/2005, 00:39
Avatar de CORE
Usuario no validado
 
Fecha de Ingreso: abril-2002
Ubicación: Merida
Mensajes: 2.165
Antigüedad: 15 años, 8 meses
Puntos: 3
Se esta volviendo una obsecion esto de las validaciones, yo creo que no deberias de preocuparte por los viejos navegadores, si realmente te preocupan mejor haz tu web en HTML4 no puedes estar al mismo paso de los usuarios que no actulizan su software debes de ir una paso mas. asi es como todos han ido actulizando su navegador al no ver correctamente los documentos deben de ir pensando en actulizarse, ¿no crees?

saludos

Última edición por CORE; 24/06/2005 a las 00:49
  #3 (permalink)  
Antiguo 24/06/2005, 09:34
 
Fecha de Ingreso: febrero-2005
Mensajes: 135
Antigüedad: 12 años, 9 meses
Puntos: 0
Pues si, por una parte tienes razón Core. Es necesario que los usuarios actualicen sus navegadores, y de preferencia que no usen el explorer . Creo que esto es un dilema cotidiano, aunque tambien no se puede hacer a un lado tan de tajo a las personas que tienen navegadores no estandares. Creo que es una situación similar a la accesibilidad para personas con deficiencias físicas, no los puedes hacer de lado solo porque sí. Bueno, esa es mi opinion.

Gracias.
  #4 (permalink)  
Antiguo 24/06/2005, 20:39
Avatar de CORE
Usuario no validado
 
Fecha de Ingreso: abril-2002
Ubicación: Merida
Mensajes: 2.165
Antigüedad: 15 años, 8 meses
Puntos: 3
Yo digo que hagas una deteccion de version y navegador ,dependiendo de esa carges la hoja de estilos asi te ahorras estar parchando tu CSS y asi mejor tienes una por navegador (que no creo que varie mucho)
Yo por ejemplo tenia unos errores con IE y FF al final mejor hice una hoja para cada uno te dejo la direccion entra con IE y luego con FF para que veas la diferencia Aqui
Cita:
Iniciado por yconoclasta
Creo que es una situación similar a la accesibilidad para personas con deficiencias físicas, no los puedes hacer de lado solo porque sí. Bueno, esa es mi opinion.

Gracias.
Alguna vez has intentado crear una web para discapacitados?
A estos entre menos codigo tenga que leer su lector de de pantalla es muchisimo mejor.

Alguna vez has oido como escuchan los debiles visuales una pagina o sabes por lo menos como usar alguna de estas etiquetas que pueden servir a estas paginas? y no me digas que voice-family: "\"}\""; voice-family:inherit; nadie se preocupa por la accesibilidad.


saludos
  #5 (permalink)  
Antiguo 24/06/2005, 21:27
 
Fecha de Ingreso: febrero-2005
Mensajes: 135
Antigüedad: 12 años, 9 meses
Puntos: 0
Entiendo lo que dices y te lo agradezco Core. Aun así, no resuelve eso mi pregunta original de cómo puedo hacer pruebas en navegadores más antiguos, en específico el iexplorer ya que no deja instalar una versión en la computadora más antigua de la que ya se tiene.

Saludos
  #6 (permalink)  
Antiguo 24/06/2005, 22:34
Avatar de CORE
Usuario no validado
 
Fecha de Ingreso: abril-2002
Ubicación: Merida
Mensajes: 2.165
Antigüedad: 15 años, 8 meses
Puntos: 3
Hacer convivir varias versiones de explorer

Multiple IEs in Windows Por si te hiciera falta un Navegador y te puedes bajar de aqui todos los explorers para que no tengas que mover los registros, pero creo que no furulan los Comentarios Condicionales

saludos

Última edición por CORE; 24/06/2005 a las 22:48
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:20.