Foros del Web » Creando para Internet » CSS »

CSS e imágenes en IE: No se ven

Estas en el tema de CSS e imágenes en IE: No se ven en el foro de CSS en Foros del Web. Hola a todos, a ver si alguien me puede echar una mano: Utilizo WordPress 1.5.2, la plantilla que utilizo es Journalized Winter 1.00 Cuando inserto ...
  #1 (permalink)  
Antiguo 28/08/2005, 05:12
 
Fecha de Ingreso: agosto-2005
Mensajes: 2
Antigüedad: 12 años, 3 meses
Puntos: 0
CSS e imágenes en IE: No se ven

Hola a todos, a ver si alguien me puede echar una mano:

Utilizo WordPress 1.5.2, la plantilla que utilizo es Journalized Winter 1.00

Cuando inserto una imagen en un post, si la inserto tal cual todo va bien, con el texto por arriba, texto por abajo, y a los lados huecos en blanco. Pero si quiero que el texto quede alineado a la izquierda o a la derecha, añado en el código de la imagen "<img src="imgen.jpg" />" le pongo align="left" o align="right" y el texto se alinea en el lado contrario, alrededor de la imagen.

El problema que tengo es que IE, respeta el espacio donde va la imagen y no pone texto por encima. Pero la imagen queda por debajo del espacio reservado para el texto en lugar de por encima, no sé si me explico. El caso es que como el fondo del texto no es transparente ni he conseguido ponérselo, el resultado es que la imagen no se ve porque queda tapada.
Les adjunto una captura de pantalla para que vean a lo que me refiero:
muchoquedecir.mu.funpic.org/trasteando.png

Con el único navegador con el que falla es con IE para PC, con el resto se ve bien. ¿Alguien sabe qué parte debo tocar en la hoja de estilos para conseguir el efecto deseado?

He probado a ponerle el background: transparent en el apartado storyContent pero no funciona. Pienso que tal vez funcionaría si pusiera por defecto la imagen en la capa superior, pero no sé cómo hacerlo. Este es el código que utilizo en la plantilla CSS para las imágenes:

img {
border-style: none;
display: block;
}

.images {
padding: 0px;
background: transparent;
border: none;
display: inline block;

¿Alguna idea?
Gracias!
  #2 (permalink)  
Antiguo 28/08/2005, 07:24
 
Fecha de Ingreso: julio-2005
Mensajes: 220
Antigüedad: 12 años, 4 meses
Puntos: 0
Prueba con la propieda z-index de css.

z-index

Salu2!
  #3 (permalink)  
Antiguo 28/08/2005, 15:21
 
Fecha de Ingreso: agosto-2005
Mensajes: 2
Antigüedad: 12 años, 3 meses
Puntos: 0
¡Sí, éso era!: un problema con las capas

Ya he conseguido solucionarlo: lo he arreglado poniéndole en el CSS a la definición de la imagen z-index=2 y al contenido z-index=1, y así consigo poner la imagen en la capa superior.

¡Gracias!
  #4 (permalink)  
Antiguo 28/08/2005, 15:28
 
Fecha de Ingreso: julio-2005
Mensajes: 220
Antigüedad: 12 años, 4 meses
Puntos: 0
Me alegro :D

Salu2!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:30.