Foros del Web » Creando para Internet » CSS »

css y explorer 8 modo estandar¿?

Estas en el tema de css y explorer 8 modo estandar¿? en el foro de CSS en Foros del Web. Hola a [email protected] llevo un par de días dandole vueltas a esto. tengo a grandes rasgos lo siguiente. <div><div></div> <ul><li></li>....</ul></div> con su contenido y sus ...
  #1 (permalink)  
Antiguo 20/07/2009, 02:38
 
Fecha de Ingreso: noviembre-2007
Mensajes: 382
Antigüedad: 10 años
Puntos: 16
css y explorer 8 modo estandar¿?

Hola a [email protected]

llevo un par de días dandole vueltas a esto.
tengo a grandes rasgos lo siguiente.
<div><div></div> <ul><li></li>....</ul></div> con su contenido y sus clases dentro de las etiquetas. Me es dificil poner las propiedades de las clases por que se generan en funcion de los ids, que se generan a partir del contenido de dentro, pero bueno.

Se viene viendo perfectamente con todas las versiones de firefox, con explorer 4.5, 5, 6, 6.5, 7, chrome, opera, safari,... creo que netscape también.
El caso es que con explorer 8 la lista se me sale del div contenedor.
He probado ya varias maneras de arreglar esto poniendo la lista dentro de tablas y de divs y no se arregla por lo que he llegado a la conclusion que hay alguna propiedad css que el navegador se la está pasando por alto y he encontrado este artículo http://www.adslfaqs.com.ar/internet-...modo-estandar/
Quería preguntaros si sabeis que expresiones son las que se está saltando el navegador, algún listado o algo, por que no encuentro nada. y bueno saber también como se quita el modo estandar para ver si quitandolo se ve bien todo, pero creo que esto ya no toca aqui, lo dejo caer por si acaso.
Muchas gracias
__________________________________________________ ____
edito: a la derecha de la la barra de direcciones sale un dibujo de una hoja rota. ahí se quita el modo estandar y este div se ve correctamente, asi que ya he dado un primer paso, localizar el problema. A ver ahora como solucionarlo.
__________________________________________________ _______________________
Edito de nuevo: Veo que tengo que ir a una sección del navegador que se llama síntomas, pero no la veo, aqui se supone que saldrán los fallos, pero no la veo aaahh!!
y vuelvo a editar: parece ser que la lista de atributos es esta: http://msdn.microsoft.com/en-us/library/cc351024(VS.85).aspx#lists

Última edición por manzarinaa; 20/07/2009 a las 02:57
  #2 (permalink)  
Antiguo 21/07/2009, 12:06
Avatar de deirdre  
Fecha de Ingreso: mayo-2009
Mensajes: 690
Antigüedad: 8 años, 7 meses
Puntos: 44
Respuesta: css y explorer 8 modo estandar¿?

Hola manzarinaa

Partiendo de que dices que tu página se muestra perfectamente en la mayoría de los navegadores llamados 'buenos' (ff, opera, safari, etc) y que también está ajustada para ie6 y ie7, la solución rápida, sencilla y eficiente es que añadieras un meta que obligue a ie8 a comportarse como ie7, de esta forma:

Inmediatamente después de <head>, coloca esto:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

De esta forma no tendrías que tocar nada en tu código y te tendría que funcionar bien en todos los browsers.

Comenta algo.

Bye
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:09.