Foros del Web » Creando para Internet » CSS »

El CSS no me funciona con AJAX

Estas en el tema de El CSS no me funciona con AJAX en el foro de CSS en Foros del Web. Hola a todos! La pregunta es simple, y espero que la solución tambien ^^. Tengo una division donde quiero cargar un arbol en css con ...
  #1 (permalink)  
Antiguo 22/05/2009, 06:53
 
Fecha de Ingreso: octubre-2007
Mensajes: 36
Antigüedad: 10 años, 1 mes
Puntos: 0
El CSS no me funciona con AJAX

Hola a todos!

La pregunta es simple, y espero que la solución tambien ^^.

Tengo una division donde quiero cargar un arbol en css con AJAX. Se trata del tipico jtree en donde se pueden desplegar sus carpetas y ver lo que hay dentro.

El tema es que todo funciona correctamente pero cuando recargo este arbol con AJAX, me sale completamente desplegado y aunque le de a alguna carpeta, no se pliega. Es como si no me cogiera el CSS, o no se ejecute el javascript.

Alguna sugerencia?

Gracias!

Última edición por behere; 22/05/2009 a las 08:07
  #2 (permalink)  
Antiguo 22/05/2009, 08:42
 
Fecha de Ingreso: octubre-2007
Mensajes: 36
Antigüedad: 10 años, 1 mes
Puntos: 0
Respuesta: El CSS no me funciona con AJAX

Vale, ya lo he solucionado volviendo a llamar la funcion de jtree cada vez que recargo:

$("#main").treeview({
collapsed: true,
animated: "fast",
unique: false,
persist: "location"
});
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:57.