Foros del Web » Creando para Internet » CSS »

Estilo de línea doble en Firefox

Estas en el tema de Estilo de línea doble en Firefox en el foro de CSS en Foros del Web. Saludos, tengo este código: img { background-color: #A504BD; border-style: double; border-color: #7A038C; border-width: 3px; margin: 8px,8px,8px,0px; } Y no entiendo bien por qué en Firefox ...
  #1 (permalink)  
Antiguo 09/02/2005, 09:52
 
Fecha de Ingreso: octubre-2003
Ubicación: Madrid
Mensajes: 320
Antigüedad: 14 años, 1 mes
Puntos: 0
Estilo de línea doble en Firefox

Saludos, tengo este código:

img {

background-color: #A504BD;
border-style: double;
border-color: #7A038C;
border-width: 3px;
margin: 8px,8px,8px,0px;

}


Y no entiendo bien por qué en Firefox no sale una línea doble bordeando las imágenes, sino una sola, más gruesa.
  #2 (permalink)  
Antiguo 09/02/2005, 23:07
 
Fecha de Ingreso: octubre-2003
Ubicación: Madrid
Mensajes: 320
Antigüedad: 14 años, 1 mes
Puntos: 0
Por favor, una ayudita. :)
  #3 (permalink)  
Antiguo 09/02/2005, 23:53
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 4 meses
Puntos: 1
mira mas cerca :)

Hay una linea doble y un color de fondo que definiste con background-color: #A504BD;

IE no interpreta el color de fondo y solo sabe usar blanco. Quita el background-color si quieres el mismo aspecto

Un detalle, tu sintaxis para margin es incorrecta, no debes poner comas (y la unidad no es obligatoria para el valor 0):
margin: 8px 8px 8px 0;

Limpiando un poco :

img {
border: 3px double #7A038C;
margin: 8px 8px 8px 0px;
}
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
  #4 (permalink)  
Antiguo 10/02/2005, 00:12
 
Fecha de Ingreso: octubre-2003
Ubicación: Madrid
Mensajes: 320
Antigüedad: 14 años, 1 mes
Puntos: 0
Muchas gracias, PascalC.

He hecho lo que me has dicho, y ya la veo doble también en Firefox. Lo que pasa es que, ahora, hay una línea doble rodeando una imagen que no debería llevarla. Y eso que tiene una clase especial puesta:

img.nada { background: transparent; border:none; }
  #5 (permalink)  
Antiguo 10/02/2005, 00:20
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 4 meses
Puntos: 1
pues depende del contexto de tu pagina y del codigo exacto. Con las 2 lineas que das aqui efectivamente no deberia haber border alrededor de la imagen con clase "nada'', seguramente hay otra regla que entra en conflicto o tu imagen esta dentro de un enlace y no has anulado el borde de las imagenes links :
a img {border:none;}
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
  #6 (permalink)  
Antiguo 10/02/2005, 00:20
 
Fecha de Ingreso: octubre-2003
Ubicación: Madrid
Mensajes: 320
Antigüedad: 14 años, 1 mes
Puntos: 0
Vaya, lo he arreglado con:

background-color: #A504BD;

¿Cómo funciona? No lo tengo claro.
  #7 (permalink)  
Antiguo 10/02/2005, 00:23
 
Fecha de Ingreso: octubre-2003
Ubicación: Madrid
Mensajes: 320
Antigüedad: 14 años, 1 mes
Puntos: 0
No, no era una imagen enlace, eso también influye en que no sepa exactamente qué ha pasado.

Me parece que me voy a dormir ya, que aquí está casi amaneciendo y yo tengo la cabeza mareadísima. :S

Gracias por tu ayuda, PascalC. Sabes un montón. Eres uno de los que más contribuye a que estos foros sean realmente útiles.
  #8 (permalink)  
Antiguo 10/02/2005, 00:24
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 4 meses
Puntos: 1
de nada :)
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:58.