Foros del Web » Creando para Internet » CSS »

Extraño subrayado

Estas en el tema de Extraño subrayado en el foro de CSS en Foros del Web. Hola! Me gustaría saber como es posible lo siguiente: Creo que algo habré tocado en el código con lo de las validaciones w3c y wai, ...
  #1 (permalink)  
Antiguo 02/04/2009, 10:36
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Exclamación Extraño subrayado

Hola!

Me gustaría saber como es posible lo siguiente:

Creo que algo habré tocado en el código con lo de las validaciones w3c y wai, porque palabras que antes no estaban con link, ahora aparecen con él, pero por más que reviso, no hay "link" en las propiedades...alguien sabe que es lo que puede haber pasado?

Lá web en cuestión es :

http://www.jarmauto.es/talleres/

Muchas gracias
  #2 (permalink)  
Antiguo 02/04/2009, 10:40
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

¿Y cuáles son esas palabras?
  #3 (permalink)  
Antiguo 02/04/2009, 11:15
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Respuesta: Extraño subrayado

Hola Mikmoro, las palabras son:

Cita:
Edit
Lo que si veo que es distinto esque hay como un "espaciador"que no se ve entre los diferentes textos, como un palito, que al seleccionar con el ratón, sale.

Que puede ser?

Muchas gracias

Última edición por NaRanJiTo78; 03/04/2009 a las 11:15
  #4 (permalink)  
Antiguo 02/04/2009, 11:25
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Extraño subrayado

Eso pasa por que has dejado tags de links abiertos, este puede ser el causante:

Código HTML:
<div id="apDiv16">
<a href="http://www.jarmauto.es/info/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Contacto','','../new3dweb/imagenes/botones/ok/contacto1.png',1)" />
<img src="http://www.forosdelweb.com/f53/new3dweb/imagenes/botones/ok/contacto2.png" alt="Contacto" title="Contacto" name="Contacto" width="40" height="40" border="0" />
</div> 
si te fijas el tag nunca se cierra
__________________
WFC
codigo82
  #5 (permalink)  
Antiguo 02/04/2009, 11:28
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

Lo siento pero está hecho con DreamWeaver y ahí mucho no te puedo ayudar.
No imagino por qué tienes los enlaces vacíos, cerrados en sí mismos en lugar de tener contenido:
Cita:
<a href="http://www.jarmauto.es/talleres/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Talleres','','../new3dweb/imagenes/botones/ok/taller2.png',1)" />
No sé por qué está esto así, desgraciadamente.
  #6 (permalink)  
Antiguo 02/04/2009, 11:30
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Extraño subrayado

Hola mik creo el problematico es el que le marque arriba ese tag <a nunca se cierra
__________________
WFC
codigo82
  #7 (permalink)  
Antiguo 02/04/2009, 11:33
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

Mira mi mensaje: sí está cerrado, pero en sí mismo, como etiqueta vacía, como img por ejemplo. (hola a ambos, por cierto )
  #8 (permalink)  
Antiguo 02/04/2009, 11:37
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Extraño subrayado

pues entonces tiene dos problemas(o quizás más que es lo más seguro), si te fijas el que yo puse tiene otro href.
__________________
WFC
codigo82
  #9 (permalink)  
Antiguo 02/04/2009, 11:42
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Respuesta: Extraño subrayado

Muchas gracias willyfc!!

Seguramente habría borrado los cierres sin querer intentando subsanar errores de validación...

;)
  #10 (permalink)  
Antiguo 02/04/2009, 11:43
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Respuesta: Extraño subrayado

Cita:
Iniciado por Mikmoro Ver Mensaje
Lo siento pero está hecho con DreamWeaver y ahí mucho no te puedo ayudar.
No imagino por qué tienes los enlaces vacíos, cerrados en sí mismos en lugar de tener contenido:

No sé por qué está esto así, desgraciadamente.
Pues en teoria poniendolo así se validaba WAI AAA...no entiendo que entonces haya diferencias estando bien el codigo y mal en la validación en este caso...
  #11 (permalink)  
Antiguo 02/04/2009, 11:45
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

willyfc: el que tú has puesto tiene barra de cierre al final en la propia etiqueta:
Cita:
<a href="http://www.jarmauto.es/info/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Contacto','','../new3dweb/imagenes/botones/ok/contacto1.png',1)" />
  #12 (permalink)  
Antiguo 02/04/2009, 11:48
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

Cita:
Iniciado por NaRanJiTo78 Ver Mensaje
Pues en teoria poniendolo así se validaba WAI AAA...
Pero una cosa es la validaciópn y otra la accesibilidad (WAI). No sé qué habrás hecho pero yo creo que así como lo tienes no valida ni de lejos.

EDITO: de hecho, tu página (el enlace que pones) tiene 70 errores y 22 advertencias de validación.

Y en cuanto a la accesibilidad, tienes un error de nivel A, 6 de nivel AA y 1 de AAA.
  #13 (permalink)  
Antiguo 02/04/2009, 11:49
 
Fecha de Ingreso: noviembre-2008
Ubicación: W2.0
Mensajes: 103
Antigüedad: 9 años
Puntos: 1
Respuesta: Extraño subrayado

cierrelo con </a> y eliminas el problema. A mí me pasaba lo mismo
  #14 (permalink)  
Antiguo 02/04/2009, 11:50
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Extraño subrayado

si si, efectivamente Mik me refería que es otro error más ya que son 2 vínculos diferentes, la verdad no me había percatado de que se cerraba en si mismo hasta que lo dices. Pero por eso mencione el href ya que es el mismo error en dos lugares diferentes
__________________
WFC
codigo82
  #15 (permalink)  
Antiguo 02/04/2009, 11:53
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

Ah ya, no te había entendido: es que todos los enlaces del principio están así.
  #16 (permalink)  
Antiguo 02/04/2009, 12:26
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Respuesta: Extraño subrayado

Mikmoro, no digo que la haya conseguido validar!! Sino que he reducido muchoas errores...es el eterno problema del Dreamweaver...

Estoy en ello poco a poco..
  #17 (permalink)  
Antiguo 02/04/2009, 12:35
Avatar de Calizman
Organiza competencias CSS
 
Fecha de Ingreso: octubre-2008
Ubicación: Ciudad de Guatemala, Guatemala
Mensajes: 1.122
Antigüedad: 9 años, 2 meses
Puntos: 83
Respuesta: Extraño subrayado

Hola a todos!! (Es uno de los pocos post en donde veo que se saludan... xD)

Yo vengo a dar mi opinion

Cita:
Mikmoro, no digo que la haya conseguido validar!! Sino que he reducido muchoas errores...es el eterno problema del Dreamweaver...

Estoy en ello poco a poco..
Tengo la solucion perfecta para ti amigo! Se llama Notpad++!!
Deja de usar DW y veras que comenzaras a ahorrar tiempo en arreglar problemas.

Con respecto a tu problema central, no creo que haga falta ayudarte, tienes a dos grandes ayudandote asi que solo eso venia a decir.

Hasta Luego!!
__________________
[ Mi Sitio Personal ]
"La felicidad no es una estacion de llegada... Es un modo de viajar"
Tom Schreiter
  #18 (permalink)  
Antiguo 02/04/2009, 12:42
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años, 1 mes
Puntos: 10
Respuesta: Extraño subrayado

asiassssss calizzz :)
  #19 (permalink)  
Antiguo 02/04/2009, 12:42
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Extraño subrayado

Cita:
Iniciado por NaRanJiTo78 Ver Mensaje
Mikmoro, no digo que la haya conseguido validar!! Sino que he reducido muchoas errores...es el eterno problema del Dreamweaver...

Estoy en ello poco a poco..
Lo siento, creí haberte leído que la habías validado, y al parecer no lo habías dicho.
Al creer que pensabas que sí, me costaba entender cómo tenías esos errores y creías pasar la validación.

Pues nada, nada, perdona: a seguir peleando con el validador

P.D.: si consigues validar, errores como el que abrió este hilo desaparecerán por arte de magia.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:04.