Foros del Web » Creando para Internet » CSS »

Firefox y IE menus diferentes

Estas en el tema de Firefox y IE menus diferentes en el foro de CSS en Foros del Web. Hola a todos tengo un problema con IE mirar tengo este menu: <div id="avmenu"> <ul> <li ><a href="actividad.htm" >Categoria0</a></li> <li ><a href="quienessomos.htm" >Subcategoria0</a></li> <li ><a ...
  #1 (permalink)  
Antiguo 08/07/2006, 09:22
 
Fecha de Ingreso: abril-2006
Mensajes: 47
Antigüedad: 11 años, 8 meses
Puntos: 0
Pregunta Firefox y IE menus diferentes

Hola a todos tengo un problema con IE
mirar tengo este menu:

<div id="avmenu">
<ul>
<li ><a href="actividad.htm" >Categoria0</a></li>
<li ><a href="quienessomos.htm" >Subcategoria0</a></li>
<li ><a href="quienessomos.htm" >Subcategoria</a></li>
<li ><a href="actividad.htm" >Categoria1</a></li>
<li ><a href="actividad.htm" >Categoria2</a></li>
<li ><a href="actividad.htm" >Categoria3</a></li>
</ul>
</div>

y este es el código

#avmenu {
FLOAT: left;
WIDTH: 140px;
position: absolute;
left: 4px;
top: 15px;
}

#avmenu UL {
LIST-STYLE-TYPE: none;
}


#avmenu LI A {
DISPLAY: block;
BORDER-LEFT: #ccc 4px solid;
TEXT-DECORATION: none;
font-size:11px;
margin: 0px;
padding: 10px;
}

#avmenu LI A.subcategoria {
BORDER-LEFT: #EAEAEA 4px solid;

}
#avmenu LI A.subcategoria:hover {
background: #F5F5F5;
color: #505050;



Pero tengo el problema que en firefox se ve de coña, pero en IE los li se me separan, me da este resultado:


Alguna alma caritativa, podria ayudarme mira que busco el problema pero no lo encuentro.

Saludos!
  #2 (permalink)  
Antiguo 08/07/2006, 19:48
 
Fecha de Ingreso: abril-2006
Mensajes: 47
Antigüedad: 11 años, 8 meses
Puntos: 0
Información Solucionado

ATENCIÓN, ya con este tipo de errores.
EL Problema no era del CSS, ya que parecia correcto sino de las etiquetas HTML

<li ><a href="actividad.htm" >Categoria0</a></li>
<li ><a href="quienessomos.htm" >Subcategoria0</a></li>
<li ><a href="quienessomos.htm" >Subcategoria</a></li>
<li ><a href="actividad.htm" >Categoria1</a></li>
<li ><a href="actividad.htm" >Categoria2</a></li>
<li ><a href="actividad.htm" >Categoria3</a></li>

Necesitan un espacio delante para separar el enlace del final de la etiqueta, yo me he sorprendido mucho con lo tonto que es IE. Vaya tela

lo correcto seria:
<li ><a href="actividad.htm" >Categoria3 </a></li>


Bueno Gracias de todos modos
  #3 (permalink)  
Antiguo 09/07/2006, 03:43
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 10 meses
Puntos: 771
Hola ordsanmi

He probado tu segundo código y se sigue viendo mal en IE

Saludos,
  #4 (permalink)  
Antiguo 09/07/2006, 08:51
Avatar de SiR.CARAJ0DIDA  
Fecha de Ingreso: junio-2004
Ubicación: Acá
Mensajes: 1.166
Antigüedad: 13 años, 5 meses
Puntos: 4
bueno es obvio que si no aplicas el holly hack te va a andar todo mal..
agrega esto asi como esta:

DIV, UL, LI { _height:1%; }

ademas no se puede aplicar 'position' a algo que flota porque no te va a hacer caso. tambien para que poner display block en un <a> ??
__________________
Internet Explorer SuckS
Download FireFox
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:29.