Foros del Web » Creando para Internet » CSS »

me funciona el :hover pero no el :active en css

Estas en el tema de me funciona el :hover pero no el :active en css en el foro de CSS en Foros del Web. Buenas tengo el siguiente menu html <!-- MENU TOP --> <div id="menutop"> <ul> <li id="bot_01"></li> <a href="./"><li class="bot_02"></li></a> <a href="./laempresa.php"><li class="bot_03"></li></a> <a href="./servicios.php"><li class="bot_04"></li></a> <a ...
  #1 (permalink)  
Antiguo 03/08/2011, 13:38
Avatar de damascosolutions  
Fecha de Ingreso: octubre-2010
Mensajes: 3
Antigüedad: 7 años
Puntos: 0
me funciona el :hover pero no el :active en css

Buenas tengo el siguiente menu

html

<!-- MENU TOP -->
<div id="menutop">
<ul>
<li id="bot_01"></li>
<a href="./"><li class="bot_02"></li></a>

<a href="./laempresa.php"><li class="bot_03"></li></a>
<a href="./servicios.php"><li class="bot_04"></li></a>
<a href="./rse.php"><li class="bot_05"></li></a>
<a href="./contacto.php"><li class="bot_06"></li></a>
<li id="bot_07"></li>
</ul>
</div><!-- Fin Menu Top -->




y el codigo css es

/* Menu Top */
#menutop
{
width:983px;
height:50px;

}
#menutop ul
{
list-style:none;
display:block;
margin:-16px;
}
#menutop ul li
{
float:left;
margin-top:-16px;
}

/*Botones*/



#bot_01
{
margin-left:-13px;

width:41px;
height:64px;
background-image:url("./images/menu_izq.png");

}

/*Botones con Hover*/


.bot_02
{
width:101px;
height:64px;
background-image:url("./images/bienvenida_link.png");
}

.bot_02:link
{
width:101px;
height:64px;
background-image:url("./images/bienvenida_hover.png");
}

.bot_02:active
{
width:101px;
height:64;
background-image:url("./images/bienvenida_hover.png");
}

.bot_02:visited
{
width:101px;
height:64;
background-image:url("./images/bienvenida_hover.png");
}

.bot_02:hover
{
width:101px;
height:64;
background-image:url("./images/bienvenida_hover.png");
}






.bot_03
{
width:101px;
height:64px;
background-image:url("./images/empresa_link.png");
}

.bot_03:hover
{
width:101px;
height:64px;
background-image:url("./images/empresa_hover.png");
}


.bot_03:active
{
width:101px;
height:64;
background-image:url("./images/empresa_visit.png");
}




.bot_04
{
width:101px;
height:64px;
background-image:url("./images/servicios_link.png");
}
.bot_04:hover
{
width:101px;
height:64px;
background-image:url("./images/servicios_hover.png");
}



.bot_04:active
{
width:101px;
height:64;
background-image:url("./images/servicios_visit.png");
}



.bot_05
{
width:101px;
height:64px;
background-image:url("./images/rse_link.png");
}

.bot_05:hover
{
width:101px;
height:64px;
background-image:url("./images/rse_hover.png");
}




.bot_05:active
{
width:101px;
height:64;
background-image:url("./images/rse_visit.png");
}

.bot_06
{
width:103px;
height:64px;
background-image:url("./images/contacto_link.png");
}
.bot_06:hover
{
width:103px;
height:64px;
background-image:url("./images/contacto_hover.png");
}


.bot_06:active
{
width:101px;
height:64;
background-image:url(./images/contacto_visit.png");
}


me funciona el :hover pero el :active no me funciona... alguien me puede echar un cable??? de como podria hacer para que funcione el :active correctamente.... y el :visited
  #2 (permalink)  
Antiguo 03/08/2011, 14:54
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 5.784
Antigüedad: 9 años, 7 meses
Puntos: 936
Respuesta: me funciona el :hover pero no el :active en css

ando un poco ido el día de hoy pero al ver tu código me da la impresión que estas confundiendo el :visited con el :active

y sin ver el resultado obtenido y el deseado no sabría decirte a ciencia cierta que te falla

la pregunta clásica y de ley.... estas usando un doctype valido?
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados u otro medio....

Etiquetas: hover, html, fondo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:04.