Foros del Web » Creando para Internet » CSS »

¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y Firefox?

Estas en el tema de ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y Firefox? en el foro de CSS en Foros del Web. Hola ¿Sólo hay hacks para IE? Ya me aburrí de intentar compatibilizar HTML5 y CSS3 con IE 8, 7 y 6. Por eso, con un ...
  #1 (permalink)  
Antiguo 17/09/2014, 12:22
Avatar de eduardobrutaldeath  
Fecha de Ingreso: agosto-2013
Ubicación: América
Mensajes: 306
Antigüedad: 9 años
Puntos: 3
¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y Firefox?

Hola

¿Sólo hay hacks para IE?

Ya me aburrí de intentar compatibilizar HTML5 y CSS3 con IE 8, 7 y 6. Por eso, con un comentario condicional voy a hacer que a esas versiones antiguas les aparezca un mensaje que les diga que están en la prehistoria y que si quieren ver mi página que actualicen su navegador. Eso ya está decidido pero, también hay versiones antiguas de Chrome, Firefox, Opera y Safari que no soportan HTML5 y CSS3. Por eso preguntaba si existe alguna manera de hacer que mi mensaje llegue también a los que usan esas versiones desactualizadas.

La mayoría de polyfills son para IE. No encuentro uno que sea para para versiones antiguas de GC, FF, O, S. Estaba instalando librerías Modernizr, Selectivzr, el polyfill PIE y otros, pero ya me llegó esta situación. Además esto es muy convincente :

http://windows.microsoft.com/es-es/w...d-support-help

Según me han dicho Google Chrome, Firefox y Opera se actualizan solos en el sistema operativo Windows, y esto me tranquiliza un poco porque la inmensa mayoría de gente tiene instalado ese sistema, o sea que no van a haber versiones viejas pero, hay otro grupo de gente que usa Linux y Mac, y en esos sistemas los navegadores no se actualizan automáticamente. O sea que pueden haber tíos que todavía tienen versiones antiguas.

Última edición por eduardobrutaldeath; 17/09/2014 a las 12:35
  #2 (permalink)  
Antiguo 17/09/2014, 12:57
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.487
Antigüedad: 20 años
Puntos: 2114
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Pues a mi en OSX se me actualiza Chrome solo. Opera no lo tengo, Firefox ni idea y Safari… Safari se actualiza una vez cada era glacial.

Respecto a IE, no entiendo en qué cabeza cabe que se quiera soportar navegadores que nadie usa. ¿IE6? Por favor… Quien usa eso estará acostumbrado a ver las páginas mal, déjalo así. Ni aviso pondría yo.
__________________
(:
  #3 (permalink)  
Antiguo 17/09/2014, 13:05
Avatar de eduardobrutaldeath  
Fecha de Ingreso: agosto-2013
Ubicación: América
Mensajes: 306
Antigüedad: 9 años
Puntos: 3
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Cita:
Iniciado por pzin Ver Mensaje
Safari se actualiza una vez cada era glacial.
Jajaja.

El aviso va a ser para IE8, porque todavía hay algunos que lo usan, y porque no me gustaría que alguno de mis clientes entrara a su página desde XP y la viera toda descuadrada y fea. Allí voy a poner un link a la página de Microsoft para que lean la noticia y también links a las páginas de descarga de Chrome, Firefox y Opera (supongo que si se pueden instalar en XP).
  #4 (permalink)  
Antiguo 17/09/2014, 13:13
Avatar de eduardobrutaldeath  
Fecha de Ingreso: agosto-2013
Ubicación: América
Mensajes: 306
Antigüedad: 9 años
Puntos: 3
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Ah, y ahora ya puedo descargar el jquery-2.1.1 porque ya no me importa I8.
  #5 (permalink)  
Antiguo 17/09/2014, 22:39
Avatar de ZoroRoronoa  
Fecha de Ingreso: marzo-2011
Ubicación: California, USA
Mensajes: 824
Antigüedad: 11 años, 4 meses
Puntos: 116
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Alguna vez has entrado a una pagina que dice:

Tus datos han sido guardados por seguridad de nuestro servidor.
Nos visitas de Estados Unidos, 000.0.00.000 GTM -4 pacific.
windows XP, Mozilla Firefox 32.1

Y cosas asi por el estilo.

Googleando se encuentran algunas cosas:
http://www.lawebdelprogramador.com/c...l_cliente.html


PD: Supongo que si me exprese sin decirlo?, y Ya por logica, en base a esto, detectaras la version y bajo tus condiciones lo que quieres mostrar o no, como el letrero ese de Actualiza tu navegador, o lo que quieras.

Saludos.
__________________
Programador jQuery & PHP
  #6 (permalink)  
Antiguo 18/09/2014, 05:44
Avatar de madman_18  
Fecha de Ingreso: agosto-2010
Mensajes: 792
Antigüedad: 12 años
Puntos: 14
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Podrías tener en cuenta a IE a partir de la versión 9 de IE...para menores lo único que yo hago es mostrar un aviso diciendo que tienen navegadores antiguos...
Como sigamos dando soporte a navegadores antiguos no van a acabar muriendo nunca.
A parte de eso, para navegadores tipo Firefox,Chrome...al sacar avisos de actualización y actualizarse al cerrar el navegador y volver a iniciarlo, nunca me ha dado por mirar si existe un hack tipo como el de IE para ello. No creo que haya que tener muy en cuenta si es una versión anticuada ya que va a ser raro (o eso creo yo ;) )
__________________
"Si consigues ser algo más que un hombre, si te entregas a un ideal, te convertes en algo muy diferente"
  #7 (permalink)  
Antiguo 18/09/2014, 10:19
Avatar de eduardobrutaldeath  
Fecha de Ingreso: agosto-2013
Ubicación: América
Mensajes: 306
Antigüedad: 9 años
Puntos: 3
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Cita:
Iniciado por madman_18 Ver Mensaje
Como sigamos dando soporte a navegadores antiguos no van a acabar muriendo nunca.
Sí, tienes razón, ya me di cuenta de eso.

Ahora, lo de las versiones viejas de Firefox y Opera aún me inquieta pero, supongo que tendré que dejarlo, total hay pocas probabilidades de que alguien este usando versiones muy antiguas de esos navegadores... Igual todo no puede ser perfecto.
Lo malo es que, si alguna vez un cliente tiene la mala suerte de entrar en una máquina con una versión antigua de FOX me va a llamar y decir : 'Me dijiste que mi página no se vería en IE8 pero sí en los navegadores modernos ¿qué pasa?'.

No me importa que no se vean propiedades como por ejemplo BORDER-RADIUS, BOX-SHADOW y GRADIENT, porque esas son secundarias, pero, si el navegador no reconoce por ejemplo al BOX-SIZING o a las pseudoclases, pseudoelementos y selectores, ahí si estoy muerto.

Podría no usar esa tecnología, armar la página con IDS y CLASES, y calcular el tamaño del borde y padding en lugar de usar BOX-SIZING ¿pero entonces cuando aprovecharía la tecnología CSS3?

Creo que tendré que arriesgarme
  #8 (permalink)  
Antiguo 18/09/2014, 12:10
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.487
Antigüedad: 20 años
Puntos: 2114
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Es que FF5 es igual de moderno que IE8. Luego no es un navegador moderno. Firefox y Chrome también tienen versiones. Si entras con un navegador considerado obsoleto, da igual de qué casa sea, sigue siendo software en desuso.

Que por cierto, creo que box-sizing por ejemplo se reconoce en todas las versiones de Chrome y Firefox. Incluso en IE6 ni siquiera hay que usarlo porque cambiaron completamente el modelo de caja por defecto a border-box. Qué tiempos aquellos más locos…

Igual te preocupas en exceso, no sé.
__________________
(:
  #9 (permalink)  
Antiguo 18/09/2014, 16:01
Avatar de eduardobrutaldeath  
Fecha de Ingreso: agosto-2013
Ubicación: América
Mensajes: 306
Antigüedad: 9 años
Puntos: 3
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Cita:
Iniciado por pzin Ver Mensaje
Es que FF5 es igual de moderno que IE8. Luego no es un navegador moderno. Firefox y Chrome también tienen versiones. Si entras con un navegador considerado obsoleto, da igual de qué casa sea, sigue siendo software en desuso.

Que por cierto, creo que box-sizing por ejemplo se reconoce en todas las versiones de Chrome y Firefox. Incluso en IE6 ni siquiera hay que usarlo porque cambiaron completamente el modelo de caja por defecto a border-box. Qué tiempos aquellos más locos…

Igual te preocupas en exceso, no sé.
SIZING es soportado en IE8, pero ya no me importa porque ahora ignoro esa versión.

Hay algo que no entiendo de esta página :

http://caniuse.com/#search=box-sizi

En la tabla aparece en plomo todo lo anterior a FireFox 30, Safari 5.1 y Opera 23
¿Significa que esos navegadores no tienen más versiones anteriores o que el soporte es desconocido para cualquier versión más baja?
  #10 (permalink)  
Antiguo 19/09/2014, 10:08
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.487
Antigüedad: 20 años
Puntos: 2114
Respuesta: ¿Hay algo parecido a los hacks de IE para versiones antiguas de Chrome y F

Cita:
Iniciado por eduardobrutaldeath Ver Mensaje
Hay algo que no entiendo de esta página :

http://caniuse.com/#search=box-sizi

En la tabla aparece en plomo todo lo anterior a FireFox 30, Safari 5.1 y Opera 23
¿Significa que esos navegadores no tienen más versiones anteriores o que el soporte es desconocido para cualquier versión más baja?
Just follow the ring:



Y si ves que falta algún dato, siempre puedes colaborar: https://github.com/fyrd/caniuse
__________________
(:

Etiquetas: antiguas, chrome, hacks, html, página, parecido, versiones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:29.