Foros del Web » Creando para Internet » CSS »

El ie no acepta #clase a

Estas en el tema de El ie no acepta #clase a en el foro de CSS en Foros del Web. Hola pues resulta que estoy haciendo un menu, y dependiendo de la clase que sea tengo que ponerle un color distinto a un link, el ...
  #1 (permalink)  
Antiguo 11/03/2008, 10:05
 
Fecha de Ingreso: febrero-2008
Ubicación: Vigo, España
Mensajes: 150
Antigüedad: 9 años, 10 meses
Puntos: 0
El ie no acepta #clase a

Hola pues resulta que estoy haciendo un menu, y dependiendo de la clase que sea tengo que ponerle un color distinto a un link, el problema que tengo es que firefox me deja hacer por ejemplo:

#menu a {
color:#000000;
}

Pero el iexplorer no me lo detecta bien... sabeis como puedo hacer para solucionarlo? un saludo y muchas gracias ;)
  #2 (permalink)  
Antiguo 11/03/2008, 10:30
Avatar de AlZuwaga
Colaborador
 
Fecha de Ingreso: febrero-2001
Ubicación: 34.517 S, 58.500 O
Mensajes: 14.550
Antigüedad: 16 años, 9 meses
Puntos: 535
Re: El ie no acepta #clase a

Hola, hablás de clases pero hacés referencia a elementos con un ID determinado (menu en el ejemplo). ¿No sería así?

.menu a {
color:#000000;
}
__________________
...___...
  #3 (permalink)  
Antiguo 11/03/2008, 12:13
 
Fecha de Ingreso: febrero-2008
Ubicación: Vigo, España
Mensajes: 150
Antigüedad: 9 años, 10 meses
Puntos: 0
Re: El ie no acepta #clase a

si perdon me equivoque al decir clase en vez de id, el problema es el mismo con uno como con otro ;)
  #4 (permalink)  
Antiguo 11/03/2008, 15:32
Avatar de marce_str  
Fecha de Ingreso: septiembre-2006
Ubicación: La Plata, Argentina
Mensajes: 203
Antigüedad: 11 años, 2 meses
Puntos: 1
Re: El ie no acepta #clase a

A mi me ha pasado que los links son medios rebeldes en esos contextos para IE.
Yo te diría que apliques una clase directamente al link.
a.clase {color:#000000;}

No es lo ideal, pero beuh...

Sino... ya que es un menu, utiliza listas
#menu {}
#menu ul {}
#menu ul li {}
#menu ul li a{}

acá funciona seguro

Saludos
  #5 (permalink)  
Antiguo 11/03/2008, 18:11
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: El ie no acepta #clase a

Cita:
Iniciado por n0ldor Ver Mensaje
Hola pues resulta que estoy haciendo un menu, y dependiendo de la clase que sea tengo que ponerle un color distinto a un link, el problema que tengo es que firefox me deja hacer por ejemplo:

#menu a {
color:#000000;
}

Pero el iexplorer no me lo detecta bien... sabeis como puedo hacer para solucionarlo? un saludo y muchas gracias ;)
Muestra el código porque no es normal que explorer no interprete

#menu a { color: #000; }

Sólo hay por ahí a millones, así que seguro que es algún fallo tonto. Imagino.

Mikel.
  #6 (permalink)  
Antiguo 12/03/2008, 17:29
 
Fecha de Ingreso: febrero-2008
Ubicación: Vigo, España
Mensajes: 150
Antigüedad: 9 años, 10 meses
Puntos: 0
Re: El ie no acepta #clase a

Ok muchas gracias, al final lo solucione poniendole el stylo directamente en el html... de momento pa ir tirando funciona, mas palante cuando la tenga acabada ya arreglare esos detallitos, ;)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:36.