Foros del Web » Creando para Internet » CSS »

Imagenes q no aparecen. Ayuda ^^

Estas en el tema de Imagenes q no aparecen. Ayuda ^^ en el foro de CSS en Foros del Web. Hola como les va, les comento que en una web que habia echo, use un codigo CSS ... el cual lo que hace es, que ...
  #1 (permalink)  
Antiguo 10/07/2008, 17:54
Avatar de Hiruma-Sama  
Fecha de Ingreso: agosto-2007
Ubicación: Floresta, Buenos Aires, Argentina.
Mensajes: 234
Antigüedad: 10 años, 3 meses
Puntos: 5
Imagenes q no aparecen. Ayuda ^^

Hola como les va, les comento que en una web que habia echo, use un codigo CSS ... el cual lo que hace es, que al uno posarse sobre un link, por ejemplo una palabra ... "entrada" a la derecha de la misma, aparezca una imagen la cual hace referencia a dicha palabra ... y si uno hace click en la palabra nos lleva a la misma foto pero pudiendola descargar.

ahora bien, me funciona perfecto en Mozilla firefox e incluso en Internet Explorer a algunos les anda bien, pero hay otros que no les anda ... osea no ven las imagenes, digamso que no aparecen ...

les dejo el link del sitio para que vean ... como es el caso, si pueden visualicenlo con ambos navegadores.

http://www.fullfun.com.ar/default.htm

aqui el codigo:

Cita:
/**Con la siguiente porcion de codigo, podemos hacer que al posar el mouse, sobre una palabra,**/
/**o tambien una frase, podamos hacer que aparezca, en determinada posicion de la web, una Imgaen.**/

div#links {width: 250px; height: 230px; font: 10px Verdana, sans-serif; z-index: 100;}
div#links a {display: block; text-align: center; font: bold 1em sans-serif;
padding: 0px 3px; margin: 0 0 1px; border-width: 0;
text-decoration: none; color: #000000; }
div#links a:hover {color: #FF0000;}


div#links a img {height: 0; width: 0; border: 3px #cb62ff;}
div#links a:hover img {position: absolute; top: 155px; left: 300px; height: 200px; width: 200px;}









Alguna solucion o algo que me digan que me pueda ayudar, para que funcione correctamente y en todos lados por igual ? ? ? ? ?
  #2 (permalink)  
Antiguo 10/07/2008, 21:58
 
Fecha de Ingreso: abril-2005
Ubicación: chihuahua Mexico
Mensajes: 49
Antigüedad: 12 años, 7 meses
Puntos: 0
Respuesta: Imagenes q no aparecen. Ayuda ^^

Que rollo man ps la neta ni vi tu codigo man pero tengo un menu que tambien funciona igual que tus <div> checalo tambien carga imagenes

<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
<style type="text/css">
/* TABS */
#tabs {
background:#F6F6F6 url('/images/conthead.gif') repeat-x bottom;
height:24px;
}
#tabs .b {
margin:0 0 0 5px;
border-right:1px solid #FFF;
border-left:1px solid #666;
float:left;
display:inline;
}
#tabs a {
display:block;
float:left;
/*width:120px;*/
border-right:1px solid #666;
border-left:1px solid #FFF;
text-decoration:none;
font-size:12px;
font-weight:bold;
color:#111;
padding:4px 15px 6px 15px;
}
#tabs a:hover {
background:url('/imagenes_pagina/averde.png') repeat-x bottom;
color:#666;
text-decoration:none;
padding:3px 15px 7px 15px;
}
#tabs #current {
background-image:url('/imagenes_pagina/averde.png');
}
#tabs #current a {
color:#999;
}

/*END TABS */
</style>
</head>


<body >
<div id="tabs"><table style="border-collapse:collapse;font-family:Tahoma,Arial, Helvetica, sans-serif;font-size:10pt;"><tr><td style="margin:0px; padding:0px; border:0px;"><a href="contacto.asp">CONTACTO</a></td><td style="margin:0px; padding:0px; border:0px;"><a href="alta_vacante.asp">ALTA VACANTE</a></td></tr></table></div>
</body>
</html>
  #3 (permalink)  
Antiguo 10/07/2008, 23:06
Avatar de Hiruma-Sama  
Fecha de Ingreso: agosto-2007
Ubicación: Floresta, Buenos Aires, Argentina.
Mensajes: 234
Antigüedad: 10 años, 3 meses
Puntos: 5
Respuesta: Imagenes q no aparecen. Ayuda ^^

gracias por responder ^^

pero bueno, mi problema radica en que en algunos Internet Explorer 6.0 ... no pueden ver las imagenes (no aparecen) cuando uno se posa sobre el contenido, cosa q en firefox siempre se cumple, y no si es un error de mi codigo o es otra cosa >_<!
  #4 (permalink)  
Antiguo 11/07/2008, 05:40
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Imagenes q no aparecen. Ayuda ^^

El asunto es largo de explicar, pero básicamente es que en IE6, el "a:hover" necesita tener posición relativa, porque si no no muestra lo que tiene dentro (la imagen en este caso)

div#links a:hover {position:relative;}

Si pones esto se verán las imágenes con IE6, pero te encontrarás otro problema: la posición absoluta de las imágenes ahora no será con respecto a la página, sino a los enlaces, y no saldrán todas en el mismo sitio, sino en un lugar con respecto a cada enlace, y arreglarlo tiene batante jaleo.

Mikel.
  #5 (permalink)  
Antiguo 11/07/2008, 12:09
Avatar de Hiruma-Sama  
Fecha de Ingreso: agosto-2007
Ubicación: Floresta, Buenos Aires, Argentina.
Mensajes: 234
Antigüedad: 10 años, 3 meses
Puntos: 5
Respuesta: Imagenes q no aparecen. Ayuda ^^

ah muchisimas gracias :D
entiendo el problema que contrae, se puede arreglar de alguna manera ?
por que en si yo con que se vea y quede en un lugar logico o que no se interpone a otra cosa, me alcanza.

gracias por el dato :P
  #6 (permalink)  
Antiguo 11/07/2008, 18:28
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Imagenes q no aparecen. Ayuda ^^

Te pongo un ejemplo para que veas por dónde va la cosa. Es en tres pasos:

1.- en la cabecera de tu html debes añadir esto justo después de la etiqueta </style>:

Cita:
<!--[if IE]><style>.uno {left:140px;} .dos {left:143px;} .tres {left:138px;} .cuatro {left:148px;}</style><![endif]-->
2.- Ahora en la css debes hacer estos cambios:

Cita:
div#links {width: 250px; height: 230px; font: 10px Verdana, sans-serif; z-index: 100;}
div#links a {display: block; text-align: center; font: bold 1em sans-serif;
padding: 0px 3px; margin: 0 0 1px; border-width: 0;
text-decoration: none; color: #000000;}
div#links a:hover {color: #FF0000;position:relative;}
div#links a img {display: none; border: 3px #cb62ff;}
div#links a:hover img {position: absolute; height: 200px; width: 200px;display: block;}
.uno, .dos, .tres, .cuatro {left: 240px;}
.uno {top:4px;}
.dos {top:-9px;}
.tres {top:-22px;}
.cuatro {top:-35px;}
copia y pega tal cual

3.- En el html debes poner una clase a cada imagen:

Cita:
<div id="links">
<a href="http://fullfun-test.iespana.es/Frente.gif">Frente<img class="uno" src="Frente.gif" /></a>
<a href="http://fullfun-test.iespana.es/Entrada.gif">Entrada<img class="dos" src="Entrada.gif" /></a>
<a href="http://fullfun-test.iespana.es/Salon.gif">Salón<img class="tres" src="Salon.gif" /></a>
<a href="http://fullfun-test.iespana.es/Escritorio.gif">Escritorio<img class="cuatro "src="Escritorio.gif" /></a>
</div>
copia y pega también para ver el ejemplo.

A ver si te orienta de por dónde va la cosa.

Mikel.
  #7 (permalink)  
Antiguo 11/07/2008, 20:51
Avatar de Hiruma-Sama  
Fecha de Ingreso: agosto-2007
Ubicación: Floresta, Buenos Aires, Argentina.
Mensajes: 234
Antigüedad: 10 años, 3 meses
Puntos: 5
Respuesta: Imagenes q no aparecen. Ayuda ^^

Bueno muchisimas gracias ^^.
me a funcionado correctamente en Internet Explorer y en Opera.
en el firefox, la imagen me aparece por debajo del link, pero pareciera que no se actualiza correctamente la pagina .html ; seguro sera algo de las cookies, pero lo importante es que ahora me anda bien en IE.

Estare al tanto para que me funcione correctamente en los diferentes navegadores, y seguire probando y haciendo pruebas...

Gracias.


PD: el primer codigo que me pasaste, va tal cual lo pusiste no ? ... ademas q es como un "comentario de codigo" ?

me refiero a:

Cita:
<!--[if IE]><style>.uno {left:140px;} .dos {left:143px;} .tres {left:138px;} .cuatro {left:148px;}</style><![endif]-->
saludos. ^^
  #8 (permalink)  
Antiguo 12/07/2008, 06:14
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Imagenes q no aparecen. Ayuda ^^

Sí, tal cual te lo puse. Eso es un comentario condicional, que sólo entiende Explorer, y se usa para poner reglas específicas sólo para él.

Mikel.
  #9 (permalink)  
Antiguo 14/07/2008, 16:43
Avatar de Hiruma-Sama  
Fecha de Ingreso: agosto-2007
Ubicación: Floresta, Buenos Aires, Argentina.
Mensajes: 234
Antigüedad: 10 años, 3 meses
Puntos: 5
Respuesta: Imagenes q no aparecen. Ayuda ^^

Realmente Muchisimas gracias, me a funcionado de maravilla ^^
  #10 (permalink)  
Antiguo 14/07/2008, 16:47
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Imagenes q no aparecen. Ayuda ^^

De nada, es un placer.

Saludos.

Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:48.