Foros del Web » Creando para Internet » CSS »

imagenes que se ven en diseño pero no en desarrollo

Estas en el tema de imagenes que se ven en diseño pero no en desarrollo en el foro de CSS en Foros del Web. Buenos días a todos.. Es la primera vez que escribo en este foro, porque soy novatilla en esto de CSS y claro, como no podía ...
  #1 (permalink)  
Antiguo 15/09/2009, 07:17
 
Fecha de Ingreso: septiembre-2009
Mensajes: 2
Antigüedad: 8 años, 3 meses
Puntos: 0
imagenes que se ven en diseño pero no en desarrollo

Buenos días a todos..

Es la primera vez que escribo en este foro, porque soy novatilla en esto de CSS y claro, como no podía ser de otra forma, la primera en la frente...resulta que estoy haciendo una aplicación web sencilla, pero en la master page se muestran en desarrollo las imágenes que tengo para los fondos del menu, pero en ejecución no..
Por supuesto, estoy utilizando hojas de estilos para poner los fondos, ¿es correcto?

esta es la parte de la hoja de estilos para el menú:

.FondoMenuBack
{
width: 20%;
height: 29px;
background : Gray url(/recursos/background.gif) no-repeat fixed;
text-align: center;
}

Gracias mil por ayudarme
  #2 (permalink)  
Antiguo 15/09/2009, 07:38
 
Fecha de Ingreso: septiembre-2009
Mensajes: 2
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: imagenes que se ven en diseño pero no en desarrollo

Ya no hace falta que me contesten, en post anteriores he encontrado la solucion:

la imagen está en la ruta que he puesto, pero al usar una ruta relativa y estar la hoja de estilo en "estilos/general.css", para llegar a la ruta que he puesto debes primero subir un nivel, es decir, poner:

background : Gray url(../recursos/background.gif) no-repeat fixed;

Gracias a todos
  #3 (permalink)  
Antiguo 15/09/2009, 15:19
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: imagenes que se ven en diseño pero no en desarrollo

Hola:

Cita:
Iniciado por vikigenia Ver Mensaje
background : Gray url(../recursos/background.gif) no-repeat fixed;
Me alegro de que tu misma hayas solucionado tu duda, pero voy a darte un consejo los colores ponlos siempre en hexadecimal, algunos navegadores podrían no interpretarlos bien poniendo como los pones.

Tu código debería ser así:

Código:
 background : #808080 url(../recursos/background.gif) no-repeat fixed;
Saludos.

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:42.