Foros del Web » Creando para Internet » CSS »

Instrucción de fondo en link incompatible!?

Estas en el tema de Instrucción de fondo en link incompatible!? en el foro de CSS en Foros del Web. Hola a todos. Bien, en el sitio web que estoy desarrollando, tengo un menu lateral que tiene un pequeño icono y cambia al situar el ...
  #1 (permalink)  
Antiguo 24/06/2007, 18:10
Avatar de hey_alan  
Fecha de Ingreso: diciembre-2006
Ubicación: México
Mensajes: 348
Antigüedad: 11 años
Puntos: 8
Pregunta Instrucción de fondo en link incompatible!?

Hola a todos.

Bien, en el sitio web que estoy desarrollando, tengo un menu lateral que tiene un pequeño icono y cambia al situar el cursor sobre el link (ver en http://cybershaman.awardspace.com en el menu lateral). Todo iba bien, hasta que descubri que la imagen de fondo del link (es decir, la que cambia) no se veia en navegadores como nestcape y amaya (en este ultimo no se ve ninguna imagen :P ).

Esta es la parte del CSS:
Código:
#lateral{float:left; width:152px; height:auto; padding-left:8px;}

#lateral ul{list-style:none; margin:0; padding:0;}

#lateral ul a{
font-size: 16px;
background: url(minilogo2.gif) no-repeat center left;
width:20px;
overflow:visible;
display:block;
padding: 3px 0px 0px 28px;
margin: 0px 0px 3px 16px;
height:24px; 
vertical-align:middle;
}

#lateral ul a:hover{background: url(minilogo1.gif) no-repeat center left;}
Y esta es la parte del html:
Código:
<div id="lateral">
  <ul>
    <li><a href="index.php">Inicio</a></li>
    <li><a href="nosotros.php">Nosotros</a></li>
    <li><a href="servicios.php">Servicios</a></li>
    <li><a href="ejemplos.php">Ejemplos</a></li>
    <li><a href="contacto.php">Contacto</a></li>
  </ul>
</div>
¿Existe alguna manera de que se vea correctamente en esos navegadores? ¿Lo estoy haciendo de la manera correcta?

Muchas gracias de antemano.
  #2 (permalink)  
Antiguo 24/07/2007, 21:06
axz
 
Fecha de Ingreso: mayo-2005
Mensajes: 360
Antigüedad: 12 años, 6 meses
Puntos: 10
Re: Instrucción de fondo en link incompatible!?

Al parecer el display de las imágenes es por delay del caché ... ya que si esperas un momento ... después de un rato, se ven bien tus imágenes ... y después de la primera vez, como ya están en caché del cliente que las vé, no hay tal retardo y se ven rápido sin problemas ...

El código que posteas se vé bien ... por lo tanto, no creo que haya problemas ...
Suerte y felicidades por usar estándares ...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:58.