Foros del Web » Creando para Internet » CSS »

Loco con los navegadores

Estas en el tema de Loco con los navegadores en el foro de CSS en Foros del Web. Hola ninjas, este humilde aprendiz os saluda. Escribo porque estoy loco con las respuestas de los navegadores a mi chuleta css (o debería decir "styleSHIT!" ...
  #1 (permalink)  
Antiguo 12/08/2010, 07:33
 
Fecha de Ingreso: agosto-2010
Mensajes: 13
Antigüedad: 7 años, 4 meses
Puntos: 0
Loco con los navegadores

Hola ninjas, este humilde aprendiz os saluda.

Escribo porque estoy loco con las respuestas de los navegadores a mi chuleta css (o debería decir "styleSHIT!" )

El problema comenzó queriendo centrar la página fuese el tamaño cual fuese de la pantalla. Al final encontré un código para el CSS que lo solucionaba:

Código:
[camping.css]

body {
background-color:006600;
font-family:sans-serif;
font-size:14pt;
color:ffffff;
text-align:center;
}

#contenedor{
 width:600px;
 margin:0px, auto;
 text-align:left;
 position:relative;
}
Lo sorprendente es que Explorer8 me lo lee sin problemas, asi como el resto de ids, pero tanto firefox 3.0 como Opera, Safari y Chrome ignoran las especificaciones de ambas, aunque aplican las del resto de ids definidas en la hoja de estilo (!!!)

Creo que puede ser cosa del Doctype:
Código:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//ES">
<HTML>
<HEAD>
 <meta name="keywords" content="camping, acampada, bungalows, habitaciones, rooms, caravana, autocaravana, scouts, grupos, cadiz, c&aacute;diz, jimena, gibraltar, algeciras, andalucia, hozgarganta, senderismo, gr7, econ&oacute;mico, economico, barato, cheap, piscina, swimming-pool" />
 
 <link rel="stylesheet" media="all" type="text/css" href="camping.css" /> 
 
 <TITLE>Camping &quot;Los Alcornocales&quot;</TITLE>
</HEAD>
Aunque no le veo el sentido, y no consigo dar con el que me lo valide para firefox (y espero que para todos los otros). Se solucionaría metiendo los estilos del BODY en la propia etiqueta?¿¿porqué?? Alguien me puede echar un cable?? xDDD Por favoooooooor!!!!



Mith

Gracias desde YA!
  #2 (permalink)  
Antiguo 12/08/2010, 07:35
 
Fecha de Ingreso: agosto-2010
Mensajes: 13
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Loco con los navegadores

pd:

AÑADO la continuación del código x si el fallo estuviera ahí ;)

Código:
</HEAD>

<body>
	<div id="contenedor" style="background-color:#006600;">	
		<div style="width:750px;height:137px;background-image:url(imagenes/cab_index.png); z-index:1;"></div>
		<!-- Banner temporal para eventos u ofertas especiales. para visibilizarlo, cambiar el parametro VISIBILITY -->
		<div style="width:170px; height:120px; position:absolute; top:10px; left:560px; z-index:2; visibility: hidden;"><a href="web/spa/piscina_spa.html" ><img src="imagenes/banner_piscina.png"; style="border:none;"></a></div>
danke!
  #3 (permalink)  
Antiguo 12/08/2010, 10:04
 
Fecha de Ingreso: enero-2008
Ubicación: Buenos Aires
Mensajes: 305
Antigüedad: 9 años, 11 meses
Puntos: 14
Respuesta: Loco con los navegadores

#contenedor{
width:600px;
margin: 0px auto;
text-align:left;
position:relative;
}

Tienes una coma entre 0px y auto, que no va!
  #4 (permalink)  
Antiguo 13/08/2010, 04:32
 
Fecha de Ingreso: agosto-2010
Mensajes: 13
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Loco con los navegadores

MUCHISIMAS GRACIAS KOKOOU!!

Joder, hay veces que por más que miramos no vemos lo más evidente---> también me faltaba un # delante del background color de BODY

Aun asi, no negaré que soy un novato en esto, y el fallo que me has revelado me hubiese (me estaba) costado la vida vislumbrarlo.

Tanke! ;)
  #5 (permalink)  
Antiguo 13/08/2010, 08:46
 
Fecha de Ingreso: enero-2008
Ubicación: Buenos Aires
Mensajes: 305
Antigüedad: 9 años, 11 meses
Puntos: 14
Respuesta: Loco con los navegadores

Son cosas que pasan :D

Etiquetas: doctype, firefox
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:53.