Foros del Web » Diseño web » CSS »

Mi CSS no funciona en Explorer

Estas en el tema de Mi CSS no funciona en Explorer en el foro de CSS en Foros del Web. Amigos necesito su ayuda con mi codigo CSS Lo que pasa es que funciona perfectamente en Mozilla. Pero en Explorer no funciona nada tan solo ...
  #1 (permalink)  
Antiguo 31/01/2011, 17:11
Avatar de blakmetall  
Fecha de Ingreso: diciembre-2010
Ubicación: Jalisco
Mensajes: 181
Antigüedad: 3 años, 7 meses
Puntos: 18
Mi CSS no funciona en Explorer

Amigos necesito su ayuda con mi codigo CSS

Lo que pasa es que funciona perfectamente en Mozilla.
Pero en Explorer no funciona nada tan solo el menu y solo los links del menu.
La verdad soy relativamente nuevo al css y no se mucho aun, ando viendo documentacion de eso. pero por lo pronto alguien me podria ayudar.


este es mi codigo HTML:

Código HTML:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml">
  3.     <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
  4.    <title>Sistema</title>
  5.     <link href="css/style.css" rel="stylesheet" type="text/css" />
  6.      <script type="text/javascript" src="js/main.js"></script>
  7. </head>
  8.  
  9. <tr>
  10.     <div id="header">
  11.  
  12.     </div>
  13. </tr>
  14. <tr>
  15.     <table class="content">
  16.         <tr>
  17.         <div id="subject">
  18.             <ul class="link">
  19.                 <li><a href="index.php"> Inicio </a></li>
  20.                 <li><a href="alta.php"> Altas </a></li>
  21.                 <li><a href="baja.php"> Bajas </a></li>
  22.                 <li><a href="actualizacion.php"> Modificaciones </a></li>
  23.                 <li><a href="reportes.php"> Reportes </a></li>
  24.                
  25.                 <div>
  26.                     <li><a href="menu1.php" class="menuLink">Expedientes</a>
  27.                     <ul class="menus" id="menu1">
  28.                         <li><a href="archivosUp.php"> Subir </a></li>
  29.                         <li><a href="archivosDown.php"> Bajar </a></li>
  30.                     </ul>
  31.                     </li>
  32.                 </div>
  33.                
  34.                 <div>
  35.                     <li><a href="menu2.php" class="menuLink">Respaldos</a>
  36.                     <ul class="menus" id="menu2">
  37.                         <li><a href="restaurar.php"> Restaurar </a></li>
  38.                         <li><a target="_blank" href="guardar.php"> Guardar </a></li>
  39.                     </ul>
  40.                     </li>
  41.                 </div>
  42.             </ul>
  43.         </div>
  44.         </tr>
  45.         <tr>
  46.         <div id="content">
  47.          Contenido
  48.         </div>
  49.         </tr>
  50.     </table>
  51. </tr>
  52. </tr>
  53.  
  54.  
  55. </body>
  56. </html>

y este es mi css:

Código CSS:
Ver original
  1. html {
  2.     height: 100&#37;;
  3.     width: 100%;
  4. }
  5.    
  6. body {
  7.     height: 100%;
  8.     width: 100%;
  9.     margin: 0;
  10.     padding: 0;
  11.     border: 0;
  12.     background: #FFFFFF;
  13.    font: 13px Verdana,Arial,Helvetica,sans-serif;
  14. }
  15.  
  16. div {
  17.     width: 180px;  
  18.     float: left;
  19. }
  20.  
  21. div#header {
  22.     height: 100%;
  23.     width: 100%;
  24.     height: 200px;
  25.     text-align: center;
  26.     background: #F4FA58;
  27.     font-size:30px;
  28. }
  29.  
  30. div#subject {
  31.     font-weight: bold;
  32.     line-height: 35px;
  33.     height: 100%;
  34.     width: 18%;
  35.     text-align: left;
  36.     background: #084B8A;
  37.     font-size:15px;
  38. }
  39.  
  40. div#subject a{
  41.     text-decoration: none;
  42. }
  43.  
  44. div#content {
  45.     height: 100%;
  46.     text-align: center;
  47.     font-size:20px;
  48. }
  49.  
  50. ul{
  51.     list-style-type: none;
  52. }
  53.  
  54. #posicion {
  55.     height: 600px;
  56. }
  57.  
  58. #content {
  59.    
  60. }
  61.  
  62. ul.link li{
  63.     color: #FFFF00;
  64. }
  65.  
  66.  
  67. ul.link a{
  68.     color: #FFFF00;
  69. }
  70.  
  71. input.invalid {
  72.     background-color: #FF9;
  73.     border: 2px red inset;
  74. }
  75.  
  76. select.invalid{
  77.     background-color: #FF9;
  78.     border: 2px red inset;
  79. }
  80.  
  81. ul#menu1, ul#menu2 {
  82.     display: none;
  83.     line-height: 25px;
  84.     margin: 0;
  85.     margin-left: 20px;
  86.     padding: 0;
  87.     font-weight: normal;
  88.  
  89. }
  90.  
  91. a.menuLink, li a {
  92.     text-decoration: none;
  93.     color: #FFFF00;
  94.  
  95. }
  96.  
  97. li a:hover {
  98.     background-color: #FF0000;
  99.     /*color: white;*/
  100. }
  101.  
  102. dl#archivosUp {
  103.     position:absolute;
  104.     top:250px;
  105.     left:400px;
  106. }
  107.  
  108. /* EXPEDIENTES */
  109.  
  110. table#tablaExpedientes {
  111.     position:absolute;
  112.     top:300px;
  113.     left:500px;
  114. }
  115.  
  116. table#tablaExpedientes tr th {
  117.     background: #084B8A;
  118.     color:#F4FA58;
  119.     font-size:15px;
  120.     padding:20px;
  121. }
  122.  
  123. table#tablaExpedientes tr td {
  124.     background: #F3F781;
  125.     color:#F4FA58;
  126.     font-size:12px;
  127.     padding:5px;
  128. }
  129.  
  130. table#tablaExpedientes a {
  131.     color: blue;
  132.     text-decoration: none;
  133. }
  134.  
  135. table#tablaExpedientes tr td {
  136.     color: blue;
  137.     text-decoration: none;
  138. }
  139.  
  140. table#reportes{
  141.     position:absolute;
  142.     top:220px;
  143.     left:500px;
  144. }
  145.  
  146. #reportes th{
  147.     color:#084B8A;
  148.     font-size:15px;
  149.     padding:5px;
  150. }
  151.  
  152. #reportes th#error{
  153.     color:red;
  154.     font-size:12px;
  155. }
  156.  
  157. table#generador{
  158.     border-color: blue;
  159.     position:absolute;
  160.     top:400px;
  161.     left:205px;
  162.     font-size:12px;
  163.     background: #084B8A;
  164. }
  165.  
  166. #generador  td{
  167.     color: #084B8A;
  168.     text-decoration: none;
  169.     background: #F3F781;
  170.     padding:2px;
  171. }
  172.  
  173. #generador th{
  174.     height: 30px;
  175. }
  176.  
  177. #generador a{
  178.     color:#F4FA58;
  179.     font-size:14px;
  180.     padding:2px;
  181. }

De antemano Gracias por todas sus respuestas
  #2 (permalink)  
Antiguo 31/01/2011, 17:50
Avatar de ArturoGallegos
Colaborador
 
Fecha de Ingreso: febrero-2008
Ubicación: Michoacán, México
Mensajes: 4.207
Antigüedad: 6 años, 5 meses
Puntos: 682
Respuesta: Mi CSS no funciona en Explorer

creo que es un milagro que FF te muestre bien tu html

andas mal en una tabla no se estructura de esa forma

esto esta mal

Código HTML:
Ver original
  1.     <tr>
  2.         <div></div>
  3.     </tr>

esto esta bien
Código HTML:
Ver original
  1.     <tr>
  2.         <td></td>
  3.     </tr>
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados ni ningún otro medio....
  #3 (permalink)  
Antiguo 31/01/2011, 18:00
Avatar de sanxuan  
Fecha de Ingreso: enero-2011
Ubicación: Gijón
Mensajes: 676
Antigüedad: 3 años, 6 meses
Puntos: 36
Respuesta: Mi CSS no funciona en Explorer

Puedes validar el HTML en htpp://validator.w3.org.
Un código que no pasa la validación no tiene ninguna garantía de mostrarse correctamente.
  #4 (permalink)  
Antiguo 31/01/2011, 18:38
Avatar de blakmetall  
Fecha de Ingreso: diciembre-2010
Ubicación: Jalisco
Mensajes: 181
Antigüedad: 3 años, 7 meses
Puntos: 18
Respuesta: Mi CSS no funciona en Explorer

Wow amigos muchisimas gracias eso es un error increiblemente tonto. yo pense que era problema de css por que si valia en firefox.

Y tambien voy a ver eso de validar HTML no sabia que existia tal cosa.

Gracias por todo
  #5 (permalink)  
Antiguo 01/02/2011, 09:20
 
Fecha de Ingreso: octubre-2009
Mensajes: 129
Antigüedad: 4 años, 9 meses
Puntos: 1
Exclamación Respuesta: Mi CSS no funciona en Explorer

Cita:
Iniciado por sanxuan Ver Mensaje
Puedes validar el HTML en htpp://validator.w3.org.
Un código que no pasa la validación no tiene ninguna garantía de mostrarse correctamente.
no te entendí muy bien no se mucho sobre este tema me podrías explicar un poco mejor gracas
  #6 (permalink)  
Antiguo 01/02/2011, 11:06
Avatar de ArturoGallegos
Colaborador
 
Fecha de Ingreso: febrero-2008
Ubicación: Michoacán, México
Mensajes: 4.207
Antigüedad: 6 años, 5 meses
Puntos: 682
Respuesta: Mi CSS no funciona en Explorer

Cita:
Iniciado por moises9633 Ver Mensaje
no te entendí muy bien no se mucho sobre este tema me podrías explicar un poco mejor gracas
que parte del problema y las soluciones no entendiste? visitaste el link del compañero -> http://validator.w3.org/

por si no lo has hecho y probado en este sitio colocas el link a tu sitio y valida el codigo que tenga una sintaxis correcta... como le a ocurrido al compañero puede haber errores en tu código que no permiten se visualice correctamente en todos los navegadores
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados ni ningún otro medio....
  #7 (permalink)  
Antiguo 01/02/2011, 11:15
 
Fecha de Ingreso: octubre-2009
Mensajes: 129
Antigüedad: 4 años, 9 meses
Puntos: 1
Respuesta: Mi CSS no funciona en Explorer

Cita:
Iniciado por Ag666 Ver Mensaje
que parte del problema y las soluciones no entendiste? visitaste el link del compañero -> http://validator.w3.org/

por si no lo has hecho y probado en este sitio colocas el link a tu sitio y valida el codigo que tenga una sintaxis correcta... como le a ocurrido al compañero puede haber errores en tu código que no permiten se visualice correctamente en todos los navegadores
aaa ok no sabia eso mira lo que me aparecio

Código PHP:
Errors found while checking this document as XHTML 1.0 Transitional!
Result:     21 Errors 
Código PHP:
Line 142Column 33there is no attribute "STYLE"
<div class="smallfont"><a STYLE="text-decoration:none" href="http://www.comunid… 

Código PHP:
 Line 142Column 185required attribute "alt" not specified
&#8230;s.com/ImagenesW/home.png" width="19" border="0" height="19" /> Inicio</a></div> 
Código PHP:
Line 145Column 193required attribute "alt" not specified
&#8230;m/ImagenesW/newsII.png" width="19" border="0" height="19" /> Noticias</a></div> 
Código PHP:
Line 152Column 192required attribute "alt" not specified
&#8230;om/ImagenesW/movies.png" width="19" border="0" height="19" /> Videos </a></div> 
Código PHP:
Line 155Column 303required attribute "alt" not specified
&#8230;/1283360546_ark2.png" width="19" border="0" height="19" /> Descargas </a></div> 
etc...
tengo que corregir todo eso ?
  #8 (permalink)  
Antiguo 01/02/2011, 11:19
Avatar de ArturoGallegos
Colaborador
 
Fecha de Ingreso: febrero-2008
Ubicación: Michoacán, México
Mensajes: 4.207
Antigüedad: 6 años, 5 meses
Puntos: 682
Respuesta: Mi CSS no funciona en Explorer

si deseas un código valido y que se vea correcto en cualquier navegador SIIII

pero a la de ya... especialmente
Cita:
Line 142, Column 33: there is no attribute "STYLE"
<div class="smallfont"><a STYLE="text-decoration:none" href="http://www.comunid…
estas usando xhtml y todas las propiedades y atributos deben ir en minúsculas, tu has escrito STYLE y debe ser style

Nota: es mejor usar una clase dentro de una hoja de estilo en lugar de aplicar el css directamente sobre el objeto en cuestión
__________________
Toda ayuda se proporciona exclusivamente en el foro, no skype, no mensajes privados ni ningún otro medio....

Etiquetas: explorer
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:09.
SEO by vBSEO 3.3.2