Foros del Web » Creando para Internet » CSS »

No me aparece imagen de fondo

Estas en el tema de No me aparece imagen de fondo en el foro de CSS en Foros del Web. Buenas a todos, estoy practicando con css y no logro que me aparezca una imagen de fondo. Os pongo el código y a ver si ...
  #1 (permalink)  
Antiguo 19/04/2010, 13:04
 
Fecha de Ingreso: agosto-2008
Mensajes: 49
Antigüedad: 9 años, 4 meses
Puntos: 0
No me aparece imagen de fondo

Buenas a todos, estoy practicando con css y no logro que me aparezca una imagen de fondo. Os pongo el código y a ver si me podéis ayudas.

Lo que intento es poner bordes redondos a una caja, pero para ello primero necesito que la imagen que va a ser el borde se vea y luego posicionarla en el lugar adecuado. Sin embargo ya la cago en el primer paso y no consigo enconrtar el error.

Un saludo.

Código HTML:
<html>

<head>
<style type = "text/css">

.caja {
	width: 200px;
	height: 200px;
	margin: 10 auto 0 auto;
	background-color: pink;
	border: 1px solid black;
	background-image: url(c:\wamp\www\Rss\BR.png);
}

</style>
</head>


<body>

<div class = "caja">
	<p> petete </p>
</div>

</body>
</html> 
  #2 (permalink)  
Antiguo 19/04/2010, 14:28
Avatar de cemansilla  
Fecha de Ingreso: septiembre-2007
Ubicación: Buenos Aires, Argentina, Argentina
Mensajes: 214
Antigüedad: 10 años, 3 meses
Puntos: 5
Respuesta: No me aparece imagen de fondo

Cambia la url a la imágen:

Código HTML:
background-image: url(http://Rss/BR.png);
__________________
CÉSAR MANSILLA
Web & Mobile Developer - Analista - Creativo - Curioso
http://cesarmansilla.com/
http://cesarmansilla.com/blog/
  #3 (permalink)  
Antiguo 19/04/2010, 14:31
 
Fecha de Ingreso: agosto-2008
Mensajes: 49
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

Cita:
Iniciado por cemansilla Ver Mensaje
Cambia la url a la imágen:

Código HTML:
background-image: url(http://Rss/BR.png);
Nope. No va.
  #4 (permalink)  
Antiguo 19/04/2010, 14:46
 
Fecha de Ingreso: agosto-2008
Mensajes: 49
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

Bueno, ya está. He colocado el archivo html y la imagen en la misma carpeta y he cambiado el código a...

Código HTML:
Ver original
  1. background-image: url(BR.png);

Es normal que haya problemas en css con direcciones absolutas?
  #5 (permalink)  
Antiguo 19/04/2010, 14:48
Avatar de linternazo  
Fecha de Ingreso: abril-2010
Mensajes: 76
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

Hola caquilla23 (excelente nombre, por cierto... )


prueba con:

background-image: url(c:/wamp/www/Rss/BR.png);
  #6 (permalink)  
Antiguo 19/04/2010, 15:09
 
Fecha de Ingreso: agosto-2008
Mensajes: 49
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

Cita:
Iniciado por linternazo Ver Mensaje
Hola caquilla23 (excelente nombre, por cierto... )


prueba con:

background-image: url(c:/wamp/www/Rss/BR.png);
Tampoco me va.

PD. Muchas gracias. El nombre se me ocurrió en un acto de desesperación que los que me gustaban no estaban disponibles. JAJAJA. EL tuyo también mola
  #7 (permalink)  
Antiguo 19/04/2010, 16:25
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: No me aparece imagen de fondo

Hola:

Está claro que el problema está en la ruta. Debes buscar información sobre rutas relativas y absolutas y despues estudiar tu árbol de carpetas. Además, fijate en lo que te marco en rojo:

Código:
background-image: url(c:\wamp\www\Rss\BR.png);
La ruta tal y como la tienes ahora busca la imagen en tu disco duro ¿Dónde la buscará cuando subas la página? Pues también en tu disco duro, lo malo es que no sabrá donde está.

Saludos.

  #8 (permalink)  
Antiguo 19/04/2010, 18:02
 
Fecha de Ingreso: agosto-2008
Mensajes: 49
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

Cita:
Iniciado por jomaruro Ver Mensaje
Hola:

Está claro que el problema está en la ruta. Debes buscar información sobre rutas relativas y absolutas y despues estudiar tu árbol de carpetas. Además, fijate en lo que te marco en rojo:

Código:
background-image: url(c:\wamp\www\Rss\BR.png);
La ruta tal y como la tienes ahora busca la imagen en tu disco duro ¿Dónde la buscará cuando subas la página? Pues también en tu disco duro, lo malo es que no sabrá donde está.

Saludos.

No si el tema de que la imagen, estableciendo la ruta absoluta en mi disco duro, no funcionará cuando esté en un servidor lo tengo claro. Pero primero quiero ver si la cosa funciona en el ordenador y luego ya haré los cambios cuando lo suba a un servidor.

Lo que me mata es que no me cargue un archivo de imagen que no esté en la misma carpeta que el html. He probado tambien a meter el archivo en una carpeta (imagenes) dentro del directorio donde tengo la web e indicarlo en url(imagenes/BR.png) pero tampoco lo reconoce. Por alguna razón no consigo que aparezca la imagen si no es estando en el mismo nivel que el html.

Me fastidia bastante saber que estoy metiendo la pata en algún sitio y no encontrar el fallo.
  #9 (permalink)  
Antiguo 20/04/2010, 02:18
Avatar de awesomeboy  
Fecha de Ingreso: abril-2010
Mensajes: 27
Antigüedad: 7 años, 7 meses
Puntos: 0
Respuesta: No me aparece imagen de fondo

caray pues mira, para que no te hagas lios pon tu html, en la misma carpeta donde esta la imagen y ya.

background-image: url(BR.png);

o en la misma carpeta donde esta tu html, pero la imagen en un directorio images

directorio principal/index.html
directorio principal/images/br.png

background-image: url(images/BR.png);

Y te va otro tip, puede ser que la imagen este en un directorio superior al de tu html

br.png / directorio principal / index.html

en ese caso debes agregar un ../ por cada directorio superior, hasta llegar a la imagen

background-image: url(../BR.png);

o estupidamente tu problema puede radicar en la diagonal, ya que en tu codigo esta " \ "
background-image: url(c:\wamp\www\Rss\BR.png);

Y generalmente se usa " / " de esta si no estoy seguro que afecte
  #10 (permalink)  
Antiguo 02/05/2010, 10:43
 
Fecha de Ingreso: octubre-2009
Mensajes: 45
Antigüedad: 8 años, 2 meses
Puntos: 3
Respuesta: No me aparece imagen de fondo

la solucion sería
background-image: url("./Rss/BR.png");
  #11 (permalink)  
Antiguo 27/11/2014, 19:42
 
Fecha de Ingreso: noviembre-2014
Mensajes: 1
Antigüedad: 3 años
Puntos: 0
Respuesta: No me aparece imagen de fondo

body{
background: url("http://localhost/Rss/BR.png");

}
  #12 (permalink)  
Antiguo 28/11/2014, 11:49
Avatar de drako_darpan  
Fecha de Ingreso: octubre-2008
Ubicación: Sinaloa
Mensajes: 617
Antigüedad: 9 años, 2 meses
Puntos: 58
Respuesta: No me aparece imagen de fondo

Gracias por responder Luis_Mateo, pero este post es algo viejo, jejeje.

Algun moderador que cierre este post.
__________________
Your Code as a Crime Scene...
  #13 (permalink)  
Antiguo 28/11/2014, 17:02
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.200
Antigüedad: 4 años, 4 meses
Puntos: 384
Respuesta: No me aparece imagen de fondo

Cita:
Iniciado por drako_darpan Ver Mensaje
Gracias por responder Luis_Mateo, pero este post es algo viejo, jejeje.

Algun moderador que cierre este post.
Nada drako,,, suelen ser posteadores en busca de los 30 mensajes.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-

Etiquetas: fondo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Tema Cerrado




La zona horaria es GMT -6. Ahora son las 19:24.