Foros del Web » Creando para Internet » CSS »

No corre en Explorer

Estas en el tema de No corre en Explorer en el foro de CSS en Foros del Web. Hola Foristas, tengo este Css que funciona bien en Firefox Mozilla y Opera, pero no en Explorer. ¿Me dan una ayudita? Gracias por todo Admoro ...
  #1 (permalink)  
Antiguo 27/02/2008, 06:00
Avatar de admoro  
Fecha de Ingreso: agosto-2005
Ubicación: Prov. de Bs As. Argentina
Mensajes: 432
Antigüedad: 12 años, 3 meses
Puntos: 3
Exclamación No corre en Explorer

Hola Foristas, tengo este Css que funciona bien en Firefox Mozilla y Opera, pero no en Explorer. ¿Me dan una ayudita?
Gracias por todo
Admoro

///////////--------------/////////////////////-----------------///////////////-----------////////////////

.nav {
height:35px;
background: url(../gif/pro_line_0.gif) repeat-x;
position:relative;
font-family:arial, verdana, sans-serif;
font-size:11px;
width:956px;
z-index:80;
}

.nav .table {
display:table;
margin:0 auto;
}

.nav .select,
.nav .current {
margin:0;
padding:0;
list-style:none;
display:table-cell;
white-space:nowrap;
}

.nav li {
margin:0;
padding:0;
height:auto;
float:left;
}

.nav .select a {
display:block;
height:35px;
float:left;
background: url(../gif/pro_line_0.gif);
padding:0 30px 0 30px;
text-decoration:none;
line-height:35px;
white-space:nowrap;
color:#FFFFFF;
}

.nav .current a {
display:block;
height:35px;
float:left;
background: url(../gif/pro_line_2.gif);
padding:0 0 0 15px;
text-decoration:none;
line-height:35px;
white-space:nowrap;
color:#fff;
}


.nav .current a b {
display:block;
padding:0 30px 0 15px;
background:url(../gif/pro_line_2.gif) right top;
}

.nav .select a:hover,
.nav .select li:hover a {
background: url(../gif/pro_line_1.gif);
padding:0 0 0 15px;
cursor:pointer;
color:#fff;
}

.nav .select a:hover b,
.nav .select li:hover a b {
display:block;
float:left;
padding:0 30px 0 15px;
background:url(../gif/pro_line_1.gif) right top;
cursor:pointer;
}

.nav .select_sub {
display:none;
}

/* IE6 only */
.nav table {
border-collapse:collapse;
margin:-1px;
font-size:1em;
width:0;
height:0;
}

.nav .sub {
display:table;
margin:0 auto;
padding:0;
list-style:none;
}

.nav .sub_active .current_sub a,
.nav .sub_active a:hover {
background:transparent;
color:#f00;
}

.nav .select :hover .select_sub,
.nav .current .show {
display:block;
position:absolute;
width:956px;
top:35px;
background:url(../gif/back_0.gif);
padding:0;
z-index:100;
left:0;
text-align:center;
}

.nav .current .show {
z-index:10;
}

.nav .select :hover .sub li a,
.nav .current .show .sub li a {
display:block;
float:left;
background:transparent;
padding:0 10px 0 10px;
margin:0;
white-space:nowrap;
border:0;
color:#444;
}

.nav .current .sub li.sub_show a {
color:#088;
cursor:default;
background:url(../gif/menus/back_1.gif);
}

.nav .select :hover .sub li a:hover,
.nav .current .sub li a:hover {
visibility:visible;
color:#088;
background:url(../gif/menus/back_1.gif);
}

Última edición por admoro; 27/02/2008 a las 06:01 Razón: Me equivoqué
  #2 (permalink)  
Antiguo 27/02/2008, 10:00
 
Fecha de Ingreso: febrero-2008
Mensajes: 62
Antigüedad: 9 años, 9 meses
Puntos: 1
Re: No corre en Explorer

Cual es el problema que presenta?
  #3 (permalink)  
Antiguo 27/02/2008, 16:14
Avatar de admoro  
Fecha de Ingreso: agosto-2005
Ubicación: Prov. de Bs As. Argentina
Mensajes: 432
Antigüedad: 12 años, 3 meses
Puntos: 3
Re: No corre en Explorer

Gracias Cleft, subo el portal para que mejor lo vean, creo será más conveniente. En rato lo posteo. Gracias de nuevo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:18.