Foros del Web » Creando para Internet » CSS »

No corre en Explorer

Estas en el tema de No corre en Explorer en el foro de CSS en Foros del Web. Hola foristas, tengo un problemilla. Estoy realizando una página que corre bien en Mozilla y Opera, pero no en Explorer. El problema, en sí, es ...
  #1 (permalink)  
Antiguo 17/03/2008, 19:34
Avatar de admoro  
Fecha de Ingreso: agosto-2005
Ubicación: Prov. de Bs As. Argentina
Mensajes: 432
Antigüedad: 12 años, 3 meses
Puntos: 3
No corre en Explorer

Hola foristas, tengo un problemilla. Estoy realizando una página que corre bien en Mozilla y Opera, pero no en Explorer. El problema, en sí, es la barra de navegación que no se ve en IE. La misma la basé en un código de CSSPLAY.
¿Me darían una ayudita? es para ver qué le sucede.
MUCHAS GRACIAS POR LAS CONSTANTES AYUDAS.
Admoro

http://www.hoymercedes.com.ar/seybu/index.html
  #2 (permalink)  
Antiguo 17/03/2008, 19:59
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: No corre en Explorer

Creo que no copiaste bien el código. Añade esto antes de cerrar la etiqueta </head>

<!--[if lte IE 6]> <link href="css/pro_dropline_ie.css" rel="stylesheet" type="text/css" /><![endif]-->

Tienes una css específica para IE6 pero no la estás llamando.

Mikel.
  #3 (permalink)  
Antiguo 18/03/2008, 12:22
Avatar de admoro  
Fecha de Ingreso: agosto-2005
Ubicación: Prov. de Bs As. Argentina
Mensajes: 432
Antigüedad: 12 años, 3 meses
Puntos: 3
Re: No corre en Explorer

Lo modifico, pero no mejora.......pero me parece que lo lee bien...no sé por dónde pasa.
Muchas gracias Mikmoro
Admoro
  #4 (permalink)  
Antiguo 18/03/2008, 13:58
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: No corre en Explorer

¿Lo has modificado? Miro tu código fuente y no veo que hayas incorporado al head de tu html el comentario condicional de explorer que te puse. Quizá te pareció que no funcionaba y lo volviste a quitar.

Perdona si te parece tonto, pero... ¿has eliminado la línea "<link href="css/pro_dropline_ie.css" rel="stylesheet" type="text/css" />" y la has incorporado al comentario condicional como te puse?

Y si todo esto está ya bien hecho... ¿no te funciona y no ves modificaciones en IE6 cuando modificas la css "pro_dropline_ie.css"? Es muy raro.

Si es posible actualiza estas modificaciones en tu html y súbelo a tu servidor para que podamos verlo, porque me extraña bastante.

Mikel.
  #5 (permalink)  
Antiguo 19/03/2008, 12:11
Avatar de admoro  
Fecha de Ingreso: agosto-2005
Ubicación: Prov. de Bs As. Argentina
Mensajes: 432
Antigüedad: 12 años, 3 meses
Puntos: 3
Re: No corre en Explorer

Hola MIkmoro, muchas gracias por tu tiempo. Lo haré en rato y les cuento.
Gracias
Admoro
  #6 (permalink)  
Antiguo 19/03/2008, 13:47
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: No corre en Explorer

Hola, Admoro.
Ya no hace falta que mires lo del comentario condicional, porque el problema no es ese; el menú está diseñado para funcionar sin eso.
He estado mirando el html y el problema es que tienes una cantidad enorme de errores en el código de la tabla. Hay etiquetas sin cerrar, otras cerradas sin abrir, comentarios condicionales que abren cosas que no se cierran, en fin, una barbaridad.

Te he corregido el código, pero deberás ser más cuidadoso cuando escribes, y sobre todo, siempre siempre intentar validar, que te dirá muchos de los errores.

Sustituye toda la tabla del menú por esta:

Cita:
<table width="956" border="0" align="center" cellpadding="0" cellspacing="0">
<tr>
<td>
<div class="nav">
<div class="table">

<ul class="select"><li><a href="index.html"><b>Home</b></a></li>
</ul>

<ul class="select"><li><a href="xts/institucional.html"><b>Extensión</b><!--[if IE 7]><!--></a><!--<![endif]-->
<!--[if lte IE 6]><table><tr><td><![endif]-->
<div class="select_sub">
<ul class="sub">
<li><a href="xts/institucional.html">Institucional</a></li>
<li><a href="xts/proyectos.html">Proyectos</a></li>
<li><a href="xts/cultura.html">Cultura</a></li>
<li><a href="xts/pei.html">Publicaciones e imprenta</a></li>
<li><a href="xts/presentacion.html">Presentación</a></li>
</ul>
</div>
<!--[if lte IE 6]></td></tr></table></a><![endif]-->
</li>
</ul>

<ul class="select"><li><a href="bts/bienestar.html"><b>Bienestar</b><!--[if IE 7]><!--></a><!--<![endif]-->
<!--[if lte IE 6]><table><tr><td><![endif]-->
<div class="select_sub show">
<ul class="sub">
<li><a href="bts/deportes.html">Deportes</a></li>
<li><a href="bts/enfermeria.html">Enfermería</a></li>
<li><a href="bts/salud.html">Salud</a></li>
</ul>
</div>
<!--[if lte IE 6]></td></tr></table></a><![endif]-->
</li>
</ul>

<ul class="select"><li><a href="sds/syc.html"><b>Sedes</b><!--[if IE 7]><!-->
</a><!--<![endif]-->
<!--[if lte IE 6]><table><tr><td><![endif]-->
<div class="select_sub">
<ul class="sub">
<li><a href="sds/cp.html">Campana</a></li>
<li><a href="sds/gs.html">San Miguel</a></li>
<li><a href="sds/ch">Chivilcoy</a></li>
<li><a href="sds/ecu.html">Eduador</a></li>
</ul>
</div>
<!--[if lte IE 6]></td></tr></table></a><![endif]-->
</li>
</ul>

<ul class="select"><li><a href="ntv/normativa.html"><b>Normativa</b></a>
</li>
</ul>
<ul class="select"><li><a href="nove/novedades.html"><b>Novedades</b></a>
</li>
</ul>
<ul class="select"><li><a href="els/enlaces.html"><b>Enlaces</b></a>
</li></ul>
</div>
</div></td>
</tr>
</table>
Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:24.