Foros del Web » Creando para Internet » CSS »

No funciona mi CSS

Estas en el tema de No funciona mi CSS en el foro de CSS en Foros del Web. El tema es el siguiente, estaba haciendo modificaciones sobre un formulario para un sistema de mensajes internos en mi web, no toqué nada del CSS ...
  #1 (permalink)  
Antiguo 05/05/2011, 19:03
 
Fecha de Ingreso: julio-2009
Ubicación: Córdoba
Mensajes: 20
Antigüedad: 8 años, 5 meses
Puntos: 0
Exclamación No funciona mi CSS

El tema es el siguiente, estaba haciendo modificaciones sobre un formulario para un sistema de mensajes internos en mi web, no toqué nada del CSS y de pronto dejaron de funcionar los estilos. Lo más extraño es que no dejaron de funcionar para toda la web, sino que para dos div (logo y login) siguió funcionando, mientras que, para todas las demas, de todas las otras páginas no funcionó más. ¿Alguien tiene idea de que puede haber pasado?

Les dejo mi CSS:

[URL="http://derucula.com.ar/index.css"]Estilos[/URL]

y el home como muestra.

Código HTML:
<title>De R&uacute;cula - Guia Culinaria C&oacute;rdoba</title> 
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> 
<meta name="Keywords" content="Restaurantes, Restaurants, Cordoba, hoteles, vinerias, vinos, comidas, gourmet, rucula" /> 
<meta name="Description" content="Guia culinaria de C&oacute;rdoba con restaurantes, vinerias, hoteles y recomendaciones gourmet." /> 
<meta name="author" content="Ezequiel Urquidi" /> 
<meta name="Subject" content="Guia Culinaria" /> 
<meta name="Language" content="es" /> 
<meta name="Robots" content="index, follow" /> 
<link rel="stylesheet" href="index.css" type="text/css" /> 
<link href='favicon.png' rel='shortcut icon' type='image/png' /> 
</head> 
 
<body> 
<div id="contenedor"> 
<div id="cabecera"> 
<div id="logo"> 
<img src="http://derucula.host22.com/imagenes/logo.jpg" /> 
</div> 
<div id="login"> 
<form id='log-in' action='login.php' method='post'> 
<span class='Estilo4'>Usuario</span> 
<input name='usuario' type='text' id='usuario' /> 
<span class='Estilo4'>Password</span>  
<input name='password' type='password' id='password' /> 
<input name='boton' type='submit' id='submit' class='buttons' value='entrar' /> 
</form> 
</div> 
<div id="menu" align="right"> 
<ul class='menu'> 
  <li><a href='http://derucula.com.ar' class='active' target='_self'><span>&nbsp;&nbsp;&nbsp;Home&nbsp;&nbsp;&nbsp;</span></a></li> 
  <li><a href='http://derucula.com.ar/restaurantes-lista.php' target='_self'><span>Restaurantes</span></a></li> 
  <li><a href='http://derucula.com.ar/vinerias.html' target='_self'><span>&nbsp;Vinerias&nbsp;</span></a></li> 
  <li><a href='http://derucula.com.ar/eventos.html' target='_self'><span>&nbsp;Eventos</span></a></li> 
  <li><a href='http://derucula.com.ar/registro.php' target='_self'><span>Registrate</span></a></li> 
</ul></div> 
</div><!-- /cabecera --> 
<div id="cuerpo"> 
<div id="destacado"> 
<img src="http://derucula.host22.com/imagenes/destacado.jpg" /> 
</div> 
<div id="facebook"> 
<iframe align="right" src="http://www.facebook.com/plugins/likebox.php?id=111622150793&amp;width=250&amp;connections=10&amp;stream=true&amp;header=true&amp;height=587" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:250px; height:587px;" allowTransparency="true"></iframe> 
</div> 
<div id="top5"> 
<img src="http://derucula.host22.com/imagenes/top5.jpg" /> 
</div> 
</div> 
<p>&nbsp;</p> 
<div id="bottonmenu"> 
<a href="http://derucula.com.ar/terminos.html">Términos y Condiciones</a>   -   <a href="http://derucula.com.ar/legales.html">Legales</a>   -   <a href="http://derucula.com.ar/contacto.html">Contacto</a>   -   <a href="http://derucula.com.ar">Home</a>   -   <a href="http://derucula.com.ar/links.html">Links</a>   -   <a href="http://derucula.com.ar/formulario.php">Agregá tu Restaurante</a> 
</div> 
<div id="bottom"> 
2010 - C&oacute;rdoba - Argentina
<img src="http://derucula.host22.com/imagenes/bottom.jpg" /> 
</div> 
</div><!-- /contenedor --> 
</body> 
</html> 
  #2 (permalink)  
Antiguo 06/05/2011, 07:51
Avatar de sergio87  
Fecha de Ingreso: octubre-2007
Ubicación: Buenos Aires
Mensajes: 323
Antigüedad: 10 años, 1 mes
Puntos: 8
Respuesta: No funciona mi CSS

Lo bajé, lo probé y funciona todo el CSS. Lo único que puedo decirte es que siempre cierres los estilos entre { }, en algunos casos vi que faltaban que lo cierres, eso hace que el resto o alguna clase deje de funcionar. También al final de linea el pon el ";" en todas las lineas inclusive la última, eso lo vi en todo tu CSS que no estaba el ;

Suerte
  #3 (permalink)  
Antiguo 06/05/2011, 13:00
 
Fecha de Ingreso: julio-2009
Ubicación: Córdoba
Mensajes: 20
Antigüedad: 8 años, 5 meses
Puntos: 0
Respuesta: No funciona mi CSS

Muchas gracias por la sugerencia, veré si funciona.
  #4 (permalink)  
Antiguo 06/05/2011, 20:12
 
Fecha de Ingreso: julio-2009
Ubicación: Córdoba
Mensajes: 20
Antigüedad: 8 años, 5 meses
Puntos: 0
Respuesta: No funciona mi CSS

El problema ya está resuelto, cuando intenté validar el código noté donde estaba el error de sintaxis. Igual muchas a los que entraron para ver si me podían ayudar. Estaría bueno que cierren el tema.

Etiquetas: attach, php
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:27.