Foros del Web » Creando para Internet » CSS »

No me funciona regla CSS sobre tag body

Estas en el tema de No me funciona regla CSS sobre tag body en el foro de CSS en Foros del Web. Ok llevo buen rato en esto asi que me atrevi a hacer esta pregunta tan imbecil... El hecho es que tengo que modificar cierta informacion ...
  #1 (permalink)  
Antiguo 04/01/2010, 01:21
Avatar de 1010011010  
Fecha de Ingreso: julio-2009
Ubicación: Xanadú
Mensajes: 58
Antigüedad: 8 años, 5 meses
Puntos: 1
Pregunta No me funciona regla CSS sobre tag body

Ok llevo buen rato en esto asi que me atrevi a hacer esta pregunta tan imbecil...

El hecho es que tengo que modificar cierta informacion a la primera y unica pagina que he vendido y quiero aprovechar para cambiarle un poco el diseño usando CSS para estructurarla...

llevo un mes estudiando varios tutoriales y hoy que me he decidido a poner la cosa en practica me encuentro con un problema realmente frustrante de lo tonto que es, de seguro que es alguna cosa tonta que no veo por novato pero señores tengo verdaderamente rato revisando los codigos que mas simples no podian ser y ya he vuelto a revisar mil veces manuales y paginas y no veo nada mal...

tengo un archivo index.html donde estoy comenzando a estructurar lo que va a ser el sitio cuyo contenido ya tengo creado. Lo tengo vinculado a un archivo CSS externo como dios manda y todos los nombres de archivo estan bien, todas las etiquetas parecen estar bien en sintaxis, pero haga lo que haga en cualquier explorador no logro que me tome el color de fondo el body :-p

Si ya se diran... toda esta chachara por eso??? pero es que realmente no veo el error :( aqui los codigos de ambos archivos....

index.html
Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Soldatecni - Home</title>
    <link href="estilos.css" rel="stylesheet" type="text/css" media="screen" />
</head>

<body>

<!-- WRAPPER  -->
<div id="wrapper">

<!-- HEADER  -->
<div id="header">
    H
</div>


<!-- MENU  -->
<div id="menu">
    M
</div>


<!-- CONTENT  -->
<div id="content">
    <p>C </p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>C</p>
</div>


<!-- FOOTER  -->
<div id="footer">
    F
</div></div><!-- FIN DE WRAPPER -->

</body>
</html>
estilos.css
Código:
@charset "utf-8";
/* CSS Document */
* { margin : 0 ; padding : 0 ; }

/* ##########################    WRAPPER    ########################## */
#wrapper {
    background-color : black;    
    width : 800px ; 
    margin : 10px auto ;
}

/* ##########################    HEADER    ########################## */
#header {
    background-color : red;
    margin : 5px ;
}

/* ##########################    MENU    ########################## */
#menu {
    background-color : purple;
    margin : 5px ;
}

/* ##########################    CONTENT    ########################## */
#content {
    background-color : grey;
    margin : 5px ;
}


/* ##########################    FOOTER    ########################## */
#footer {
    background-color : pink;
    margin : 5px ;
}

/* HTML's */
html { height : 101% } ;

body {
    color : orange ;
    font-family : Calibri, Verdana, Arial, Helvetica, sans-serif ;
    font-size : small ;
    background-color : green ;
}

h1 { font-size : 150% ; margin-bottom : 1em ; font-weight : bold; }
h2 { font-size : 130% ; margin-bottom : 1em ; font-weight : bold; }
h3 { font-size : 100% ; margin-bottom : 1em ; font-weight : bold; }
Eso lo redacte con Dreamweaver CS4 y estoy probando con "Firefox 3.5.6" e "IE 8" en ambos exploradores tengo el mismo inconveniente...

Cabe destacar que si se esta vinculando el archivo estilos.css porque todas las demas reglas que defini estan funcionando a cabalidad.... es unicamente con el tag body que no me toma el color de fondo....

Disculpen este tipo de preguntas pero de verdad que llevo rato en esto y nada que doy con el porque...
  #2 (permalink)  
Antiguo 04/01/2010, 03:59
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Respuesta: No me funciona regla CSS sobre tag body

Hola 1010011010

mira, se te ha escapado un punto y coma (;) fuera de sitio que invalida lo que va detrás

Código:
/* HTML's */
html { height : 101% } ; 
si lo mueves dentro de la llave, o simplemente lo quitas ya furula el resto
__________________
Javascript Códigos - Bambú difunde
  #3 (permalink)  
Antiguo 04/01/2010, 09:11
 
Fecha de Ingreso: agosto-2008
Mensajes: 469
Antigüedad: 9 años, 3 meses
Puntos: 20
Respuesta: No me funciona regla CSS sobre tag body

Hola 1010011010, con lo que comenta tunait el problema se solventa. También te aconsejaría que al poner los colores uses notación hexadecimal.

Por ultimo, firebug o webdeveloper, que son plugins para firefox, te pueden ahorrar muchos quebraderos de cabeza.

Saludos¡¡
__________________
Revisa las FAQ's antes de disparar.
  #4 (permalink)  
Antiguo 04/01/2010, 09:54
Avatar de 1010011010  
Fecha de Ingreso: julio-2009
Ubicación: Xanadú
Mensajes: 58
Antigüedad: 8 años, 5 meses
Puntos: 1
De acuerdo Respuesta: No me funciona regla CSS sobre tag body

Bloody hell!!!!!!!! que pena vale

Weno me imaginaba que era algo tonto como eso pero que verguenza haber creado un tema por un error como ese

Weno gracias a ambos pues ciertamente ese era el problema, y eso que leia y releia caracter por caracter pero weno me imagino que la hora tuvo que ver en el asunto pues eran como las 3 de la mañana cuando andaba en eso xD

pues nada muchas gracias por tomarse un tiempo para ayudar a noveles como yo

El web developer ya lo he ido probando y ciertamente es buen consejo aunque la interfaz y mas especificamente la vista de diseño del dreamweaver CS4 esta tan mejorada que creo que poco van haciendo falta ultimamente estas utilidades, pero si la he usado y ciertamente es muy util...

Sin embargo para los CSS le voy a seguir el consejo a un amigo que me recomendo el Expression Web de Mocosoft... que tiene señalacion de errores CSS asi como lo hace "word"

Pues nada, mil gracias de nuevo y nos estamos leyendo

EDIT: ahh.. y lo de los colores tambien es buen consejo, pero solo habia puesto esos valores para hacer pruebas y tener un buen contraste de tonos... :p
  #5 (permalink)  
Antiguo 04/01/2010, 11:05
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: No me funciona regla CSS sobre tag body

Para otra ocasión que algo no te vaya bien te aconsejo el validador de css
__________________
No diseñes usando tablas.
  #6 (permalink)  
Antiguo 04/01/2010, 11:51
Avatar de tunait
Moderadora
 
Fecha de Ingreso: agosto-2001
Ubicación: Terok Nor
Mensajes: 16.805
Antigüedad: 16 años, 3 meses
Puntos: 380
Respuesta: No me funciona regla CSS sobre tag body

Cita:
Iniciado por 1010011010 Ver Mensaje
Bloody hell!!!!!!!! que pena vale

Weno me imaginaba que era algo tonto como eso pero que verguenza haber creado un tema por un error como ese
Ná, todos hemos pasado por ahí, es zona segura que hay que pisar luego se pillan más rápido y pronto te sonará la frase "hay que ver cómo se pone por un punto y coma de m***da"
__________________
Javascript Códigos - Bambú difunde
  #7 (permalink)  
Antiguo 04/01/2010, 14:28
Avatar de 1010011010  
Fecha de Ingreso: julio-2009
Ubicación: Xanadú
Mensajes: 58
Antigüedad: 8 años, 5 meses
Puntos: 1
De acuerdo Respuesta: No me funciona regla CSS sobre tag body

Pues gracias de nuevo por esas palabras y consejos... definitivamente no me equivoque cuando pense en registrarme aquí... gracias ;)

Etiquetas: body, regla, tag
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:00.