Foros del Web » Creando para Internet » CSS »

no muestra imagen de fondo

Estas en el tema de no muestra imagen de fondo en el foro de CSS en Foros del Web. en el archivo donde estoy aplicando el diseño de css (archivo .css) tengo en el head esto: Código: <link rel="stylesheet" href="http://serv/css/css_gral.css" TYPE="text/css"> donde css_gral.css es ...
  #1 (permalink)  
Antiguo 28/10/2008, 11:19
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
no muestra imagen de fondo

en el archivo donde estoy aplicando el diseño de css (archivo .css) tengo en el head esto:

Código:
<link rel="stylesheet" href="http://serv/css/css_gral.css" TYPE="text/css">
donde css_gral.css es mi archivo de css

en ese archivo tengo esto:

Código:
.table_login_1 {
	background-image: url(../img/bg_login_form.jpg);
	border: 0px;
	font-family: Trebuchet MS, "Arial", serif;
	font-weight: bold;
	color: #CC3300;
}
donde .table_login_1 quiero que sea la clase (diseño) para mis tablas de "logeo" nose si aqui esta el problema, ustedes diganme.

en la pagina tengo lo siguiente:

Código:
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<link rel="stylesheet" href="http://serv/css/css_gral.css" TYPE="text/css">
</head>

<body bgcolor="#333333">

<table cellpadding="0" cellspacing="0" width="293" class="table_login_1">
	<!-- MSTableType="layout" -->
	<tr>
		<td height="216">&nbsp;</td>
	</tr>
</table>

</body>

</html>
todo carga bien, tipo de letras, colores, todo, hasta la imagen de fondo que tengo en el "body" (mi archivo css define tambien para el body y otras cosas) pero lo unico que no logro hacer es que esa tabla tome la imagen de fondo que estoy definiendo en el codigo css que puse anteriormente

por favor ayudenme, me urge, gracias!

(*corregido lo de serv y net)

Última edición por Mcruzmx; 28/10/2008 a las 11:39
  #2 (permalink)  
Antiguo 28/10/2008, 11:31
Avatar de talmente  
Fecha de Ingreso: noviembre-2007
Mensajes: 233
Antigüedad: 10 años
Puntos: 4
Respuesta: no muestra imagen de fondo

Prueba a poner una ruta absoluta a la imagen
  #3 (permalink)  
Antiguo 28/10/2008, 11:32
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: no muestra imagen de fondo

¿Cuál es la ruta correcta hasta la css? La que pones la primera:

http://serv/css/css_gral.css

o la segunda:

http://net/css/css_gral.css

En cualquier caso, ¿es seguro que tienes una carpeta img al mismo nivel que la carpeta css, y dentro de ella la imagen?
__________________
Visita mi nueva web idplus.org
  #4 (permalink)  
Antiguo 28/10/2008, 11:34
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
Respuesta: no muestra imagen de fondo

changos, en realidad la segunda es ke para el ejemplo hiba a cambiar net por serv pero se me olvido, pero en "teoria" ambas representan la misma direccion disculpen por no aclararlo, sigo con el problema
  #5 (permalink)  
Antiguo 28/10/2008, 11:36
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
Respuesta: no muestra imagen de fondo

los archivos estan asi

--servidor
----css (carpeta de archivos css)
----scd (carpeta de archivos que tambien uso con css)
------index.php (un archivo donde estare usando css tambien)
----img (carpeta de imagenes)
----login.php (archivo donde intento usar el css)

(intento hacer un arbol de los archivos ojala y se entienda :S )

notese que en cualquier nivel de las carpetas tengo el problema :S
  #6 (permalink)  
Antiguo 28/10/2008, 11:40
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: no muestra imagen de fondo

El único error que veo es que esto está al revés:

font-family: Trebuchet MS, "Arial", serif;

La que debe ir entrecomillada es la que tiene el nombre compuesto.

font-family: "Trebuchet MS", Arial, serif;
__________________
Visita mi nueva web idplus.org
  #7 (permalink)  
Antiguo 28/10/2008, 11:47
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
Respuesta: no muestra imagen de fondo

bueno gracias mikmoro pero no tengo actualmente ningun problema con fuentes o colores, tengo un problema con mostrar la imagen de fondo, nose por que, uso IE7 y FrontPage 2003, si el codigo esta bien, deberia funcionar sea cual sea el editor que use, lo que me hace pensar es que podria ser incompatibilidad de IE7 pero nose, podria alguien probar el codigo que di y ver si a ustedes les funciona o bien compartir alguno que hayan hecho que funcione (tabla con imagen de fondo con css) y asi yo poderlo probar y decirles si me funciona? gracias.
  #8 (permalink)  
Antiguo 28/10/2008, 11:53
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
Respuesta: no muestra imagen de fondo

compañeros, gracias por la ayuda, fue mi error, chale, la imagen estaba en otra carpeta img

--servidor
----css (carpeta de archivos css)
----scd (carpeta de archivos que tambien uso con css)
------img (carpeta de imagenes para los archivos dentro de esta carpeta, aqui estaba la imagen de fondo)
------index.php (un archivo donde estare usando css tambien)
----img (carpeta de imagenes aqui buscaba la imagen y obio que no estaba aqui)
----login.php (archivo donde intento usar el css)

changos, novatie horrible, siento mucha verguenza jeje, pero gracias por su apreciable ayuda, saludos :)
  #9 (permalink)  
Antiguo 28/10/2008, 11:55
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: no muestra imagen de fondo

No digo que tengas ningún problema con las fuentes, pero un error en un selector puede dar al traste con todo el selector entero

El resto de tu código es correcto, y debería funcionar si el código está como lo has mostrado, la estructura de carpetas es como la has puesto y la imagen existe o se llama exactamente así.

Comprueba también que el nombre es exacto en cuanto a mayúsculas y minúsculas.

EDITO: escribía esto mientras tu ya publicabas que lo has solucionado.
__________________
Visita mi nueva web idplus.org
  #10 (permalink)  
Antiguo 28/10/2008, 12:24
Avatar de Mcruzmx  
Fecha de Ingreso: abril-2006
Mensajes: 357
Antigüedad: 11 años, 8 meses
Puntos: 9
Respuesta: no muestra imagen de fondo

muchas gracias mikmoro :) y todos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:10.