Foros del Web » Creando para Internet » CSS »

no me quita el text-decoration en imagen

Estas en el tema de no me quita el text-decoration en imagen en el foro de CSS en Foros del Web. Hola, tengo en mi web un logo, el cual es un enlace hacia el index.html de la página, pero quiero que al pasar el mouse ...
  #1 (permalink)  
Antiguo 28/10/2004, 23:35
Avatar de jesusbet
(Desactivado)
 
Fecha de Ingreso: mayo-2004
Ubicación: Monterrey, MX
Mensajes: 2.667
Antigüedad: 13 años, 7 meses
Puntos: 2
no me quita el text-decoration en imagen

Hola, tengo en mi web un logo, el cual es un enlace hacia el index.html de la página, pero quiero que al pasar el mouse sobre dicha imagen no me ponga el odioso text-decoration: underline (o que me lo subraye pues), en miarroba no había tenido problema, pero ahora ya no puedo, miren: http://jesusbet.hollosite.com si pueden ver ahí al pasar el mouse sobre cada imagen, me subraya la imagen.

si ven el código fuente, pueden ver que está en una capa #logo, y en la css tengo esto:
#logo { /* CAPA LOGO */
left: 10px;
position: absolute;
top: 5px;
background-color: #FFFFFF;
text-decoration: none;
width: 27%;
}

obvio que eso es para la capa, para la/s imagen/es con enlace tengo esto:
a:hover {
color: #FFFFFF;
background-color: #004080;
text-decoration: none;
}

a img {
border-style: none;
border-width: 0;
text-decoration: none;
background-color: #FFFFFF;
}

a img:hover{
text-decoration: none;
}

y varias combinaciones mas para quitar el subrayado, pero no me sale
  #2 (permalink)  
Antiguo 29/10/2004, 00:07
n2h
 
Fecha de Ingreso: octubre-2004
Mensajes: 163
Antigüedad: 13 años, 1 mes
Puntos: 0
que no es al reves?

img a { /* primero la etiqueta, y luego la propiedad */
border-style: none;
border-width: 0;
text-decoration: none;
background-color: #FFFFFF;
}

img a:hover { /* idem q antes */
text-decoration: none;
}
  #3 (permalink)  
Antiguo 29/10/2004, 00:15
Avatar de jesusbet
(Desactivado)
 
Fecha de Ingreso: mayo-2004
Ubicación: Monterrey, MX
Mensajes: 2.667
Antigüedad: 13 años, 7 meses
Puntos: 2
voy a probar, gracias ;)
  #4 (permalink)  
Antiguo 29/10/2004, 05:45
 
Fecha de Ingreso: agosto-2003
Mensajes: 499
Antigüedad: 14 años, 4 meses
Puntos: 1
no es eso, en realidad no hay subrayado, es el color de fondo que aparece al hover por causa de esta regla :
a:hover {
color: #FFFFFF;
background-color: #004080;
text-decoration: none;
}

Quita el background-color y funcionara. Eso pasa porque las imagenes son elementos inline alineados en la linea de base (vertical-align:baseline), puedes jugar con el verticla align, le line-height o cambiarles el display a block para que no haya problemas con el color de fondo.
__________________
Plaza Mozilla
http://www.chevrel.org/es/noticias/
  #5 (permalink)  
Antiguo 29/10/2004, 10:47
Avatar de jesusbet
(Desactivado)
 
Fecha de Ingreso: mayo-2004
Ubicación: Monterrey, MX
Mensajes: 2.667
Antigüedad: 13 años, 7 meses
Puntos: 2
aaaaahhh... es cierto... gracias man, eres un master
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:06.