Foros del Web » Creando para Internet » CSS »

No se ven mis imagenes en ie

Estas en el tema de No se ven mis imagenes en ie en el foro de CSS en Foros del Web. Hola ante todo muchas gracias desde ya (pues se que encontraré ayuda). Mi problema es el siguiente : Resulta que estoy diseñando una Web con ...
  #1 (permalink)  
Antiguo 14/05/2009, 09:53
Avatar de RonaldNet  
Fecha de Ingreso: mayo-2009
Mensajes: 31
Antigüedad: 8 años, 7 meses
Puntos: 0
No se ven mis imagenes en ie

Hola ante todo muchas gracias desde ya (pues se que encontraré ayuda).
Mi problema es el siguiente:
Resulta que estoy diseñando una Web con PHP y MySql y tengo una tabla "productos" de la cual voy mostrando los datos de los productos que se eligan al hacer clic en un enlace, y todo sale de maravilla en todos los navegadores menos en el "buen" IE , solo me muestra una linea en la capa contenedora de la imagen. No se si saben de algún truco (hack) con css para resolverlo.. pls
nuevamente gracias...
PDT: Si necesitan el codigo lo publicaré...
  #2 (permalink)  
Antiguo 14/05/2009, 09:55
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: No se ven mis imagenes en ie

Es conveniente que nos muestres el código para poder reproducir el problema (el de la imagen y el estilo que tiene). O en su defecto un enlace a la página.

Saludos.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 14/05/2009, 10:16
Avatar de RonaldNet  
Fecha de Ingreso: mayo-2009
Mensajes: 31
Antigüedad: 8 años, 7 meses
Puntos: 0
Respuesta: No se ven mis imagenes en ie

Gracias y aqui está el código:
Código codigo:
Ver original
  1. <div class="grid_4 omega" id="izquierdaX">
  2. ......... si el usuario hace clic en el enlace muestra la imagen
  3.         if ($nfilas == 1)
  4.         {
  5.             $resultado = mysql_fetch_array ($consulta);
  6.             echo '<img src="../img/'.$resultado['imagen_producto'].'" width="350" height="auto" border="1"></img>';
  7.         }
  8. ....................
  9. </div>
y aqui está el estilo de esa capa:
Código:
#izquierdaX{
  	margin-left: 30px;
  	margin-top: 30px;
	width: 350px;
	height: auto;
	padding-left: 0px;
	padding-right: 0px;
}
ahh tambien estoy trabajano con un frameworck para css 960grid para Grid_4 con un container_16.
Asi tal y como está sale vien nomas en mozilla, opera, safari, menos en IE7
pls ayuda
  #4 (permalink)  
Antiguo 15/05/2009, 14:01
Avatar de RonaldNet  
Fecha de Ingreso: mayo-2009
Mensajes: 31
Antigüedad: 8 años, 7 meses
Puntos: 0
Respuesta: No se ven mis imagenes en ie

Logre solucionarlo, aunque talvez es algo tonto; lo que sucede solamente borre esta parte al código: height="auto" y ya muestra mis imagenes a la perfección creo que IE no sabia como interpretar esa instrucción...
  #5 (permalink)  
Antiguo 15/05/2009, 14:12
 
Fecha de Ingreso: diciembre-2007
Ubicación: Valencia
Mensajes: 113
Antigüedad: 10 años
Puntos: 1
Respuesta: No se ven mis imagenes en ie

Cita:
Iniciado por RonaldNet Ver Mensaje
Logre solucionarlo, aunque talvez es algo tonto; lo que sucede solamente borre esta parte al código: height="auto" y ya muestra mis imagenes a la perfección creo que IE no sabia como interpretar esa instrucción...
Claro1 esque internet explorer toma los datos del margin, padding height y width ta l y como deben ser no como firefox!
  #6 (permalink)  
Antiguo 15/05/2009, 15:03
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: No se ven mis imagenes en ie

Cita:
Iniciado por juanpons14 Ver Mensaje
Claro1 esque internet explorer toma los datos del margin, padding height y width ta l y como deben ser no como firefox!

¿no será al revés?
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #7 (permalink)  
Antiguo 15/05/2009, 15:18
Avatar de RonaldNet  
Fecha de Ingreso: mayo-2009
Mensajes: 31
Antigüedad: 8 años, 7 meses
Puntos: 0
De acuerdo Respuesta: No se ven mis imagenes en ie

me parece que kseso tiene razón pues en algun lado lei que IE no respeta los Estandares Web W3C para nada...
  #8 (permalink)  
Antiguo 16/05/2009, 06:03
 
Fecha de Ingreso: diciembre-2007
Ubicación: Valencia
Mensajes: 113
Antigüedad: 10 años
Puntos: 1
Respuesta: No se ven mis imagenes en ie

Cita:
Iniciado por kseso? Ver Mensaje

¿no será al revés?
Puede que me haya equivocado...jaja perdon! :P
  #9 (permalink)  
Antiguo 16/05/2009, 15:23
Avatar de arthpix  
Fecha de Ingreso: diciembre-2003
Ubicación: Cancún
Mensajes: 2.340
Antigüedad: 14 años
Puntos: 93
Respuesta: No se ven mis imagenes en ie

Cita:
Iniciado por juanpons14 Ver Mensaje
Puede que me haya equivocado...jaja perdon! :P
O te faltó la etiqueta [SARCASMO] [/SARCASMO]
__________________
Antes de hacer rabietas infórmate: Linux != Windows
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:14.