Foros del Web » Creando para Internet » CSS »

Padding y border-spacing que no funcionan

Estas en el tema de Padding y border-spacing que no funcionan en el foro de CSS en Foros del Web. Bueno, estoy haciendo una web personal y, como me urge terminarla pronto, no me puedo poner a experimentar con divs, así que estoy usando tablas, ...
  #1 (permalink)  
Antiguo 06/10/2008, 17:05
 
Fecha de Ingreso: marzo-2008
Mensajes: 207
Antigüedad: 9 años, 9 meses
Puntos: 0
Padding y border-spacing que no funcionan

Bueno, estoy haciendo una web personal y, como me urge terminarla pronto, no me puedo poner a experimentar con divs, así que estoy usando tablas, que es lo que mejor se me da (de momento). La cosa es que todas mis tablas y celdas tienen como atributos en la hoja de estilos lo siguiente, para eliminar cualquier posible margen que pueda aparecer:

Código HTML:
<style>
.estilo {
  padding: 0px; 
  border: 0px solid;
  border-spacing: 0px;
  border-collapse: collapse;
}
</style> 
Todas las tablas y celdas me pillan bien la configuración de estos atributos, pero una en concreto, no lo hace, y para que no me genere márgenes, no me deja otra que usar los atributos cellpadding y cellspacing directamente dentro de la etiqueta de <table>, pero no me gusta implantar así los estilos, soy más de hoja de estilos. De todas formas, con esto tengo el problema solucionado. Validando la página como xhtml transitional va perfectamente, e incluso se valida correctamente como xhtml strict, el problema es que como strict, en firefox y safari, el cellpadding y el cellspacing no funcionan, y se me descuadra la página...

¿Alguna idea de por qué esa tabla no me pilla el estilo asignado? Pensé que podría ser por el nombre, y se lo cambié (al estilo), pero tampoco. También he probado a crear un estilo sobre el identificador de la tabla, pero tampoco lo coge... ¿Alguien sabe que rayos le pasa?

Dejo el link de la página (es sólo una plantilla en html que montaré en php cuando la termine)

http://www.abtu.net/inb/pruebas/laninadeloscupones

Gracias por adelantado ;)

PD: La tabla que no me coge el estilo es la que usa el estilo "tabla_recuadro_cuerpo" (<table class="tabla_recuadro_cuerpo">), en la línea 86.
  #2 (permalink)  
Antiguo 31/10/2009, 16:48
Avatar de jjyepez  
Fecha de Ingreso: abril-2009
Mensajes: 8
Antigüedad: 8 años, 7 meses
Puntos: 0
Respuesta: Padding y border-spacing que no funcionan

Hola masane,
Creo que encontré la razón del problema y lo que es mejor aún ... la solución!

Aplica la clase ".estilo" a los <td> de la tabla que presentan el problema y voilà!! ....
Cuando usas un <div> dentro de la celda con ciertas propiedades pues pareciera darse el comportamiento extraño, pero de esta forma lo corriges.

Espero que te funcione tan bien como a mí.

Éxito!
--
jjyepez
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:28.