Foros del Web » Creando para Internet » CSS »

Problema al cargar los CSS

Estas en el tema de Problema al cargar los CSS en el foro de CSS en Foros del Web. Hola a todos, tengo creado un proyecto web en netbeans. Dentro de la carpeta web-inf he creado una carpeta llamada Styles donde pongo mis css. ...
  #1 (permalink)  
Antiguo 20/07/2011, 03:32
 
Fecha de Ingreso: julio-2011
Mensajes: 14
Antigüedad: 5 años, 10 meses
Puntos: 0
Problema al cargar los CSS

Hola a todos, tengo creado un proyecto web en netbeans. Dentro de la carpeta web-inf he creado una carpeta llamada Styles donde pongo mis css. Tambien tengo dentro de web-inf una carpeta llamada Jsp donde tengo las jsp. El problema es que cuando ejecuto la aplicación en el servidor no me aplica la hoja de estilos, el servidor es apache tomcat 7.0. He probado con varias rutas relativas pero en principio creo que la correcta sería la siguiente: ../Styles/Style.css

¿Debo usar href o import?

Gracias por vuestra ayuda.

Un saludo.
  #2 (permalink)  
Antiguo 20/07/2011, 03:50
Avatar de vgonga1986  
Fecha de Ingreso: marzo-2008
Ubicación: País de Pandereta
Mensajes: 1.021
Antigüedad: 9 años, 2 meses
Puntos: 252
Respuesta: Problema al cargar los CSS

Tienes que utilizar el tag <style/> dentro de la cabecera, más o menos sería así:

<link rel="StyleSheet" type="text/css" href="../Styles/Style.css" />

Espero que te sirva, un saludo.
__________________
¿Alguna pregunta, duda, acotación, nota, cuestión, reparo, comentario, demanda, crítica, interpretación, objeción, interrogante, discrepancia, observación, réplica, disquisición, apostilla o exégesis?
  #3 (permalink)  
Antiguo 20/07/2011, 03:53
 
Fecha de Ingreso: julio-2011
Mensajes: 14
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: Problema al cargar los CSS

Habia leido que habia que utilizar el import porque no crea una referencia como el href, pero no estoy muy enterado de este tema. Con <syle... ¿funciona en todos los navegadores?
  #4 (permalink)  
Antiguo 20/07/2011, 04:00
Avatar de vgonga1986  
Fecha de Ingreso: marzo-2008
Ubicación: País de Pandereta
Mensajes: 1.021
Antigüedad: 9 años, 2 meses
Puntos: 252
Respuesta: Problema al cargar los CSS

Claro.

Un saludo.
__________________
¿Alguna pregunta, duda, acotación, nota, cuestión, reparo, comentario, demanda, crítica, interpretación, objeción, interrogante, discrepancia, observación, réplica, disquisición, apostilla o exégesis?
  #5 (permalink)  
Antiguo 20/07/2011, 04:04
 
Fecha de Ingreso: julio-2011
Mensajes: 14
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: Problema al cargar los CSS

Pero en tu respuesta de mas arriba no veo el tag <style>... perdona pero soy novato en esto.

Gracias por tu ayuda.

Un saludo.
  #6 (permalink)  
Antiguo 20/07/2011, 04:54
Avatar de vgonga1986  
Fecha de Ingreso: marzo-2008
Ubicación: País de Pandereta
Mensajes: 1.021
Antigüedad: 9 años, 2 meses
Puntos: 252
Respuesta: Problema al cargar los CSS

Perdón, fallo mío, no quería poner style, quería poner link. <style> es para definir directamente en el html los estilos, <link/> es para enlazar con otro fichero. Lo siente, se me fue el santo al cielo.

Un saludo
__________________
¿Alguna pregunta, duda, acotación, nota, cuestión, reparo, comentario, demanda, crítica, interpretación, objeción, interrogante, discrepancia, observación, réplica, disquisición, apostilla o exégesis?
  #7 (permalink)  
Antiguo 20/07/2011, 05:06
 
Fecha de Ingreso: julio-2011
Mensajes: 14
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: Problema al cargar los CSS

Ok no pasa nada..xD... Muchas gracias lo probaré y a ver si soluciono el problema.

Un saludo.
  #8 (permalink)  
Antiguo 20/07/2011, 16:58
 
Fecha de Ingreso: julio-2011
Mensajes: 14
Antigüedad: 5 años, 10 meses
Puntos: 0
Respuesta: Problema al cargar los CSS

Sigue sin cogerme las CSS, tengo puesto lo siguiente en la pagina jsp.

<link rel="StyleSheet" type="text/css" href="../Styles/Style.css" media="all"/>

la estructura de directorios es la siguiente:

WEB-INF
--jsp
--Styles

ejecuto la aplicacion desde netbeans sobre apache tomcat 7.0

Un saludo
  #9 (permalink)  
Antiguo 02/11/2011, 11:37
 
Fecha de Ingreso: febrero-2008
Mensajes: 42
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: Problema al cargar los CSS

Buenas, Tengo el mismo problema.. pudiste resolverlo??

Etiquetas: netbeans, tomcat
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:01.