Foros del Web » Creando para Internet » CSS »

Problema cn CSS

Estas en el tema de Problema cn CSS en el foro de CSS en Foros del Web. Estimados: Tengo el siguiente codigo: Código PHP: . menuItem  {      vertical - align :  middle ;      background - image : url ( images ...
  #1 (permalink)  
Antiguo 11/06/2008, 09:36
 
Fecha de Ingreso: diciembre-2004
Mensajes: 354
Antigüedad: 13 años
Puntos: 0
Problema cn CSS

Estimados:

Tengo el siguiente codigo:

Código PHP:
.menuItem {
    
vertical-alignmiddle;
    
background-image:url(images/mnuMiddle.jpg);
    
background-position:left;
    
background-repeat:no-repeat;
    
border-top:1px solid white;
    
border-bottom:1px solid #B0B0B0;
    
width:150px;
}
.
menuItem a:link, .menuItem a:active, .menuItem a:visited {
    
color:#333333;
    
display:block;
    
padding:3px 0 3px 10px;
    
width:150px;
    
text-decoration:none;
    
font-familyGenevaArialHelveticasans-serif;
    
font-sizexx-small;
}
.
menuItem a:hover {
    
vertical-alignmiddle;
    
background-repeat:no-repeat;
    
color:#FFFFFF;
    
display:block;
    
padding:3px 0px 3px 10px;
    
text-decoration:none;
    
font-familyGenevaArialHelveticasans-serif;
    
font-sizexx-small;
    
background-image:url(images/mnuMiddle_f2.jpg);


Y resulta que en Firefox se ve perfecto, pero en IExplore al poner el mouse encima del link, ese fondo se muestra con 10px menos hacia la izquierda.

Que será?
__________________
Pedro Pablo Vivanco D.
Webmaster todoalbo.cl
[email protected]
http://www.todoalbo.cl
"Dios creo el Cielo, Colo-Colo le puso todas sus Estrellas"
  #2 (permalink)  
Antiguo 11/06/2008, 17:34
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema cn CSS

No sé si tendrá algo que ver, pero tienes un pequeño error en este selector:

.menuItem a:link, .menuItem a:active, .menuItem a:visited

el orden correcto debe ser

- link - visited - active

es decir:

.menuItem a:link, .menuItem a:visited, .menuItem a:active

Mikel.
  #3 (permalink)  
Antiguo 11/06/2008, 18:06
Avatar de MasterXNicoX  
Fecha de Ingreso: junio-2008
Ubicación: ../Arg/SanLuis.city
Mensajes: 943
Antigüedad: 9 años, 6 meses
Puntos: 28
Respuesta: Problema cn CSS

Bueno, perdon Mikel que te contradiga, pero eso, No tiene que ver :P
------------------------------------------------------------------------------------------
Todoalbo, en Iexplorer siempre se desentran un poco las cosas..

No se cual es la magnitud exactamente del error en tu web, no podrias poner la url, o bien una imagen para que veamos mejor el error ??..

Un Abrazo :)
  #4 (permalink)  
Antiguo 11/06/2008, 18:24
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema cn CSS

No, no me contradices; había puesto "No sé si tendrá algo que ver". Al ver ese error no me he puesto a mirar más hasta que fuera corregido.

Ahora lo he mirado, y quizá sea que falta el background-position:left; en el :hover.

Mikel.
  #5 (permalink)  
Antiguo 11/06/2008, 20:22
 
Fecha de Ingreso: diciembre-2004
Mensajes: 354
Antigüedad: 13 años
Puntos: 0
Respuesta: Problema cn CSS

http://www.todoalbo.cl en el menu de la izquierda esta el error.
__________________
Pedro Pablo Vivanco D.
Webmaster todoalbo.cl
[email protected]
http://www.todoalbo.cl
"Dios creo el Cielo, Colo-Colo le puso todas sus Estrellas"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:35.