Foros del Web » Creando para Internet » CSS »

problema con background-image

Estas en el tema de problema con background-image en el foro de CSS en Foros del Web. Hola a todos, tengo un problemita con esto del background-image tengo en mi hoja de estilo lo siguiente: BODY { BACKGROUND-IMAGE: url(images/background.gif); MARGIN: 0px } ...
  #1 (permalink)  
Antiguo 10/06/2005, 10:32
Avatar de Tarecito  
Fecha de Ingreso: noviembre-2003
Ubicación: Lima - Perú
Mensajes: 443
Antigüedad: 14 años
Puntos: 1
Pregunta problema con background-image

Hola a todos, tengo un problemita con esto del background-image

tengo en mi hoja de estilo lo siguiente:

BODY {
BACKGROUND-IMAGE: url(images/background.gif); MARGIN: 0px
}
.
.
.
.

y en mi página asp llamo a la hoja de estilo. Se q lo está llamando bien xq si está aplicando los estilos a todos los demás elementos... menos al cochino Body. No entiendo q puede estar pasando, la ruta está bien, el nombre del archivo también, la llamada al archivo .css también ... alguien podría ayudarme con esto x favor??
__________________
Tarecito
  #2 (permalink)  
Antiguo 10/06/2005, 11:08
 
Fecha de Ingreso: enero-2005
Mensajes: 188
Antigüedad: 12 años, 10 meses
Puntos: 0
Mmmm... no sé, yo lo pondría así:

Código:
body {
background-image: url("images/background.gif");
margin: 0;
}
No se si afecta el que background-image esté en mayúsculas. Lo típico es escribirlo en minúsculas, y la URL entre comillas simples o dobles.
El margen o cualquier otra medida, si es 0, no se pone la unidad (px, em, pt...).
Prueba a ver, de todas formas, si la dirección del enlace está bien, yo creo que debería funcionar.
  #3 (permalink)  
Antiguo 10/06/2005, 11:20
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Creo que te equivocas al llamar URL

El codigo deberias ser:

BODY {
BACKGROUND-IMAGE: images/background.gif; MARGIN: 0px
}

en vez de:

BODY {
BACKGROUND-IMAGE: url(images/background.gif); MARGIN: 0px
}
__________________
Al final del día hablar es gratis, codificar no lo es
  #4 (permalink)  
Antiguo 10/06/2005, 11:23
Avatar de baccxus  
Fecha de Ingreso: mayo-2005
Ubicación: Panama city, Panama, Panama
Mensajes: 870
Antigüedad: 12 años, 6 meses
Puntos: 17
Tambien puede que tu CSS esté guardada en un subdirectorio y no en el principal, entonces al llamar a la imagen lo hace en el subdirectorio en que estás, si es así, prueba con esto.

si algo nos avisas

body{
background-image: url(../images/bg_grad.jpg);
margin: 0px;
}
__________________
Al final del día hablar es gratis, codificar no lo es
  #5 (permalink)  
Antiguo 10/06/2005, 11:46
 
Fecha de Ingreso: enero-2005
Mensajes: 188
Antigüedad: 12 años, 10 meses
Puntos: 0
Esto no es correcto:
Cita:
Iniciado por baccxus
El codigo deberias ser:

BODY {
BACKGROUND-IMAGE: images/background.gif; MARGIN: 0px
}
En cambio, esto es muy probable que sea el problema:
Cita:
Iniciado por baccxus
Tambien puede que tu CSS esté guardada en un subdirectorio y no en el principa
Para más información sobre la sintaxis correcta:
http://www.w3.org/TR/1998/REC-CSS2-1...ckground-image
  #6 (permalink)  
Antiguo 10/06/2005, 22:53
Avatar de Tarecito  
Fecha de Ingreso: noviembre-2003
Ubicación: Lima - Perú
Mensajes: 443
Antigüedad: 14 años
Puntos: 1
holas, pues el problema era ese del directorio donde guardaba el css, lo solucioné poniendo: url(../images/bg_grad.jpg); ... gracias a todos
__________________
Tarecito
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:31.